Bypass OpenWrt login page (NGINX already requesting login)

Currently I'm using NGINX for the web login+password to the device.

However there's a double login: first, have to login with NGINX, then have to immediately login with OpenWrt.

Is there a way to bypass the OpenWrt login? Such as, merely deactivating it, or passing the NGINX credentials to OpenWrt so it thinks it's logged in already?

software versions?

Assuming you use nginx as reverse proxy in front of uhttpd, you need to pass-through the authentication http header, then LuCI will auto-logon. This assumes that username and password match your system credentials (root and SSH password). If not, you can adjust the login in /etc/config/rpcd


nginx -V
nginx version: nginx/1.17.7 (x86_64-pc-linux-gnu)
built with OpenSSL 1.1.1g 21 Apr 2020
TLS SNI support enabled

OpenWrt version is at 19.07.