Builds for Linksys WHW03 V2 + V1

Looks like it is not loading the partition on the NAND correctly, and cannot boot successfully.
It is not the first time someone has reported a similar situation.
Could you share your device hw version?
I'm afraid there is a difference with the versions I have and I'll need to create a new device model.

I do try to update from the official 21.02 branch from time to time, but latest release should work.
It might be related to @Nico1320 problem, can you provide a boot log?

Thanks for looking into this. Here is the link Log File

It's WHW03v2, I've tried to boot initramfs to no avail.

If the kernel still crashes loading from initram will not help.
If you have access to a shell on the Linksys firmware, by using the support password, you could get the device tree and I'd be able to work a identify the difference and build an image.

Unfortunately I returned the device already.

I have access to shell, but how do I exactly dump everything? I know dts-related files are in /proc/device-tree

got it! I used tftp and tar

@flipy I compiled and compared the device tree that @jms19 provided and it's basically the same as mine

Is there any guide I can check on how to convert the @flipy files to a .img that I can load using the /fwupdate.html URL from the Velop factory firmware? Or how to use the .bin files? Apologies for the newbie questions in advance. I have the Velop V1 WHW03 but do not have the background on how to use the builds.

You should flash *factory.bin for your hardware version. in your case;

I tried using the .bin file but get the error

Blockquote "result": "ErrorUnauthorized"

I am using the /fwupdate.html web based link available from the factory firmware. Is there a different method that allow the .bin file upload to the equipment?

@flipy good news! I've decided to try every build you ever made (initramfs) and found whw03v2- (Dec 11 2020) booted successfully!

That is actually very good news as I can refer to the DTS image I built at that time!

Adding a new build for V2 based on the DTS from

Hi flipy.
I'm new hier.
Your firmware require to open my velop and/or any specific cables or something like that ?
I never done this before
Is there any tutorial :wink: :wink:?

Hey flipy
Can I install via webui and if not how do I go about installing via tftp

install via http://routerip/fwupdate.html, or go into linksys webUI, click CA at the bottom of the page and install openwrt like any other linksys.

Not to say I have attempted to install it yet but just for future reference

Does it allow for mesh networking on the openwrt build