Building OpenWrt on centos7

am trying to build openWRT on CentOS7(64bits) by using command like make , but its giving error like

svn: /home/shwetha/openwrt/trunk/staging_dir/host/lib/ no version information available (required by /lib64/

I tried changing some configurations but its giving same error:

/home/shwetha/openwrt/trunk/staging_dir/host/lib/ no version information available (required by /lib64/ /lib64/ undefined reference to 'lzma_code@XZ_5.0' /lib64/ undefined reference to 'lzma_stream_decoder@XZ_5.0' /lib64/ undefined reference to 'lzma_end@XZ_5.0'



try it:

sudo yum -y install epel-release libevdev.x86_64 nfs-utils.x86_64 kmod-libs.x86_64 kernel.x86_64 kernel-headers.x86_64 kernel-devel.x86_64 && sudo yum update -y && reboot
sudo yum -y install subversion binutils bzip2 gcc gcc-c++ gawk gettext flex ncurses-devel zlib-devel zlib-static make patch unzip perl-ExtUtils-MakeMaker glibc glibc-devel glibc-static quilt ncurses-libs sed sdcc intltool sharutils bison wget git-core openssl-devel xz
sudo yum -y install libssh2-devel.x86_64 libssh2.x86_64 jansson.x86_64 jansson-devel.x86_64 xz-devel.x86_64 pyliblzma.x86_64

I installed Openwrt on Centos. Follow this link to installation goes well.

Hi, @Perser
Thanks for your suggestion