Build second time after make clean does not output sysupgrade.bin

Every time I build, after make menuconfig, I do not get a sysupgrade.bin file.
All I did is deselect kmod-mmc-spi.
make menuconfig shows a selected squashfs Target Image none else.
What am I doing wrong?

Can you provide the output of ./scripts/ from openwrt source root directory?

It's quite verbose so I pasted it here:
thanks for any hints...

I can not believe this is the only thing you did... :thinking:

As you are using the device Linkit Smart 7688, this device has about 30 MB flash and you have selected a lot of additional packages, i think the resulting image is to big for the target device.
Thats why no image is generated.

Well I truly tried several things to enable the build of the .bin again but I remember only to have disabled the mmc-spi kernel driver.

Disabling all packages that can be added later, it now builds successfully the sysupgrade.bin file again.

What is the reason that there is no error message?
If the build is checking for image size to match flash size it seems simple to add a message output...

There is an error message in the verbose build log, but the build does not stop for the "size too large" errors, as that would hurt in the buildbot where several routers are built at the same time.

In the verbose build log (if you have enabled that) it says like this:
Warning: /.../bin/ar71xx/openwrt-ar71xx-generic-dir-825-b1-squashfs-sysupgrade.bin is too big

You can grep the log for "is too big".

Can we add a script that checks the log in the end of the build sequence for all possible errors and give them out in a way that does not hurt buildbot?

I just realized that the package folder in openwrt/bin/targets/ramips/mt7x88/<package> is missing and the config.buildinfo as well. My sysupgrade.bin is now 31.2MB.
Why do those files/folders don't get build there anymore?

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.