Build OpenWrt for netgear R6800

I installed openwrt but my phone wasn't auto reconnecting to wifi anymore and my chromecast was invisible on the network after a few hours until a reboot.

I tried nmrpflash to put back the stock firmware but it kept complaining about bad memory blocks. In the end I was able to recover the router by resetting it via the physical reset button.

So far, the LED is not working properly, the wireless network will go wrong for up to 24 hours, and no device can find the signal.

I'm seeing the power LED on here, glowing orange; that looks fine. LAN1 shows a steady white, no difference whether there's traffic or not.

In the LED section, I see WAN + all four LAN LEDs defined, but when I hook up another device to e.g. LAN2 or LAN3, the related LEDs don't light up, despite the port becoming active (logread says so). Is this what you're seeing?

Edit: I noticed that, when a LAN port is active at boot, the LED will turn on; but if the client shuts down e.g. the LED will just stay on. Same if you unplug the cable. The LED state only gets refreshed at the next boot.

Yes, the led is a minor problem, now it disappears after a period of wifi, and it cannot be searched.

I flash the last version. I think the most important issue is the 5Ghz wifi, it's very weak.
LED is not very important. I hope to release a next version as soon as possible to solve the problem of weak 5GHz wifi signal. Thank you!

Could someone please share firmware which has upgrade to openwrt possible?

i tried 4 times upgrading via gui (fr; - it bricks.

1 Like

@yukunyi See here for an update on the LEDs:

@xkuza I recently flashed a recent master build without issues from stock, so you might want to try your hand at an early 21.02 image. You might need to rename it so it looks like a Netgear image filename (e.g. netgear-v2.0.1.img or something like that).


Is there any VLAN support on R6800?
I don't see the "Switch" menu entry under "Network"
I'm using openwrt 21.02.0-rc1


Just a basic success report for the R7450 (Walmart?) variant.

From a factory stock firmware (R7450_V1.2.0.88_1.0.1.img), I was able to install the openwrt-21.02.0-ramips-mt7621-netgear_r6800-squashfs-factory.img via the stock firmware's upgrade menu. I did have to rename the image file (to R7450_V1.img). Trying to use the OpenWrt factory image under the original name failed. For the renamed file, the stock firmware warned that it was a version downgrade; but it went ahead and let me install OpenWrt anyway.

I should also mention that I tested using the debrick tool (nmrpflash) before installing OpenWrt. It worked, but I did have to use the reset button rather then power cycling the router to get the timing right. This was using an Ubuntu 20.04 system as the host, so maybe power cycling the router would have worked with Windows.

As for functionality, I've only tested basic routing (lan to wan) as well as 5G WiFi to wan which all seems to work okay.

I have two of the R7450s and hope to use one as my primary wan to lan/wifi home router and the other one as a lan to wifi access point. Eventually using them as file servers for backup is another goal.

This topic was intended for adding support for this specific device.
Since official 21.02.0 images are available now, I will set a timer for this topic to close.


Because specific problems for this device with official releases are better handled in separate topics, in order to make finding relevant information easier.

Therefore: Please open new topics for any open issues with this device.

Thanks! :slight_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.