Build for WRT3200ACM (Discontinued)

@wrt1x00, you need to learn some etiquette. Unless it is your own thread, stay on topic. And even if it is on topic, don't spam with 20 posts in a row, with each one being insanely long, before anyone even responds. And they aren't even about lede or @cybrnook's builds.

This thread has alot of helpful info in it, plus @cybrnook is still posting the occasional build when something major changes, It wasn't dead, maybe it is now after you spamming it for 5 days with literally multiple dozens of screens worth of garbage,

I'm sorry.

Dude, make a point, I get it, but don't demoralize, I am under the impression we are all here to help each other.

Besides, while you are quite often very helpful, you are not always accurate either.


You could have recommend the user create a separate post for their issue without all the chastising.

i understand that cybrnook's build has USB support for the WRT3200ACM (LEDE stable doesn't recognize my external HDD and i'm looking to switch) but i want to know if any of these builds have a working DLNA server (like MiniDLNA) as i would like to stream from this disk.

Can someone clarify, and, in case that neither of these community builds has a DLNA server working, point me on the right track to build the packages myself?

How about just installing minidlna with opkg?
There is no need to have all packages included in the firmware itself. You can pretty freely install add-on packages to a running firmware.

Oh!, what a dumbfuck. I didn't update the repo list. Sorry :-/

New builds with latest driver/firmware and samabacry fix:




Thanks!, trying it out right now.

@cybrnook thanks for the time you put into providing these builds. The beta builds run great on my WRT1900ACSv2.

Just for your information: I am currently using LEDE stable on the same device, with a USB flash drive and a couple of HDDs attached. The USB flash drive is not recognized on boot if plugged in the USB 3.0 port; I have to plug it while the device is already running, or plug it on the USB 2.0 port. Other than that, everything works as expected.

Hi, can you please add fuse libs to kernel, since ntfs-3g cannot work without it and there's no way to install it as a package. I already reported this problem.

Hi, can you please add fuse libs to kernel, since ntfs-3g cannot work without it and there's no way to install it as a package. I already reported this problem.

This is not a problem, it is something you would like to use, reporting this as a problem is pretty rude here as no one has any responsibility to you considering these features...

Thanks for the update, read about the Samba exploit and really appreciate the update with the fix on that!
Even though the problem is pretty non existent when using Samba only in LAN (which should always happen for obvious reasons), cryptoware hopefully cannot do anything to Samba shares this way (where I highly doubt I will ever be vulnerable to since I never get viruses, but better safe than sorry). Use Samba pretty heavily on this Router, so nice to have it fixed.

Everything works perfect, running the stable build.

Hi, Koldur. It worked once, in the past builds. Required to install certain packages, but this is no longer works. Ntfs-3g can't communicate with fuse.
I have no problems to build lede from source for myself, which I actually did due to this issue, but I'd like to see such a popular build to have no such issues, that's why I report.
Davidc and others builds I tried work just fine.

New mwlwifi commits right after you build, and apparently a new lede version is starting tomorrow? Ah well I configured the latest snapshot build manually, good stuff.

Hi, Thanks for the insight, i was clearly missing some packages and didn't recognize the problem earlier. Sorry to bother. My USB 3 HDD worked out of the box on the corresponding USB 3 port on boot and there's no need to plug it in after the device boots.

I'm currently using latest @cybrnook build and everything works fine. (3200ACM)

Two questions:
Is there a concise set of instructions to build LEDE for the WRT3200ACM, or an addendum to regular image builder guide? I saw @cybrnook 's github fork referenced a few hundred posts ago, but it wasn't clear where I pull in the lasted mwlwifi source. Also, I've seen some discussion of using kernels ranging from 4.4.x to 4.9.x; any insight on the most appropriate would be useful.

Now that the driver is useful, what's the timeline and process for an official build?

My primary interest is getting a build with strongswan (IKEv2) support. At present I'm unable to install it because it has kernel dependencies which aren't met in @cybrnook 's build.

EDIT: It looks like the lede-v17.01.2 tag already has mwlwifi pinned to 36bc32767ed89e07c5c83036861d2fa4eb1f8629 from Jun 6, which should meet my needs. May have posted too soon. Still interested in understanding the path to an official build, and may have questions when I blow this thing up.

Should find everything to do your own build here. The mwlwifi readme explains how to get an update into your own build; the latest stable does have the latest driver, except what just came in, but that is just preparatory for kernels coming down the pipe.

Would suggest using the latest stable, get everything you want installed, then use the output of opkg list-installed to put together your own image using make menuconfig with everything baked in as described in the documentation. You can use the config.seed of an existing image to start, not necessarily going to buy you a lot though, but the how is also described in the documentation.

Hi all,

I have wrt1900ac v1 and tried image of @cybrnook from link few posts above, and my router reboots.

Then I tried latest Lede stable version 17.01.2 and after 20 min of full load (I mean 160 mbit of torrents over wireless plus iptv over wire plus several wireless devices), well after 20 min it reboots too.
I did fresh install with reset to defaults, no special settings.

Is my router broken? Why even stable 17.01.2 makes router to reboot?