Build for WRT3200ACM (Discontinued)

do not install the one from hnyman it made my WRT3200ACM to reboot. also how can i upgrade with out having to reinstall all the packages?

Does not appear to be unique to @hnyman build as my build on rango just did the same for me; wonder if this is in any way related to the mamba 4.9k experience.

It might be related to the wifi settings in use. I have otherwise rather vanilla settings except that I use ieee802.11r (but that is likely more on the hostapd side than the core wifi driver).

(And the extras included in my test build are the same as in my community builds for WNDR3700 and R7800. See those threads for info.)

Hi, interesting post! I always wondered, why SOC is running so high ~75C even on 100% idle! Thanks to your posts I understood proper CPU idle is disabled. What a shame.

Have you tried to enable it on latest kernel? Maybe it's time to test after 2 years of development? I wish I will be able to build Lede for myself to test.


excellant image ! tx very much, perfect extras !

up and running-no issues !!!

Thanks so much @cybrnook! Can't wait!


I am up and running your LEDE img for the 3200acm. 5GHz and 2.4GHz radios seem to be working well, plus the leds working. Thank you (my first time with LEDE/OpenWRT).

Cooking in the oven :slight_smile: .............

Alright, give them a test drive please. There are two builds per branch. A normal, what's published to source build, and a second build that includes the same commits but has the latest beta driver.




Appreciate the hard work and sharing. I just installed 3990 beta driver and it connects and drops on both 2.4 and 5.0 pretty continuously.


I just flashed the 3990-BETA and so far no disconnections. Just trouble withe the BETA-BETADRIVER build for me. Let me know if you want me to try anything.

Just list your router model, and what channels you use (please don't say "auto"). You can also try the stable branch with the beta driver as well.

WRT3200ACM Channel 161 for 5G and Channel 2 for 2.4G I swapped channels a few times and it didn't improve on the BetaDriver.

I'll try the stable branch beta next.

Just tried the Stable Branch 3200ACM Beta Driver. So far no drops of course it's only been a few minutes.

The LED seems to light up but on the wireless page the signal strength isn't shown. That doesn't bother me not one iota.

Thanks. I'll give it a workout and let you know.............

Again, thanks for the hard work and sharing.

few questions,

  1. which one out of the two 5GHz bands can i use?
  2. can i use auto channel for both the 2.4GHz and 5GHz?

I "was" useing the LEDE build that hynman put together using the "changes" for the wifi driver for a few hours.

I was streaming the show leftovers up to the bedroom apple tv when things took a nose dive after 2 or so hours of really good use.

No multi-media/websites would load after the nose-dive. Tho I was able to ssh(with wifi) into the wrt3200acm and ping lets say

A reboot didn't fix anything either. So I had to switch partition boot back to stock fw.

Was too lazy at 3am to come check the wrt3200acm at a wired system.

Just thought I'd let you all know what I ran into.

---edited because i wrote r9000 router instead of wrt3200acm

tried 3990-BETA-BETADRIVER and having some issues with wifi, cant enable 5GHz one going to try non beta driver one.
edit: im still having issues with wifi is dropping connection and/or not allowing me to get connected/

@cybrnook, thanks a bunch for building these!

3325-STABLE-BETADRIVER is working perfectly on my WRT1200AC V1.

Channel 147 on 5GHz and Channel 8 on 2.4GHz (as I've had for ages).

Everything is working flawlessly, signal strength is shown, noise level is shown, logs look fine, nothing out of place.

I'm sure this will be my new daily driver.

Just curious, why did you call it beta driver and not simply updated driver? It just looks like the latest update on the mwlwifi github page.

@cybrnook Installed the r3325-STABLE-BETADRIVER on my Rango (WRT3200ACM), and I cant do 2 things: put the 2.4GHz to 40MHz width (both only stays at 20MHz), and I cannot use the DFS channels on 5GHz.

When i do iw dev shows this:

Interface mlan0
ifindex 9
wdev 0x200000001
addr 60:38xxxx.....
type managed
txpower 0.00 dBm
Interface wlan1
ifindex 17
wdev 0x100000003
addr 60:38xxxx.....
ssid LEDE 2.4GHz
type AP
channel 13 (2472 MHz), width: 20 MHz, center1: 2472 MHz
txpower 20.00 dBm
Interface wlan0
ifindex 19
wdev 0x3
addr 60:38xxxx.....
type AP
txpower 20.00 dBm

I am doing anything wrong? (Using LuCI to setup WIFI)

Thanks for the new build. I have a problem with ntfs-3g saying it cannot find fuse interface ("try modprobe fuse"), but kmode_fuse package is already included in your build.

I see the channel number is 13. Wifi charts show this maybe an issue if you try 40 width. How does it work if you use, say, channel 11?