Build for WRT3200ACM (Discontinued)


  • usb2 stick on usb2 port, usb3 HD on usb3 port

  • usb2 led on bright, usb3 led on bright with dot

    root@lede:~# ls -las /sys/bus/usb/devices
    0 drwxr-xr-x 2 root root 0 Dec 7 1968 .
    0 drwxr-xr-x 4 root root 0 Dec 7 1968 ..
    0 lrwxrwxrwx 1 root root 0 Dec 7 1968 1-0:1.0 -> ../../../devices/platform/soc/soc:internal-regs/f1058000.usb/usb1/1-0:1.0
    0 lrwxrwxrwx 1 root root 0 Dec 7 1968 1-1 -> ../../../devices/platform/soc/soc:internal-regs/f1058000.usb/usb1/1-1
    0 lrwxrwxrwx 1 root root 0 Dec 7 1968 1-1:1.0 -> ../../../devices/platform/soc/soc:internal-regs/f1058000.usb/usb1/1-1/1-1:1.0
    0 lrwxrwxrwx 1 root root 0 Dec 7 1968 2-0:1.0 -> ../../../devices/platform/soc/soc:internal-regs/f10f8000.usb3/usb2/2-0:1.0
    0 lrwxrwxrwx 1 root root 0 Dec 7 1968 3-0:1.0 -> ../../../devices/platform/soc/soc:internal-regs/f10f8000.usb3/usb3/3-0:1.0
    0 lrwxrwxrwx 1 root root 0 Dec 7 1968 3-1 -> ../../../devices/platform/soc/soc:internal-regs/f10f8000.usb3/usb3/3-1
    0 lrwxrwxrwx 1 root root 0 Dec 7 1968 3-1:1.0 -> ../../../devices/platform/soc/soc:internal-regs/f10f8000.usb3/usb3/3-1/3-1:1.0
    0 lrwxrwxrwx 1 root root 0 Dec 7 1968 usb1 -> ../../../devices/platform/soc/soc:internal-regs/f1058000.usb/usb1
    0 lrwxrwxrwx 1 root root 0 Dec 7 1968 usb2 -> ../../../devices/platform/soc/soc:internal-regs/f10f8000.usb3/usb2
    0 lrwxrwxrwx 1 root root 0 Dec 7 1968 usb3 -> ../../../devices/platform/soc/soc:internal-regs/f10f8000.usb3/usb3

Just noticed that date, pre-dates Unix Epoch?

1 Like

I think that sounds correct to me. Dot signifies usb 3 protocol.

(Hey, you got a 3200....... )


Do you have a final "patch" available that I could use against my build (looks like you made some revisions today). I would much prefer to flash my own build with your fix to test. I am running the WRT1900ACv2 at the moment.

Ya, you didn't get yours yet? Just kiddin':wink:

Ya, I think the LEDs are correct on everything except mamba, which seems to have changed somewhere along the way. Well... usb anyway, rango still has a ways to go on other fronts.

Ooooh, so this didn't work well on your v1? (and no smart @$$ :stuck_out_tongue_winking_eye: ) I did not get mine yet :sleeping:

@cybrnook I've pushed the final patch to my staging repo: Please do not include the patch in your build yet. I will push it to master if I consider the patch as stable enough.

The result posted by @anomeome matches my expectation. Thanks for testing it on the rango as well!

Yeah, I share your concerns about mamba. Either the USB LED stuff is broken since a while on mamba or does work different. Lets hope that I can find a tester for the WRT1900AC v1.

Nichts passiert Mathias, und danke schon! I will hold off for now in publishing. However I will patch a build for ACv2 soon and test for you.

This from a mamba.

With this change to /etc/config/system (original is in FS#425)

config led 'led_usb1'
    option name 'USB 1'
    option sysfs 'mamba:white:usb2'
    option trigger 'usbport'
    list port 'usb1-port1'

config led 'led_usb2'
    option name 'USB 2'
    option sysfs 'mamba:white:usb3_1'
    option trigger 'usbport'
    list port 'usb3-port2'

config led 'led_usb2_ss'
    option name 'USB 2 SS'
    option sysfs 'mamba:white:usb3_2'
    option trigger 'usbport'
    list port 'usb3-port2'

give working LEDS on mamba. Not sure which is the sata though.


What are you thinking @anomeome, a merger of the V1 you provided, with what @mkresin has put together for all else?

No, @mkresin just has to change the patch to use port2 on mamba; it's the odd one out.

But since we're at it we may as well get the usb 1 sata port going. I think I have an external sata case around here somewhere, but I will have to pull this HD out of the current usb 3 case to drop it in the sata case to test. Just not sure if the requisite bits are in place.

Great job on the build, I appreciate all the hard work. I've finally managed to get OpenVPN connecting to my VPS, but when I move on to the next step of configuring it through stunnel I hit a roadblock. I've tried a few different things and even re-flashed and tried from a fresh install and always end up with this error message:

Wed Jan 25 20:41:06 2017 procd: Instance stunnel::instance1 s in a crash loop 6 crashes, 0 seconds since last crash

I've googled around and can't seem to find any causes or solutions. Might anybody here be able to give me some pointers? I've got a Linksys WRT3200ACM running the STABLE Snapshot posted here.


Hi, need some advice.

  1. Do making my own build with pre-installed package from imagebuilder will spare more free space than install them one by one after flashing? I suppose the answer is yes from my observation

  2. Is it straight forward to build a image? I never build it before. I read this thread from start, seems cybrnook has been doing a lot of work.

  3. Is it risky to flash a non-tested build? (built in the future by myself) For WRT1900ACS, the 3-times-restart-button trick will safe me?

I have been using David's build for a few weeks, but I found that there is an issue I do not have with the latest LEDE Stable. Want to tried cybrnook's build but in fact I just want to squeeze more space with standard LEDE settings at the moment. My old Buffalo have 27MB free space on stand LEDE image, while the same standard build my WRT1900ACS only have 20MB after the flashing. :disappointed_relieved:

Want to know: which package will drive USB3 a faster speed than USB2 speed?

@anomeome Do you have access to a mamba? I'm not entirely sure if your example is correct. The current config in LEDE uses usb2-port2 for the "USB 2" LED. I've no idea if it is a mistake or intentional.

But with the config you pasted, the SuperSpeed LED is always switch on if the normal "USB 2" LED is switched on since both LEDs are tiggered by usb3-port2 . That doesn't sound right to me. Futhermore, the "USB 2" LED shouldn't work with either usb 2.0 or usb 3.0 devices, since it has only one trigger port set.

What I'm really concerned about, are the extra usb trigger on mamba which are not present on the other boards:

  • usb2-port2
  • usb3-port2

I've no idea what they are for. But I'm sure they are there for a reason.

BTW (sorry if I overlooked it in this thread) This build. Is it now based on branch lede-17.01 instead of master?

Yes, the "stable" build is. The "beta" folder is the master branch (which I am thinking of not publishing anymore, only stable).

Just wondering if there is anyone with a cobra(ACv2) that they can tick off as working with @mkresin LED fix, @cybrnook did you have one of those? Would be nice to get this into the first LEDE stable if possible.

You got it brotha. Yes, I am using the ACv2 as my main device right now.

Sorry took so long, I have been in the middle of upgrading from micro-atx to full size atx on my home server. So I have been "down" for the past ~week. Will work on testing it tonight. (technically speaking, I have a 1200ac, 1900acv1, 1900acv2, 1900acs, and hopefully soon to be the 3200 from linksys)

New builds:

Stable - R3028
Beta - R3157

Note: I have removed the "nick"naming conventions. So they are now only head version number and BETA/STABLE.

Hmmmm..... (I made a separate test build with your changes for my WRT1900ACv2) @anomeome @mkresin

Outside of plugging in and removing a USB2.0 and USB3.0 device between both USB ports, is there anything else I need to do to test? I am not getting the second (small dot) on either USB port with 2 x different USB 3.0 thumb drives.

Both LED's light up regardless if I have a USB2 or USB3 device plugged in, so I think that is good, no?
However USB port 2 will not light it's second dot even when I have tried 2 x different USB 3.0 thumb drives.

The USB 2 SS is the trigger on the usb 3 dot indicator, and should list what ports you have available to try. It is just changing out the port in /etc/config/system (although I have not tried that shiny new gui interface), a list of which you can see with:

find /sys/ -iname usb*

from FS#425, and my mamba example.

Edit: maybe the cobra is somewhat link the mamba in this regard. Just changing the port to "usb3-port2" from "usb3-port1" in the "USB 2 SS" stanza in the system config my be enough (assuming that port exists).