Build for WRT3200ACM (Discontinued)

[quote="hnyman, post:307, topic:545, full:true"]

Thanks for the clarification @hnyman

Thanks hnyman,

I tried that and caused the router to reboot. Looks like I will have to use the snapshot image from the main LEDE download site if I want to leverage that kernel module (or build it myself). Thanks.

root@LEDE-AQUARIUS:/lib/modules/4.4.42# opkg install kmod-wireguard --force-depends
Installing kmod-wireguard (4.4.42+0.0.20170115-1) to root...
Installing kmod-udptunnel6 (4.4.42-1) to root...

Installing kmod-udptunnel4 (4.4.42-1) to root...

Installing kmod-ipt-hashlimit (4.4.42-1) to root...

Configuring kmod-udptunnel4.
Configuring kmod-udptunnel6.
Configuring kmod-ipt-hashlimit.

2 days and 18 hours. looking good. By the way I have this "user.notice root: FAN CONTROL fan set at 0%" in my system log for every 5 minutes. I suppose the fan control is checking temp for every 5 minutes to see if it needs to turn on fan? Tia

That's correct

You did a great job with your build. I have no love from David's, maybe his build is based on beta. I think either my AC v1 is very picky or is dying. I got so frustrated, I nearly bought a TP-Link c2600 or switched to my back up ea6900 with xvortex merlin until I tried your stable build. Hope it last. Thanks again for your hard work.

Anyone knows what this is, found it in my system log, tia:

daemon.warn dnsmasq[17876]: possible DNS-rebind attack detected:

I would not be too concerned with it. I have seen this when using a pi-hole in the past as well. Unless "" means anything to you, you can disable rebind protection in your DNS settings, and this message will no longer appear. Even when I saw it before, I saw no adverse effects, so I wouldn't be too worried.

Thanks for the info.

Router rebooted by itself 7 hours ago. System log before the reboot was not there so no idea what is going on but date after reboot became Jan 22 and later adjusted back to Jan 24 by itself. Looks like it is my WRT1900AC acting. Will switch to my back up EA6900.

Sorry to hear it buddy. You had reboots on stock, David's, and mine right? Was your unit a refurbished model?

Never use stock. It is used from Kijiji, maybe it was broken all along. I had reboot on all, DDWRT, Gargolye etc.

Doesn't seem normal, especially not across all open source builds. :cry:

Yes, looks like it is a lemon. Any suggestions for a new router? The ACS or something else? Tia

Are you located in the US? Do you want to stick with an mvebu device? There are some good threads in here about "what router should I get for LEDE", and they have a large amount of atheros recommendations. There is a Zyxel Armor Z2, for example, that looks really nice.

Are you going to start making your own build, use build bot builds, or just use community builds (like mine). This will also help dictate your path.

If your in the US, I have a handful of WRT devices. I could sell you one of those......

I am located in Canada. Zyxel is not available here. I like your build, I may get another WRT.

Well, if you want to stick with the WRT series, and your in the market NOW. Then I would recommend either the WRT1900ACS or the WRT1900ACv2, whichever is cheaper, as they are both the same router. If you buy new now, you will likely get a v2 which means the radio control is not able to be manipulated via firmware, things like unlocking region code or enabling things like noscan.

However, with that said, as long as your planning on playing by the rules you would never be any wiser.

Currently I'm fixing two issues regarding the usb LEDs:

  • the USB2 LED works only if an USB3 device is attached
  • the naming of the LEDs in /etc/config/system doesn't match the names printed on the case

The issues where reported in FS#423 and FS#425.

But I need tester which can confirm that the issues are fixed with my changes and no new issues are introduced. I've uploaded fixed images based on the 17.01 release branch (including LuCI) to

It need to be tested on:

  • WRT1200AC (caiman)
  • WRT1900AC v1 (mamba)
  • WRT1900AC v2 (cobra)
  • WRT1900ACS (shelby)
  • WRT3200ACM (rango)

Don't preserve your config when upgrading!


I had to upload fixed images. I had a stupid copy/paste error and I was hinted that there is one more related USB LED. The expected behaviour is:

  • the first USB LED should get bright in case either an USB 2.0 or USB 3.0 device is attached to the first USB port.
  • the second USB LED should get bright in case either an USB 2.0 or USB 3.0 device is attached to the second USB port.
  • the "dot" LED below the second (bar) USB LED should get bright in addition to the (bar) LED in case an USB 3 device is attached to the second USB port

The names should be "USB 1" for the first USB LED, "USB 2" for the second USB LED and "USB 2 SS" for the "dot" LED below the second (bar) USB LED.

Is this the only change (01_leds)? :slight_smile:;a=blob;f=target/linux/mvebu/base-files/etc/board.d/01_leds;h=d6e42ddfd590ff8e6136bffafd0c57159f1cbb98;hb=9641ceea0ce68d1c507b9d2bbe7cf8da518a2eb8

If so , I can just incorporate it into future builds until it is committed into master branch (and stable).

Thanks for the work in any case.

Thanks, I am researching on the Tp-link C2600 since they are on clearance here.

Make sure to research the revision that was made to that model.

Here is a thread I started back in 2015, has good info: