Build for WRT3200ACM (Discontinued)

It looks like you have some nand badblocks which aren't getting marked a bad and added to the badblock tables.

If you create a McDebian rootfs and chroot to it via DD-WRT you can use the below command to flash the firmware to both image locations. McDebian kernel would update the badblock table during firmware write and I believe DD-WRT kernel will most likely do the same. You really should have a USB to TTL cable in case you make a mistake.

Well, now I have my wrt1900acv2 stuck in a boot loop somehow. RIP $75. Cant' get to DDWRT or anything really anymore.

It starts up, flashes the power and LAN lights... few seconds later, it reboots again. So... I've broken out a USB-Serial cable, but the ports on this board are differently aligned than what the documentation shows on the OpenWRT page. The Serial connector is perpendicular to the board instead of parallel to it, so I'm going to have to guess which pin is which. It matches the picture that's in this other forum post:


Edit: And have u tried this?

To enter failsafe, turn on router, continually press the WPS key on the back as fast as you can until the power light begins flashing rapidly.

Edit2: This is for openwrt/lede not ddwrt...

Edit3: You have spammed the crap out of this very useful thread over the past few days with things completely off topic! GO AWAY!

Careful USB to TTL is very different from USB to RS232 (null modem cable).

Sorry I mixed up DD-WRT and LEDE :fearful:

Sorry, was not knowingly spamming offtopic --- initially I was installing cybernook's build on my WRT1200AC, which worked amazing. So when I got my refurb WRT1900ACv2, I wanted to do the same. Then it didn't work, so I thought I would ask the people in this thread since I thought they might be most knowledgable (and all of you certainly are!). I can go away and start a new thread, but then I'd have to repeat the context again. I'm new to the forum, so I will acquiesce to whatever you would like -- I assumed there would be no more threads here since the builds are discontinued so it was OK to continue in here.

Also I've started the serial process, took a little bit of doing, but I'm at the point I can get serial boot output. Going to try and dig myself out of this nice hole I've made for myself.

1.389171] Waiting 1 sec before mounting root device...

[ 2.401321] VFS: Cannot open root device "ubiblock0_0" or unknown-block(0,0): error -6
[ 2.409255] Please append a correct "root=" boot option; here are the available partitions:
[ 2.417634] 1f00 2048 mtdblock0 (driver?)
[ 2.422711] 1f01 256 mtdblock1 (driver?)
[ 2.427784] 1f02 256 mtdblock2 (driver?)
[ 2.432859] 1f03 1024 mtdblock3 (driver?)
[ 2.437931] 1f04 40960 mtdblock4 (driver?)
[ 2.443006] 1f05 37888 mtdblock5 (driver?)
[ 2.448077] 1f06 39936 mtdblock6 (driver?)
[ 2.453152] 1f07 36864 mtdblock7 (driver?)
[ 2.458223] 1f08 256 mtdblock8 (driver?)
[ 2.463298] 1f09 37888 mtdblock9 (driver?)
[ 2.468370] 1f0a 6656 mtdblock10 (driver?)
[ 2.473531] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
[ 2.481814] CPU1: stopping
[ 2.484529] CPU: 1 PID: 0 Comm: swapper/1 Not tainted 3.18.25 #23
[ 2.490634] Backtrace:
[ 2.493100] [] (dump_backtrace) from [] (show_stack+0x18/0x1c)
[ 2.500685] r6:00000000 r5:00000000 r4:c04cec10 r3:00000000
[ 2.506401] [] (show_stack) from [] (dump_stack+0x8c/0x9c)
[ 2.513642] [] (dump_stack) from [] (handle_IPI+0xe8/0x174)
[ 2.520966] r5:c04b78ac r4:00000001
[ 2.524569] [] (handle_IPI) fr

Ok, Thanks to the USB-to-TTL instructions, I was able to flash OEM Linksys firmware back using a TFTP server setup. I used FW_WRT1900ACv2_2.0.7.167471_prod.img from the Linksys website, renamed it as cobra.img, and the update went well from Putty serial port.

Since then, I have tried to use the Linksys GUI to try and load different versions of LEDE, I've tried Cybernook's last build of
and also davidc's build of a couple days ago

Both seem to end with a failure to boot. I am able to recover it since I'm still connected to serial by using "run altnandboot", which puts me back in Linksys firmware. What am I doing wrong here?

[ 1.400866] armada38x-rtc f10a3800.rtc: setting system clock to 2089-01-04 16:00:27 UTC (3755692827)
[ 1.410345] Waiting 1 sec before mounting root device...
[ 2.481469] VFS: Cannot open root device "(null)" or unknown-block(0,0): error -6
[ 2.488968] Please append a correct "root=" boot option; here are the available partitions:
[ 2.497354] 1f00 2048 mtdblock0 [ 2.501370] (driver?)
[ 2.503742] 1f01 256 mtdblock1 [ 2.507758] (driver?)
[ 2.510122] 1f02 256 mtdblock2 [ 2.514142] (driver?)
[ 2.516506] 1f03 1024 mtdblock3 [ 2.520522] (driver?)
[ 2.522890] 1f04 40960 mtdblock4 [ 2.526906] (driver?)
[ 2.529270] 1f05 34816 mtdblock5 [ 2.533289] (driver?)
[ 2.535653] 1f06 40960 mtdblock6 [ 2.539668] (driver?)
[ 2.542035] 1f07 34816 mtdblock7 [ 2.546050] (driver?)
[ 2.548414] 1f08 38912 mtdblock8 [ 2.552433] (driver?)
[ 2.554796] 1f09 6656 mtdblock9 [ 2.558811] (driver?)
[ 2.561175] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
[ 2.569459] CPU1: stopping
[ 2.572174] CPU: 1 PID: 0 Comm: swapper/1 Not tainted 4.9.20 #0
[ 2.578107] Hardware name: Marvell Armada 380/385 (Device Tree)
[ 2.584052] [] (unwind_backtrace) from [] (show_stack+0x10/0x14)
[ 2.591816] [] (show_stack) from [] (dump_stack+0x7c/0x9c)
[ 2.599057] [] (dump_stack) from [] (handle_IPI+0xcc/0x184)
[ 2.606384] [] (handle_IPI) from [] (gic_handle_irq+0x78/0x94)
[ 2.613971] [] (gic_handle_irq) from [] (__irq_svc+0x6c/0x90)
[ 2.621469] Exception stack(0xdf475f90 to 0xdf475fd8)
[ 2.626532] 5f80: 00000001 00000000 00000000 c001b160
[ 2.634729] 5fa0: 00000000 df474000 c061efe4 00000002 c0619138 00000000 df475fe8 00000001
[ 2.642925] 5fc0: df46c040 df475fe0 c000f808 c000f80c 60000013 ffffffff
[ 2.649556] [] (__irq_svc) from [] (arch_cpu_idle+0x2c/0x38)
[ 2.656974] [] (arch_cpu_idle) from [] (cpu_startup_entry+0xf0/0x19c)
[ 2.665173] [] (cpu_startup_entry) from [<000095ac>] (0x95ac)
[ 2.672203] Rebooting in 1 seconds..
BootROM - 1.73

You should try loading the LEDE trunk firmware.

Ok I will try that. I created a new thread to stop spamming in here:

Apologies to everyone here, what started out as a small question ballooned into a big mess. Hopefully the mess is now contained in my own thread.

@wrt1x00, you need to learn some etiquette. Unless it is your own thread, stay on topic. And even if it is on topic, don't spam with 20 posts in a row, with each one being insanely long, before anyone even responds. And they aren't even about lede or @cybrnook's builds.

This thread has alot of helpful info in it, plus @cybrnook is still posting the occasional build when something major changes, It wasn't dead, maybe it is now after you spamming it for 5 days with literally multiple dozens of screens worth of garbage,

I'm sorry.

Dude, make a point, I get it, but don't demoralize, I am under the impression we are all here to help each other.

Besides, while you are quite often very helpful, you are not always accurate either.


You could have recommend the user create a separate post for their issue without all the chastising.

i understand that cybrnook's build has USB support for the WRT3200ACM (LEDE stable doesn't recognize my external HDD and i'm looking to switch) but i want to know if any of these builds have a working DLNA server (like MiniDLNA) as i would like to stream from this disk.

Can someone clarify, and, in case that neither of these community builds has a DLNA server working, point me on the right track to build the packages myself?

How about just installing minidlna with opkg?
There is no need to have all packages included in the firmware itself. You can pretty freely install add-on packages to a running firmware.

Oh!, what a dumbfuck. I didn't update the repo list. Sorry :-/

New builds with latest driver/firmware and samabacry fix:




Thanks!, trying it out right now.

@cybrnook thanks for the time you put into providing these builds. The beta builds run great on my WRT1900ACSv2.

Just for your information: I am currently using LEDE stable on the same device, with a USB flash drive and a couple of HDDs attached. The USB flash drive is not recognized on boot if plugged in the USB 3.0 port; I have to plug it while the device is already running, or plug it on the USB 2.0 port. Other than that, everything works as expected.

Hi, can you please add fuse libs to kernel, since ntfs-3g cannot work without it and there's no way to install it as a package. I already reported this problem.