Build for WNDR3700v1/v2 / WNDR3800


#83

ok let me try to fix first it ,thank you
skip it (Could you debug them by teamviewer,please please...)


#84

@hnyman

hi Hynman
finally,I made it,I know withou you I can do not this. thank you very much!

the firewire for my wndr4300 is ok,although there are a lot of txt and pathc ,sh files with date prefix in bin/targets/ar71xx/nand/


#85

Yes, that is just the goal of my build scripts, that you get a full archive of source changes for each build, so that you can clearly see the made changes and you can re-install the same build environment again easily. Just as you have done.


#86

@hnyman
hey Hnyman,Hope you have a fun weekend.
The wps button on r7800 is ok,but it's not work for my 4300v1
I do a search on Google,but have't get an answer yet,Would you please give me a little tips to find the answer
Thanks in advance


#87

Please don't hijack device-specific threads for hardware advice for quite other devices.
I have no special knowledge about 4300v1 specifics.

Different routers have different hardware and hardware definitions.
You need to look into source code (and your /etc/rc.button directory) to see what are the differences.
At the first glance I spot no major difference in button definitions:
3700: https://git.lede-project.org/?p=source.git;a=blob;f=target/linux/ar71xx/files/arch/mips/ath79/mach-wndr3700.c;h=1315bab03739ac99185763383b97fdebeadf71b7;hb=HEAD#l76
4300: https://git.lede-project.org/?p=source.git;a=blob;f=target/linux/ar71xx/files/arch/mips/ath79/mach-wndr4300.c;h=2a00a0ed961faf8c0e538c04f2b2455db190b6db;hb=HEAD#l103

But in any case, you are on your own. I have no knowledge about 4300v1.


#88

OK I got it
Thank you Hnyman


#89

@hnyman

Hey Hnyman
According your tips
I put a wps file to /etc/rc.button from wps-hotplug.sh
when I press wps button on my WNDR4300,the led color change,I think it's work now

but I did not find the words" wps avaiable " ony my phone after forget my WNDR4300's wifi

then I try to test my r7800,it's also no words" wps avaiable "

should I add some packages on my router? just like following lik

please git me futher tips later

thanks


#90

@hnyman
Sorry Hnyman,I should check carefully
I just find there is a option for wps in luci menu on my r7800
I'm testing...

and I also found "wpad hostapd-utils,hostapd-common" has been installed on r7800

I checked box of "Enable WPS pushbutton, requires WPA(2)-PSK" in luci menu,and press wps button on my r7800, both wifi and wps led are flashing,but I did see the " wps avaiable " yet

thanks

edit
finally I got wps on both routers worked, I'm so happy!

thank you for your tps Hnyman !


#91

@hnyman
Are you considering adding support for "fast path" in your compilations (only in the form of additional kernel modules).
By the way - is there any sense of adding this FP support for the WNDR3800?
Example patch - https://dl.eko.one.pl/lede/17.01-SNAPSHOT/patches/target/linux/generic/patches-4.4/950-net-patch-linux-kernel-to-support-shortcut-fe.patch
Other important patches: https://dl.eko.one.pl/lede/17.01-SNAPSHOT/patches/target/linux/generic/patches-4.4/952-net-conntrack-events-support-multiple-registrant.patch
https://dl.eko.one.pl/lede/17.01-SNAPSHOT/patches/target/linux/generic/patches-4.4/951-bridge-Add-new-bridge-APIs-needed-for-network-HW-acc.patch


#92

I already tested it in early August as I wrote in this thread...

dissent1 has made a clean patch to add it to the master. eko.one.pl seems to incorporate his patches...
https://github.com/lede-project/source/pull/1269

I did not get so much benefit from it that I would have included it permanently. And it did misbehave with SQM.


#93

@hnyman Oddly, whenever I'm looking for something- you seem to pop up. :smiley: I'm finding quite a bit of noise, but little signal about a prebuilt OpenVPN 2.4 based client.

I can hook up a HD and turn my WNDR3800 into a slow builder (after delving deeper into this entire system), but can you tell me offhand if it's in the local build feed? I am on a 60GB SSD, and don't have room to git the tree at this time.

Cheers!


#94

You can check the available packages either via "opkg" tool or directly from the package download directory. OpenVPN is in the base packages
https://downloads.lede-project.org/snapshots/packages/mips_24kc/base/


#95

Hi hnyman,

In the second post you wrote how to re-create your build environment. I did, everything compile fine, but everything compiles for the new kernel kmod-wireguard_4.4.89+0.0.20170115-1_mips_24kc.ipk. It is not possible to use older kernel while compiling packages?


#96

Packages always compile with the current kernel.
(If you wan't to us an old kernel, you need to do some git magic for time machine... But even then, due to kernel version checksums, you should then compile the whole firmware including the packages you want.)


#97

Ahhh, there is no essy solution. I like your mods for the wndr3700 and I am trying to avoid a full reinstall because of one module. :grimacing::grinning::raised_hand:


#98

(If you wan’t to us an old kernel, you need to do some git magic for time machine… But even then, due to kernel version checksums, you should then compile the whole firmware including the packages you want.)

I did the git magic to get the .83 kernel, compiled the firmware and the Wireguard kmod, but still can't use them, because kernel has different checksum. :thinking: How is the checksum calculated? I can't get the same checksum again?


#99

For whatever reason, my opkg was using a different referenced package group. I'm still not quite sure what happened there. Thanks for the note!


#100

You can't. It is a checksum over all kernel module options. To achieve exactly same checksum as with release builds, is practically impossible (as you need to build all kernel modules etc.).

In practice, just build a fresh new firmware with all needed modules included.


#101

@hnyman

Thanks for the Test build with Kernel 4.9.53. Need some heavy Testing by watching Star Trek: Discovery over Netflix :wink:

23242179

Update:

53

53_Netlink


#102

Dear Hnyman
How are you doing
Recently I'm using aria2 to dowload some files.external hard disck can be mounted perfectly under your firmware
my question is how to transfer file between windows and my router except winscp etc,Could I just copy files via windows network without install samba on my router

thank