Build for WNDR3700v1/v2 / WNDR3800 (discontinued)

Yes, it is based on normal git.
And that commit is quite normally in the main sources:;a=commit;h=eb09d79c163c9f9f913c57eed90d866e458d5ea7

@hnyman do you also experience issues with the 5Ghz?
With my WNDR4300 I experience with some devices that they can see the 5Ghz and can connect.
At some point the devices are disconnected and cannot see the 5Ghz anymore except if I reboot the router.

I'm asking this because the WNDR3700v2 is similar as the WNDR4300.

Thanks in advance.

No. I have not noticed anything special.

@hnyman thanks for your quick response

Any idea which could cause this?
I already tried disable the ATF patch but it doesn't seem to be the problem.

Hi, noob here.

Using: LEDE Reboot 17.01-SNAPSHOT r3270-09a8183ce8 / LuCI lede-17.01 branch (git-17.063.59066-a5191efc7)

Trying to mount a external drive.
dmesg says:

8.475862] scsi 0:0:0:0: Direct-Access Seagate Expansion 9300 PQ : 0 ANSI: 6
[ 8.486303] sd 0:0:0:0: [sda] Very big device. Trying to use READ CAPACITY(16 ).
[ 8.494055] sd 0:0:0:0: [sda] 7814037167 512-byte logical blocks: (4.00 TB/3. 64 TiB)
[ 8.501836] sd 0:0:0:0: [sda] 4096-byte physical blocks
[ 12.477111] sd 0:0:0:0: [sda] Write Protect is off
[ 12.481913] sd 0:0:0:0: [sda] Mode Sense: 4f 00 00 00
[ 12.483086] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, does n't support DPO or FUA
[ 12.493584] sd 0:0:0:0: [sda] Very big device. Trying to use READ CAPACITY(16 ).
[ 12.590728] sda: sda1
[ 12.595104] sd 0:0:0:0: [sda] Very big device. Trying to use READ CAPACITY(16 ).
[ 12.605115] sd 0:0:0:0: [sda] Attached SCSI disk

Trying to install ntfs-3g gives:

Installing ntfs-3g (2016.2.22-1-fuseint) to root...
Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for ntfs-3g:
  • kernel (= 4.4.52-1-840c23c3f9dc6160d8c7bd302c6f494d) *
  • opkg_install_cmd: Cannot install package ntfs-3g.

Please advise :slight_smile:
Thanks in advance! /D.

If you need additional kernel modules, you probably should use the release build, as installing kmods to private builds will fail to kernel checksum check. You might try manual install with opkg using --force-depends but that may brick the device.

Ah ok, so this is not accurate then?
Ok, I´ll install the release build from the OP repo.

My build includes kmod-fs-ntfs, but not the ntfs-3g that you want to install:


Ah ok.
What's the difference between these two? kmod-fs-ntfs=y and ntfs-3g.
One is a kernel module and the other one is a package I suppose, but do they not depended on each other?

When I started the community build 6 years ago, the ntfs-3g wasn't quite stable (or finished), so I have only included the kmod-fs-ntfs, which does not offer full support. I think that it offers read-only.

But there have not many many requests for ntfs capabilities during the years, so I have never bothered to include ntfs-3g, which offers more full support for ntfs.


I own a few devices (clients) that cannot handle higher channels (if channel=auto selected) - so if the router (auto) switch the channel -> sometimes these are invisible for that devices (my Netgear WN2500RP and some USB3.0 AC Dongles don´t like them) | Set the channel manual and/or update | change the clients.

I saw this behaviour with the devices WNDR3700v2 and the TP-Link Archer C7 v2


What about a WNDR3700v4 build?

Thanks for the great support ! :wink:

3700v4 is rather different and I do not have that device. So no support for that one.

I´am familiar with TFTP Recovery.... I would give them a try... #tHumbsUPp#

You can easily copy my settings using the script included in the download directory if you want to build v4 for yourself. But it is a nand device and different than the others so I am not interested in that and will not build it myself.


Will try it next weekend... is there any build root for LEDE? Also have some Huawei hg556a to test.... Amigos from have some detailed instructions how to...

Will reply....

This build seems to have the same issue the core LEDE snapshots have on the 4300 I bought- it's no longer vending the overriden MAC address to my provider, causing pain (and a new IP).

Thanks for this awesome build!

Is it possible to decrease the transmit power without having to restart the wifi signal? i tried this in wndr3700 but without sucess. Every time i need to restart wifi to make changes. Only save dont modify the value.

I need to make a handover without lost connection.

SSH in, and use iw.

iw dev wlan0 set txpower ...

You can save it in your /etc/rc.local if you want to make changes that aren't being saved, just make sure the final line to rc.local is exit 0


r39183: WPS pin code set to the original value given by Netgear in the label at the router's bottom

  •    # Set WPS label pin to match original Netgear value stored in art partition
  •    # Value for wps_pin can be overridden by /etc/config/wireless
  •    local PINdefault="$(dd if=/dev/mtdblock6 bs=1 skip=18 count=8 2>/dev/null)"
  •    set_default wps_pin "$PINdefault"

WNDR3800 does not have a sticker with a pincode WPS ...
The factory stickers indicate the WiFi Network Name (SSID) and Network Key (Password).
My notebook has only Wifi, so it's very important that after the initial firmware, the WiFi is included with the SSID and Key from the sticker on the case.
Is it possible to do this?

Thank you for your work.
More question:
LEDE master: lede-r3887-17f60b1cd2-20170328
Which changes?