Build for WNDR3700v1/v2 / WNDR3800 (discontinued)


The newest build contains a fix for selecting antennas properly in the ath79 builds. Antennas were originally properly selected in the ar71xx, but that was overlooked in the initial transition to ath79.

The fix should improve 2.4 GHz signal quality in all the routers in the series and 5 GHz performance for 3700v1 (while v2 and 3800 were already ok).

Debug discussion:


I will backport that to my next build also for 19.07 in any case, and @chunkeey will likely backport that officially to 19.07.

1 Like

I've upgraded the units with this "old" builds 13503 a few hours ago. So I gues I have to do revert it back again. oO I hope that Wifi is stable enough for a while. But the space problem is solved now. :slight_smile: What I saw is that there are still the 6x4 protocols and ppp within the v1 builds. I think those can be dropped for this old units to save space for bigger kernels in future. Just a thought nothing more.


I can confirm that Wifi is not stable for 13503@ath79 (was calling the owner). Their TV-Box is dropping out randomly.

Wifi is working since two days without any issue on ath79-master-r13533. One negligible thing I've recognized is that the wifi leds are inverted.

Thanks a lot for adding wireguard!

I have no wireless anymore on my WNDR3700v2. I started with WNDR3700v2-master-r13533-69f6fc7b15-20200610-1936-sqfs-sysupgrade.bin, then went on to WNDR3700v2-master-r13565-373f446049-20200614-2046-sqfs-sysupgrade.bin which gave a warning with a yellow and a red box (something with -F) so I skipped that. Then WNDR3700v2-owrt1907-r11108-b515edb775-20200615-1921-sqfs-sysupgrade.bin.

I've done a 30-30-30.

Finally I tftpd stock WNDR3700v2_WNDR37AVv2-V1.0.1.14.img into it. There was no wireless and no WAN either. The MAC adresses were 0000000 or FFFFFFF.

When searching I read about corrupted art partition. The previous owner has used DD-WRT on it. At the moment I am on firmware_with_no_write_protection WNDR3700v2-trunk-r45667-2015-05-10-1816-squashfs-sysupgrade.bin but cannot logon.

Then I'm about to edit wndr3700v2_mtd5_art_edit.bin and have to find out how to write that into the MTD partition. There's only one MAC on the bottom of the device, and this is not the same as I see in my working router (this was registered when the 19.07 firmware was running).

Can you help me with the password of the special firmware? How to find out the ETH0, WLAN and ETH1 MAC? Or doesn't it matter?
What would be the correct MTD write command after unlock? mtd write /tmp/wndr3700v2_mtd5_art_my_edit.bin art?

Or am I on the wrong way altogether ....

Thanks for any help.

There is no password by default.

No idea, as we have seen no logs or anything like that. We also do not know if the radio worked for you when you got the second-hand router.

But as your "previous owner used dd-wrt" problems likely have nothing to do with my build by itself, you might open your own thread about seeking help for the problems. (This thread is not meant as a generic WNDR3700 help thread.)

That sounds right.

But before writing anything there, you should use hexdump or something to see the current contents of mtd5.

Ps. there is no 30-30-30 any more

When entering root and enter or click login with the blank pw nothing happens. Anything I could have done wrong loading the image or entering here? With the two 19.07 images blank pw went fine. If I can't get in the no_write_protection_image then I can't do repair (if necessary).

I'll create a new topic for the wireless, first do some more searching.

I'm in. A browser cache refresh did the trick. Thanks.

Whooomp! And working again! Thanks to your special firmware and art binary. Happy!

Thanks for providing Builds for the WNDR3700 - this lets me continue to use mine without the expense of purchasing a new router. Much appreciated.


Thank you very much for these builds, they have saved me countless hours of headache and cash! With wireguard they really are the cats pyjamas. Thanks again!


ath79 has now moved from kernel 4.19 to kernel 5.4, which has increased the image size, again. It is possible that 3700v1 image again grows too large for jffs2 to work, and I need to cut again a few packages from v1.

Would be great if somebody with 3700v1 gives feedback on the free storage amount. (my own v1 is elsewhere)

Yep, the image is to big. There is no space left (fallback to ramoverlay).


Thanks for confirmation.
I will try to cut a few packages from v1 in the next build.


Would anyone mind sharing their wireguard speeds?
Got a v2 and just want to confirm my findings. Max 32 Mb/s down at dslreports.

I removed fs-cifs from v1
Not sure if the image is now small enough for v1.

1 Like
root@OpenWrt:~# df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/root                 5.3M      5.3M         0 100% /rom
tmpfs                    28.6M    472.0K     28.1M   2% /tmp
tmpfs                    28.6M    108.0K     28.5M   0% /tmp/root
tmpfs                   512.0K         0    512.0K   0% /dev
/dev/mtdblock5          384.0K    232.0K    152.0K  60% /overlay
overlayfs:/overlay      384.0K    232.0K    152.0K  60% /

After a full reset (settings wiped).

Thanks for confirmation. Seems to be enough, but just barely. 152 kB free after basic clean boot is not much. There is not much free space for any additional settings or packages :frowning:

(If I remember right, jffs2 needs at least 5 blocks of 64 kB, so 320 kB would be the minimum for overlay to work r/w in mtdblock5)

There aren't that many large packages that I could still remove from v1 while keeping LuCI and openssl there. I think that that at least USB block device support needs to stay for possible extroot. Possibly some ipsec etc. kmod things could still be removed, but those are small, a few kB each.

Well I've bought a 8MB unit for 1€ recently. Just to try to cut out things. I already made a build (-O2,gcc10,binutils2.34,libstdc,PIE/StackSmasing enabled). Ended up with 6.9 MiB / 7.275.286 (cutting compared to your settings 6x protocols, ppp, ccrypt, nano, htop, debug=off). With another build I will try to cut out the monitoring things (nlbwmon, luci-statistic, collectd, rrdtool) to see the diff in terms of free space. But I don't know if there are sideeffects for LuCI.

I will try to make a build without statistics during this week to see if the usage savings is worth to drop it.

Statistics (luci stats, collectd, rrdtool1) would naturally free space, but I see that as a rather necessary part of the build. Otherwise one could just install the relase build :wink:

My goal is to keep the v1 build with some resemblance to v2 & 3800 builds. Dropping all packages, and e.g. changin from openssl to mbedtls or wolfssl would free lots of space, but that would then make the v1 build quite different (hostaod/wpad etc.)

I understand that. Dropping ppp stuff was just for my unit running as a dumb switch.

Well there isn't really much left.
Would dropping nano, ccrypt, htop, debug=off, sqm-scripts, remove buildconfig within firmware be an option?
Are there options for squashfs or is it already optimized (for this unit) or just "general" optimized? Blocksize, Dictionary size.