Build for WNDR3700v1/v2 / WNDR3800 (discontinued)

The TFTP recovery mode should work. Described in wiki in detail.

Btw, there is no "OpenWrt default wifi w/o password". The default is wifi disabled.
(And my build, that this thread is about, sticks to that default)

1 Like

Hi @hnyman - I love your WNDR builds. Modeled one for my crappy ZBT until it died.

It's literally advertising as being OpenWRT and active for the 2.4Ghz network, with no security. It looks like someone did a 30-30-30 on it, but I've never seen one nuked like this (without console) I have no idea how it ended up that way. Being lazy, I ended up bridging across an external switch because every time it dropped, the computer would disable the ethernet when it dropped and take seconds to bring it back online.

Still have had no luck on it accepting packets. Guess it's time to look for a TTL. :confused:
Thanks.

The latest ath79 builds (ath79-master-r12889-02a1914585-20200409) come up with no wireless network. Luci webinterface shows some generic wireless devices.

Thanks for info.

There was a big change to the OpenWrt config system a few days ago. I noticed some peculiarities but looks like I did dot check the radios well enough.

The config system changes a few days ago apparently broke the ability to build for multiple devices. A fix has been proposed, but not yet implemented.
https://www.mail-archive.com/openwrt-devel@lists.openwrt.org/msg52071.html

ath79-master-r12903-c30220d458-20200411 has again a normally working wifi.

I applied the patch proposed in
http://lists.infradead.org/pipermail/openwrt-devel/2020-April/022752.html

ok, thank you!

I'd like to say a big thank you to hnyman. I have been using your builds with my WNDR3700v2 almost since I bought the device back in 2012 or so and they have been serving me well all these years. Yesterday I did a hardware mod to upgrade the RAM, and again, your repository made this process quick and easy.
More details in the following topic:
https://forum.openwrt.org/t/wndr3700v2-ram-mod-revisited

Do I have to regard sth. special if I flash from ar71 to ath79 on WNDR3700v1 units? I tried to flash from an older ar71 build directly to ath79. After flash and several resets the unit did not save any settings I made. I flashed back to ar71.

It is strongly recommended not to retain settings (sysupgrade -n /tmp/openwrt-…-squashfs-sysupgrade.bin) for cross-grading between ar71xx and ath79 (and neither to restore an old configuration!). A number of configuration settings differ between ar71xx and ath79 in incompatible ways (wireless, LEDs/ GPIOs, etc.).

1 Like

Ah O.K. Thx for input! I was upgrading with preserve settings through LuCI (just forgot to turn off this feature). But I'm still wondering why a reset (pressing button on unit) did not fix it. I will try to flash again within the next days. I can't touch them for the moment cause they are in use.

With wndr3700/3800 there aren't any really dangerous settings changes between ath79 and ar71xx so I am constantly jumping between 19.07 ath79, master ath79 and master ar71xx builds with the same settings kept in sysupgrade. Usually with wndr3700v2.

I do not have v1 at home any more, so it is quite possible that the build has again grown marginally too large so that the 8 MB flash gets too full, and there is not enough space to save settings. Logs and "df -h" are useful to understand what happens with jffs2 overlay.

1 Like

That makes sense. I didn't pay attention to size. So I'll either stick with ar71 or use extroot. Is it recommended to use ath79 beside general security concerns because ar71 is not longer maintaind? Thx for your builds and help hnyman!

Today I was able to flash one unit again. But sadly I've forgotten to save the Screenshot of the log. I didn't read it, so I cannot recall anything usefull. The routers do not belong to me anymore. I gave them away and I cannot take them down and look into at home. Maybe I will try it on Weekend again if necessary.

But 2 shot survived "df -h" before flash and after flash:

out

Today I flashed again to get the log:

Sat May 30 13:43:06 2020 kern.notice kernel: [    0.000000] Kernel command line: console=ttyS0,115200 rootfstype=squashfs,jffs2

[...]

Sat May 30 13:43:06 2020 kern.info kernel: [    0.564237] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.

[...]

Sat May 30 13:43:06 2020 kern.err kernel: [   21.146854] jffs2: Too few erase blocks (4)
Sat May 30 13:43:06 2020 kern.err kernel: [   21.152307] jffs2: Too few erase blocks (4)
Sat May 30 13:43:06 2020 user.err kernel: [   21.156785] mount_root: failed to mount -t jffs2 /dev/mtdblock5 /tmp/overlay: Invalid argument
Sat May 30 13:43:06 2020 kern.err kernel: [   21.648909] jffs2: Too few erase blocks (4)
Sat May 30 13:43:06 2020 user.err kernel: [   21.654015] mount_root: unable to set filesystem state
Sat May 30 13:43:06 2020 user.info kernel: [   21.659461] mount_root: switching to jffs2 overlay
Sat May 30 13:43:06 2020 user.err kernel: [   21.664439] mount_root: switching to jffs2 failed - fallback to ramoverlay

[...]

Sat May 30 13:43:40 2020 kern.err kernel: [   65.032351] jffs2: Too few erase blocks (4)
Sat May 30 13:43:40 2020 daemon.err block: mounting /dev/mtdblock5 (jffs2) as /mnt/mtdblock5 failed (22) - Not a tty

I think I got the essential passages. If full log is needed I will spam it here. :wink: But I think its flash memory related. So ath79 is not suitable for the 8MB variants and thus EOL.

Well you can compile it yourself and make image smaller. I have WNDR3700v4 which has 128 MB RAM & ROM and when i compile my image i include as much as i want. I updated my router today and compile image was 25 MB in size. You could configure extroot then and also install as much software as you want.

Yep, looks like it needs a bit more free space. 8 MB starts to be too little. (OpenWrt already has a 4/32 warning, but rather soon there needs to be 8/32 or 8/64 warning...)

I will drop a few more packages from the ath79 build for v1. (I am packing some packages only to v2 and 3800, so that v1 build would be smaller, but the list of packages fitting in gets smaller and smaller as kernel grows)

1 Like

You might try ath79-master-r13503-050c31fa26-20200607

I dropped full GNU wget, adblock and nlbwmon from the v1 build, and the sysupgrade file size dropped by 320 kB (from 7425 kB to 7105 kB). Very likely it is again usable with v1.

If those packages are needed, they should be normally installable by opkg.

1 Like

Yes I know that I could do that. But the units do not belong to me anymore. I gave them away to ppl. in my neighbourhood (with kids) instead of throwing them away (had 3 of them). They have no clue about routers as most ppl. They do not update because they don't know howto. I just do upgrade the units from time to time if I come by. And this time I had to invest more time as usually. If I would do a build by my own I would need to test ... But without a unit near by me it's pointless. I never used extroot and I'm scared about to suggest others without any clue about using this technique. IMO just another layer of possible problems if it comes to upgrades.

Yes it's probably time to sort out those units. Maybe a solution is to drop LuCI to keep them alive for future.

Thank you very much for your work! :slight_smile: I will try to shift over to ath79. I will test during next week and report back.

hnyman are you considering adding wireguard for the WNDR3700v2/3800 builds? It would be sufficient to add kmod-wireguard to your build, the rest can be installed via opkg install.

I might add it.
I have already added wireguard to R7800, but I have so far avoided it due to the size constraints on v1. But as I dropped some packages today, there might be room for at least the kernel part of wireguard

I will add wireguard. I do not use it myself, but it is popular, and the kernel nodule part needs to be compiled with the firmware.

Looks like I will include only kmod to v1 (it takes just 64 kB), but i will include also tools & LuCI app for v2 and 3800.