Build for WNDR3700v1/v2 / WNDR3800 (discontinued)

HI,fRUTTiFrESH thanks for your help

I'm use ext4 on my external harddisk
Now I think I know what's going on
thanks again !


i have a small problem with my wndrmacv2. I build my LEDE on a vm and used the BTN_2 content of your work here to get the Wifi togle button working and that went on fine for years (openwrt and LEDE).

Now when i press the button after boot 2.4 and 5 deactive. After pressing it again 2.4 activates and 5 just flashes for a fraction on a second and nothing happens. When its activated i can use it with no problems.

Is my router done for or has something changes (last months) that interferes with the button?

Thnaks for your work!

Just tested with my own 3700v2 running master r5117-fbde9ac718, and wifi button still works normally.

You need to check the system logs and try to understand what errors materialize

Hi hnyman, I just tried to update my build, which is a slightly customized version of yours. Is it OK to ask here about build errors since it is based on yours? Perhaps you can point me to a better resource for this type of question.

Anyhow, I am getting this error (more lines here )

touch /home/ledebuilder/lede/trunk/build_dir/target-mips_24kc_musl/libiwinfo-2017-08-23-c1a03e82/.prepared_047b2218aaa10150d47d2cbd7fd07e0e_6664517399ebbbc92a37c5bb081b5c53_check
. /home/ledebuilder/lede/trunk/include/; xzcat /home/ledebuilder/lede/trunk/dl/libiwinfo-2017-08-23-c1a03e82.tar.xz | tar -C /home/ledebuilder/lede/trunk/build_dir/target-mips_24kc_musl/libiwinfo-2017-08-23-c1a03e82/.. -xf -
tar: This does not look like a tar archive


shame on me. should have done that first :wink:

This is what happens when 5GHz craps out:

Thu Oct 19 21:51:35 2017 daemon.err hostapd: hostapd_free_hapd_data: Interface wlan1 wasn't started
Thu Oct 19 21:51:35 2017 daemon.notice netifd: radio1 (3928): WARNING (wireless_add_process): executable path /usr/sbin/wpad does not match process 2175 path ()
Thu Oct 19 21:51:35 2017 daemon.notice netifd: radio1 (3928): Device setup failed: HOSTAPD_START_FAILED

Your problem sounds a bit similar as in Wpad 802.11w no longer working in trunk?

You should try removing the possible corrupt package source archive dl/libiwinfo-2017-08-23-c1a03e82.tar.xz

You might test also "make dirclean" to build everything from scratch, or even delete the source archives from "dl".

Thanks for the hint! I recompiled my image with wpad-mini and now the buttons work as expected!

Thank you!

Hi @hnyman thanks for the build, you gave new life to my router.

By the way, is the KRACK patch already included in the r5142 I see in Dropbox?

Yes, all builds are from branch HEADs.

Is the routing patch file supposed to be empty?

Yes, no changes there at the moment

1 Like

Been using your builds for many years now hnyman. Thanks a ton for all your work!

For some reason my (3800) wifi performance drops if the router has been up for a few days. So I just made a cron to reboot at 4am. Am wondering if the bandwidth monitoring logs are flushed to persistent db when a reboot is triggered by cron. Don't know enough of the system to find out myself.

I don't think that it gets committed. The default db dir for nlbwmon in ramdisk /var in any case, so if you want to keep the database across a reboot, make sure to change the dir in nlbwmon config and set a rather frequent save interval.

I will drop the routing feed diff/patch from the patch set, as I have no changes there at the moment.

I will just comment out the respective lines in the build scripts (createbuildinfo and newbuildroot), so if somebody is using my scripts and has patches for that feed, just uncomment the lines.

First of all, thanks for the builds you keep making for this old router!

Still want to ask you something regarding an issue I have with my WNDR3700v2.
When I use (netflix) for a speedtest on my router, it works flawlessly on 2.4G but makes the router crash when I connect to 5G.
The router reboots and all is ok again.
I tried to get a system log/kernel log but I could not get it to store on my Synology nas.
Any ideas how to find out what is happening?

Sounds like you need serial console connection during the crash.

Just to rule out software issues, back up your settings, do a completely clean flash after a 30/30/30, and set up the basics and try again, unless you have a USB->TTL interface already (they only cost pennies, but take forever to ship from China- and finding drivers can be problematic when they're workalikes).

I've got a 3800 (and a 4300) that crash when they're online for more than 4 hours. At least one is a hardware issue, but I'm hoping the other is just an overheat/cold solder issue..

Bandwidth Monitor is stopped working.

I have set Due date 4.

It worked from 10-04 to 11-03 and stopped working on 11-04.

What can be the problem here?


I am having a similar problem with the newest build (r5444), but in my case the router works perfectly until I turn on any wireless adapter. After turning on the 2.4GHz or 5GHz connection I lose the ethernet connection to the router and it enters a boot loop.

Works fine with the OF and LEDE 17.01 r3600, though.