Build for Netgear R7800

Thanks for noticing.
I accidentally copied my wrt3200acm 19.07 build there, instead of the18.06 build for R7800 that I was supposed to copy. Too many builds :frowning:

1 Like

Anyone been able to get over 80 mbps with qos for 100+mbps line for these builds, like in kong's build?

Any fixes for "old" driver that may warrant a new build? Thanks.


based on testing v5.4-rc2-0-gda0c9ea146cb

Hey guys

New to OpenWRT so builds like these are great to already have some functionality.
Having trouble installing NFS on the 1907-r10599 build though

Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for nfs-kernel-server:
 * 	kernel (= 4.14.149-1-0894164cab0effc42201a29fec8ce33f)
 * opkg_install_cmd: Cannot install package nfs-kernel-server.

Any advice on getting it installed? Thanks

Please avoid double-posting:

I have compiled master a few days ago based on hnyman build with some additional software, including NFS. That should be the one:
I've got sysupgrade only.

Cheers, might give that a try. What else did you add on?


Not sure about the last one.

Not really. but I still made a new build, just for masochism...

There is a new wifi driver version "mac80211: Update to version 5.4-rc2" (that slh already referenced) but no help from it.
Still a flood of "SWBA overrun on vdev 0, skipped old beacon" errors with the build of master-r11302-e4155bcc45-20191021-ath10k-crashes. I did not experience a crash in the first few minutes, but I guess that crashes will happen.

Looks like the "-ct" is still the stable version, at the moment.

Hmm, yea, the tide has turned, CT works very well for me now.

1 Like

Thanks @hnyman I'll try -ct again at some point.

One way to test how well it is working (not the stability, though) is to run htop -d 1 on the router over ssh over a wireless connection. The ct driver makes the output very bursty/delayed. The non-ct one is way better in this test. But I am using a 19.07 build here.

I'm running latest master with CT driver and just tried htop -d 1 (rdp then ssh, both over WLAN) and to my eye it is without any glitches.

Trying latest -ct ... still seeing crashes/traces in dmesg. Normal or just me?

[ 3813.564547] CPU: 0 PID: 0 Comm: swapper/0 Not tainted 4.14.149 #0
[ 3813.586758] Hardware name: Generic DT based system
[ 3813.592872] [<c030f3b4>] (unwind_backtrace) from [<c030b31c>] (show_stack+0x14/0x20)
[ 3813.597540] [<c030b31c>] (show_stack) from [<c07d5074>] (dump_stack+0x88/0x9c)
[ 3813.605443] [<c07d5074>] (dump_stack) from [<c031fff8>] (__warn+0xe4/0x100)
[ 3813.612466] [<c031fff8>] (__warn) from [<c031fcdc>] (warn_slowpath_null+0x20/0x28)
[ 3813.619402] [<c031fcdc>] (warn_slowpath_null) from [<bf860d44>] (ath10k_htt_t2h_msg_handler+0x16bc/0x2150 [ath10k_core])
[ 3813.627201] [<bf860d44>] (ath10k_htt_t2h_msg_handler [ath10k_core]) from [<bf862338>] (ath10k_htt_get_rx_ring_size_64+0xb58/0xc34 [ath10k_core])
[ 3813.638139] [<bf862338>] (ath10k_htt_get_rx_ring_size_64 [ath10k_core]) from [<bf862af0>] (ath10k_htt_txrx_compl_task+0x6dc/0xbb0 [ath10k_core])
[ 3813.651014] [<bf862af0>] (ath10k_htt_txrx_compl_task [ath10k_core]) from [<bf8b6034>] (ath10k_pci_napi_poll+0x78/0x11c [ath10k_pci])
[ 3813.663928] [<bf8b6034>] (ath10k_pci_napi_poll [ath10k_pci]) from [<c06cd070>] (net_rx_action+0x144/0x31c)
[ 3813.675754] [<c06cd070>] (net_rx_action) from [<c03015c0>] (__do_softirq+0xf0/0x268)
[ 3813.685209] [<c03015c0>] (__do_softirq) from [<c03245c0>] (irq_exit+0xdc/0x148)
[ 3813.693116] [<c03245c0>] (irq_exit) from [<c03671b0>] (__handle_domain_irq+0xa8/0xc8)
[ 3813.700139] [<c03671b0>] (__handle_domain_irq) from [<c0301484>] (gic_handle_irq+0x6c/0xb8)
[ 3813.708123] [<c0301484>] (gic_handle_irq) from [<c030c18c>] (__irq_svc+0x6c/0x90)
[ 3813.716274] Exception stack(0xc0b01f48 to 0xc0b01f90)
[ 3813.723934] 1f40:                   00000001 00000000 00000000 c0315300 ffffe000 c0b03cbc
[ 3813.728980] 1f60: c0b03c6c 00000000 00000000 c0a2ca28 00000000 00000000 c0b01f90 c0b01f98
[ 3813.737125] 1f80: c030868c c0308690 60000013 ffffffff
[ 3813.745281] [<c030c18c>] (__irq_svc) from [<c0308690>] (arch_cpu_idle+0x38/0x44)
[ 3813.750322] [<c0308690>] (arch_cpu_idle) from [<c035c0f4>] (do_idle+0xe8/0x1bc)
[ 3813.757779] [<c035c0f4>] (do_idle) from [<c035c43c>] (cpu_startup_entry+0x1c/0x20)
[ 3813.764822] [<c035c43c>] (cpu_startup_entry) from [<c0a00cf8>] (start_kernel+0x41c/0x428)
[ 3813.772461] ---[ end trace 50c85d02124dac68 ]---
[ 3813.782948] ath10k_pci 0001:01:00.0: SWBA overrun on vdev 1, skipped old beacon
[ 3813.787347] ath10k_pci 0000:01:00.0: SWBA overrun on vdev 0, skipped old beacon

I searched for Exception in recent syslog files and there is nothing. What is your /etc/config/wireless?
Mine below for the reference:

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11a'
	option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
	option legacy_rates '0'
	option distance '10'
	option country 'XX'
	option channel '64'
	option htmode 'VHT80'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
	option noscan '1'
	option htmode 'HT20'
	option log_level '2'
	option distance '12'
	option legacy_rates '0'
	option channel '13'
	option country 'XX'


The ath10k-ct dev @greearb is responsive to crash reports if you open an issue on his ath10k-ct github site here and include the dmesg output from the crash (as much as you have).

It's not uncommon for him to build a test fix for you to try - sometimes within 24 hrs of your report.

I don't think he regularly check the forums.

@perceival I posted my config a while back, please let me know if you notice anything unusual in it:

@anon98444528 I do report these crashes and other issues in @greearb's github but no comments so far:

Just you. (???)

There haven't been that many crash reports for R7800 or ath10k-ct lately, so it may well be some not so usual combination of options (or client devices and their traffic) causing it.

You might try identifying the possible combination of options/devices/traffic that trigger the crashes for you. Some certain device? First device connecting to the router? Does it happen with vanilla settings (like first channel in the band, no special options, HT40 etc.)?

With "ct" I'm seeing something similar with ssh between 2 Macbook Pros both on wifi. Typing is laggy/bursty as if the devices are far away over lossy Internet. Same 2 devices are OK when using "old".

I'm also seeing the same old issues with "ct" where low power "smart" IoT devices are not able to always send notifications/alerts because when they wake up they sometimes can't connect to wifi. None of these problems with "old". My test here is a simple "ping" to one of these devices: on "old" it takes a few seconds but they eventually start responding to pings, on "ct" they never respond, all pings time out. I reported this in the "ct" github but no progress yet.

I think it's unfortunate that the decision has been made to move to the "ct" driver as the default. At least with my setup it seems inferior to "old".
There also is the danger that there's only 1 developer working on the "ct" firmware/driver. I'm not being critical here, I do appreciate @greearb's work and knowledge, but things do come up in life where open source projects take a back seat. We've seen this with many other projects that depended on a single developer.

1 Like