Build for Netgear R7800


#1345

Well, hopefully then the typo in stromgswan-mod-kernel-libipsec was just a typo in the message here.
"stroMg"


#1346

Ha, good eye! But yes it was just a typo here.

I was careful to compare each of my lines to the package table at openwrt.org to ensure I didn’t mistype or misspell any package names.


#1347

It is easier to use "make menuconfig" to first add the packages into .config, and then use ./scripts/diffconfig.sh output to collect the actual differences in .config, so that you do not make typos / syntax errors. I only add the "top-level" package into .config.init and let those packages to pull in their dependencies.

Example:
luci-app-wireguard has dependencies as wireguard-tools, kmod-wireguard and luci-proto-wireguard, so just adding luci-app-wireguard into .config.init will also then pull in the three other actual wireguard packages.

("wireguard" itself is just an empty meta-package, so you can skip it, as you already depend on the two actual packages... https://github.com/openwrt/openwrt/blob/master/package/network/services/wireguard/Makefile#L51 )

Smooth using of .config.init (and diffconfig.sh) requires some source code browsing (or using "/" to search packages in menuconfig), so that you can only include just the necessary packages.


#1348

Ok, that all looks great! I really appreciate your input, hopefully by taking your advice I can get a proper custom image built.


#1349

So I followed your instructions and no matter what I add it fails. I decided to do 'make clean' and then './hnscripts/singlecompile.sh' and when it failed I had a quick look through 'build.log' and spotted this;

Collected errors:
* check_data_file_clashes: Package libustream-openssl wants to install file /home/thomas/OpenWRT/R7800/master/build_dir/target-arm_cortex-a15+neon-vfpv4_musl_eabi/root-ipq806x/lib/libustream-ssl.so
	But that file is already provided by package  * libustream-mbedtls
* opkg_install_cmd: Cannot install package libustream-openssl.
* check_data_file_clashes: Package libustream-openssl wants to install file /home/thomas/OpenWRT/R7800/master/build_dir/target-arm_cortex-a15+neon-vfpv4_musl_eabi/root-ipq806x/lib/libustream-ssl.so
	But that file is already provided by package  * libustream-mbedtls
* opkg_install_cmd: Cannot install package luci-ssl-openssl.

When I added Transmission I specifically selected the OpenSSL version because I knew that OpenSSL was already going to be built and used for LuCI anyway. I tried again with the mbedtls version of Transmission and get the same error with the same text.

Any insight?


#1350

Some package that you have added requires libustream mbedtls and installs it.

Cshark only supports mbedtls, I think.

That causes the conflict.
You might edit its Makefile and remove the dependency. You will have a libustream variant installed in any case, so hopefully that is enough.

Or you might try compiling others but not cshark packages.

Ps. And always start compilation from a clean .config.init so that the tested dependencies get purged from .config


#1351

Success!

I’m not an idiot but these things really do go over my head sometimes ha. Edited the Makefile to remove that dependency for CloudShark and it built first time.


#1352

Yeah, it is not that complicated, but requires some source code investigation (or menuconfig search) in case there is this kind of conflict between packages versions.

Great that you succeeded.


#1353

@hnyman Just so you know, I had issues with the latest dnsmasq changes to master. Seems like dnsmasq isn't very happy for some reason, I get no DNS etc.
Could just be some oddball issue I have but still.


#1354

image

is there a problem with online image builder rightnow


#1355

That online builder thing has nothing to do with my build.
You better ask that in the discussion thread about it.


#1356

On the newest master with the old ath10k firmware (master-r8684-f6e9f23771-20181210-ath10k) I'm getting errors similar like this one on most pages:

Failed to execute cbi dispatcher target for entry '/admin/system/system'.
The called action terminated with an exception:
/usr/lib/lua/luci/template.lua:74: Failed to load template 'cbi/map'.
Error while parsing template '/usr/lib/lua/luci/view/cbi/map.htm':
Syntax error in /usr/lib/lua/luci/view/cbi/map.htm:24: unexpected symbol near ')'
stack traceback:
	[C]: in function 'error'
	/usr/lib/lua/luci/template.lua:74: in function '__init__'
	/usr/lib/lua/luci/util.lua:65: in function 'Template'
	/usr/lib/lua/luci/template.lua:27: in function 'render'
	/usr/lib/lua/luci/cbi.lua:257: in function 'render'
	/usr/lib/lua/luci/cbi.lua:440: in function 'render'
	/usr/lib/lua/luci/dispatcher.lua:945: in function

Reset, reboots or a completely clean flash with tftp result in the same behaviour. The previous build "master-r8661-32bc733796-20181207-ath10k" is working fine for me.


#1357

Looks like the map error in Luci, which got fixed two days ago, but is still in that build.

Next build should be ok again.

You could also manually edit the file right now. It is a one character fix to /usr/lib/lua/luci/view/cbi/map.htm

Or you can opkg install the updated luci-base from snapshot repo.

EDIT:
new build:
master-r8702-3198ec5b9d-20181212-ath10k


#1358

I found out why dnsmasq won't start for me now.
It thinks the /etc/config/dhcp pxe options i use are invalid, I redirect pxe boot to another server like this.

EDIT:
worked before this commit
Not entirerly sure that's the reason but it's a big candidate.


#1359

What's the current best option to go for with firmware? I see there's 2 different version of master? -ct or not?

Just general home use, no extra add ons.

Cheers.


#1360

hi, not an expert, but i think your current version of your linux kernel is below 4.14.82. you can see the version in the overview page.


#1361

Just for my interest: Does this build contain an openssl version with activated hardware support for the R7800 as demonstrated here?


#1362

Someone is working on it


#1363

small flash
large flash
what difference

i use R7800
Which one should I use?


#1364

That distinction only applies to 17.01.x.

In short, both the OEM firmware and the official LEDE 17.01.x are small flash variants (2 MB kernel, around 19 MB rootfs).

Since 18.06, these 2 MB are no longer enough for the kernel (which currently requires around 2.4 MB). Accordingly the partitioning had to be changed (4 MB for the kernel), which also opened the door to repurpose the netgear partition as extended rootfs (around 90 MB) as well.

The downside, changing the partitioning split is disruptive, requiring tftp recovery to succeed. Therefore hnyman is now offering a 17.01 derived variant of his build following the new (18.06.x) partitioning, which doesn't require tftp for flashing back and forth.

Given that there is no reason not to choose 18.01.x (or newer) you end up with 'large' anyways.