Build for Netgear R7800


#1325

Mmm i noticed it's a global error. Not only CPU.
I will try to make new build, I haven't changed anything related to that so idk what could be wrong, maybe master git had some error at the time i pulled it.
EDIT:
Now it works, I don't know what was wrong but I think perhaps it was my extra optimization that I used. Don'¨t go higher than -O2 when compiling, stuff seems to break.
Perhaps you can go with that as default @hnyman? Instead of -Os?


#1326

Currently using

Firmware Version OpenWrt 18.06-SNAPSHOT r7324-05606de1aa / LuCI openwrt-18.06 branch (git-18.247.71242-9541751)
Kernel Version 4.14.71

I changed the wifi driver due to wifi issues ... will installing an update overwrite that driver or not or do newer updates get newer wifi drivers?


#1327

Yes. All drivers / packages get overwritten in a firmware upgrade.


#1328

Are they the latest and greatest now? :wink:


#1329

They are the newest in master, and the still then same old ones in 18.06
But the greatest?? No idea...


#1330

Hi, I use OpenWrt 18.06-SNAPSHOT, r7365-91a8bc1dd0
When I install f2fs-tools it’s ok, when I install kmod-fs-f2fs I get

root@OpenWrt:~# opkg install kmod-fs-f2fs
Installing kmod-fs-f2fs (4.14.82-1) to root...
Downloading http://downloads.openwrt.org/releases/18.06-SNAPSHOT/targets/ipq806x/generic/packages/kmod-fs-f2fs_4.14.82-1_arm_cortex-a15_neon-vfpv4.ipk
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-fs-f2fs:
 *      kernel (= 4.14.82-1-d9f1d0b0018fe1c6aa713f31af21957b) *         kernel (= 4.14.82-1-d9f1d0b0018fe1c6aa713f31af21957b) * 
 * opkg_install_cmd: Cannot install package kmod-fs-f2fs.

Please help


#1331

Well, I am such user who is bothered
It is real surprise for me that OpenWrt USB speed is only 17 MB/s read and 6 MB/s over wire
I flashed latest DD-WRT then and got 75 MB/s read and 56 MB/s write
Voxel f/w gives me solid 114MB/s read and 93 MB/s write

After some tweaks on cpu scale and performance posted above in this thread, on latest master openwrt I get 32 MB/s read and 10 MB/s, so less

While drivers itsels look good and show me real speed

root@OpenWrt:~# hdparm -Tt /dev/sda1
/dev/sda1:
Timing cached reads: 1288 MB in 2.00 seconds = 644.67 MB/sec
Timing buffered disk reads: 172 MB in 3.09 seconds = 55.58 MB/sec
root@OpenWrt:~# hdparm -Tt /dev/sdb1
/dev/sdb1:
Timing cached reads: 1270 MB in 2.00 seconds = 635.50 MB/sec
Timing buffered disk reads: 664 MB in 3.01 seconds = 220.79 MB/sec


#1332

Hi guys,

I updated from R7800-master-r6011-805f756d6e-20180206-2323 to R7800-master-r8467-dd02a19ff5-20181118-1702 last week. Since then, I've seen a few domains/hosts on the Internet to be unavailable from time to time. I haven't been able to pinpoint a specific situation on when or how this occurs.

For instance hub.docker.com is suddenly not available. I'm browsing the hub, and from one page to the other, it's suddenly unavailable. DNS resolving seems to be OK. when I try to ping the host, the requests time out. When checking a few minutes later, the host is available again.

Next time when this happens, I'll try using a different device to make sure it's not related to my laptop, or the combination of the R7800 and my laptop. This behavior is not limited to hub.docker.com, but to other hosts as well. I'll also try to use my phone's Internet connection not using WiFi at that time.

I am using the built in adblock service in this build of OpenWRT.

And off course, I can't find any "status down" messages about those sites at that time when I check them. Not by the status page of docker.com or my ISP. I can't help but thinking it's not plain coincidence this happens to me this week on a new build for the R7800, after running this ISP for about 12 years and this particular R7800 for 9 months. So I thought I'd drop this message, hoping to find me-too's :sweat_smile:

--EDIT--
Well that was quick: my phone can find and access the Docker Hub without any unexpected issues at the same time my laptop can't, via the same WiFi network. So it's obviously related to my laptop and my R7800. :sweat:

This means I need to dig further. I have seen the same behavior like on my laptop on my iPad too since the new build when I come to think of it :thinking:... So it's not entirely isolated to my laptop and the R7800. I'm experiencing the issue right now, it's coming and going. At the moment, the hostname hub.docker.com can't even be resolved.

Is there some place I can check for any eventual errors in OpenWRT?


#1333

IPv6 springs to my mind. Could this be part of the culprit? I've got both versions enabled. IPv6 with a LA-Prefix.

From my laptop:

$ dig +short hub.docker.com
elb-default.us-east-1.aws.dckr.io.
us-east-1-elbdefau-1nlhaqqbnj2z8-140214243.us-east-1.elb.amazonaws.com.
34.232.230.241
52.86.8.163
52.205.36.130

but:

$ ping hub.docker.com
ping: cannot resolve hub.docker.com: Unknown host

and:

ping6: getaddrinfo -- nodename nor servname provided, or not known

But still:

$ nslookup hub.docker.com
Server:		192.168.1.254
Address:	192.168.1.254#53

Non-authoritative answer:
hub.docker.com	canonical name = elb-default.us-east-1.aws.dckr.io.
elb-default.us-east-1.aws.dckr.io	canonical name = us-east-1-elbdefau-1nlhaqqbnj2z8-140214243.us-east-1.elb.amazonaws.com.
Name:	us-east-1-elbdefau-1nlhaqqbnj2z8-140214243.us-east-1.elb.amazonaws.com
Address: 52.86.8.163
Name:	us-east-1-elbdefau-1nlhaqqbnj2z8-140214243.us-east-1.elb.amazonaws.com
Address: 52.205.36.130
Name:	us-east-1-elbdefau-1nlhaqqbnj2z8-140214243.us-east-1.elb.amazonaws.com
Address: 34.232.230.241

But my phone can access the Docker Hub without a problem at the same time.


#1334

I don't need ipv6 so I try to keep it disabled everywhere. Not the best solution I know but at least it prevents address confusion.
I still have it active in OpenWRT.


#1335

I may have found the culprit... I’ve mentioned I’m using the Adblock service. What I did when flashing the new build was create a backup and restore that after flashing. Apparently one of the lists I selected a few months ago has had an update... To include amazonaws.com... Who would have thought of that being a good idea?

I whitelisted that domain in the Adblock service. According to my previous post, this may solve the issue for me when docker’s loadbalancers serve me a host on AWS. At this moment, I’m betting on updated Adblock (lists) to be the cause.


#1336

It's not that, it's a little typo in the regexp for adguard. Please update it with the following and it should work good:

config source 'adguard'
	option adb_src 'https://filters.adtidy.org/windows/filters/15.txt'
	option adb_src_rset 'BEGIN{FS=\"[/|^|\r]\"}/^\|\|([[:alnum:]_-]+\.)+[[:alpha:]]+[\/\^\r]+$/{print tolower(\$3)}'
	option adb_src_desc 'combined adguard dns filter list, frequent updates, approx. 17.000 entries'
	option enabled '1'

#1337

Awesome :+1: that was quick! I've updated the regexp for Adguard and removed the whitelist for amazonaws.com. A /etc/init.d/adblock query amazonaws.com didn't return any results, which is good!

If I don't report back on this, consider it fixed :innocent:


#1338

Note: using LuCI to sysupgrade from master builds between r8530-41770add03 of Nov 26th and r8614-78ca6a5578 will fail, or at least the shown SHA256 checksum is wrong.

The issue got fixed a minutes ago by https://github.com/openwrt/openwrt/commit/9808bd279927bcd2d3a78d19a55229b93bbbcf05 , so sysupgrading from newer builds is again possible in normal fashion.

If you are using a build from that time period, you can either

  • use SCP to transfer the image file to the router and do sysupgrade from console, or
  • do the simple one-line edit for /lib/upgrade/fwtool.sh to mimic 9808bd27 (removal of the recently added -t option)

Note, the issue concerns likely all routers with metadata at the end of the sysupgrade image. At least ipq806x, and based on the LuCI issue report also ath79, but likely other targets, too.


#1339

How is irqbalance supposed to be run?
irqbalance --oneshot doesn't seem to do much?

running irqbalance as a dawmon does more but I had troubles with wifi interface going missing, not sure if it was irqbalance fault tho'.


#1340

I haven't used it much myself, but a safe approach is maybe to use oneshot mode after some traffic has already passed through the router, so that there is some data for the one-time balancing.

I remember from earlier discussions that dissent1 (or somebody) had some trouble with daemonised irqbalance.

Otherwise, you can naturally also manually adjust the IRQ affinities to CPU cores, so using irqbalance is not the only way to distribute the IRQ load.


#1341

Ok, I'll just run it for a while as a daemon and see how it behaves. No loss of wifi today, could've just been a hiccup.


#1342

Hnyman, what would be the best way of adding in some other packages to install during the build process? I've tried various way and I always get an error during the build. I can complete a normal build with just your changes with no issues though.

I'm trying to add;

cshark
luci-app-cshark
strongswan-full
stromgswan-mod-kernel-libipsec
wireguard
wireguard-tools
kmod-wireguard
luci-app-wireguard
luci-proto-wireguard
transmission-cli-openssl
transmission-daemon-openssl
transmission-web
luci-theme-openwrt

I know you mention that adding custom packages to the snapshot can be risky but I'd like to at least be able to work out the issue.

I'm just trying another build and then when (not if, I have no confidence at this point) it fails I'll share the build.log.


#1343

sounds strange.

You need to look at the build logs, then. If you use the singlecompile.sh script, you no not get mixed with parallel compilation and you should see rather clearly, which package breaks the build.

You can use quite normal "make menuconfig" to add packages. Add one by one, and compile to test the compilation. If necessary, do first a "make clean".

E.g. add all wireguard related packages and compile. If ok, copy .config into backup as a working one, and add strongswan stuff, and clean and compile. ...

In the long run the correct way is to add the packages to the .config.init recipe and always use copy that fresh into .config before launching the build process.


#1344

Interesting, that’s the way I had been doing it initially by adding the various CONFIG_PACKAGE lines at the bottom of .config.init before doing cp .config.init .config

It’s running now and I’m tailing the build log while I work so I can keep an eye on what might be triggering the error. I’m doing ./hnscripts/singlecompile.sh for now as per your instructions further back in the thread regarding suppressed errors. Hopefully I’ll see what’s up.