Build for Netgear R7800


#1283

Have you tried disabling the CPU powersave / frequencency scaling options like you discussed a month ago?


#1284

yes, but then the device starts crashing after a while :frowning:


#1285

is there any news in last master for samsung compatibility?


#1286

any news in last master for samsung compatibility?

What Samsung compatibility?
There is nothing Samsung-specific wifi stuff in my build.

I guess that this is fallout from the ath10k-ct change, where master is now using this "-ct" driver and firmware. But in order to get any reasonable feedback to that, you should open an own thread, as there is nothing specific to my build or even to R7800 by itself (but possibly to the combination of QCA9984 and ath10k-ct).


#1287

oh well, sorry, i was just wondering if anything got fixed in master (not "your" master) for the ath10k-ct with samsung
last time i tried your master build (i think the one from octomer 11th) it was just terrific..


#1288

Sadly there has been no relevant commits to ath10k. My own experience from this -ct is crappy so far, but I hope that @blogic had a valid reason to switch the default to -ct, and our usage of it can improve the driver.

(I have wondered if I should revert back to the regular ath10k, as I was pretty happy with the earlier regular version.)


#1289

That’s a very nice cat.. however.. why he/she is always near the router, isn’t it because the router gets too hot lol


#1290

actually i think now ath10k is better than ct with the kernel firmware update...
i notice lots of problem with ct firmware personally...


#1291

would it be possible for you to put on your Dropbox the last version buildt with regular ath10?
i'd like to install it, waiting for some good news on ath10k-ct..

Oh, taking advantage of your disponibility :slight_smile: could you please confirm you can use on your master the openssh-sftp-server?
thanks a lot :slight_smile:


#1292

I think you should go with the latest official firmware and the non-ct driver for the time being imho.

Yes, he likes it because it's warm, when he was just a small kitten, he found that place the first night he was new at my place.


#1293

Hi,

I have installed netperf on my router running the latest firmware and also flent on my local machine (iMac 2017, 802.11ac). I am curious to know what could cause latency spikes between my computer running flent and the router as demonstrated in the latency report below:

flent_latency_report

I'd appreciate any feedback.
Andrejs


#1294

Disable all location services and try again.


#1295

Just did and it seems to be the same:

flent_latency_report


#1296

Yeah,
I have now built again the "normal" "old" ath10k instead of the current default ath10k-ct, which seems somewhat problematic.

master-r8392-3dba852547-20181030-ath10k


#1297

i'm refreshing your dropbox folder waiting for this lol :slight_smile:
thanks a lot!!


#1298

Now the files are there.
Apparently I forgot to copy them initially.


#1300

up and running with that.
You are number one :slight_smile:
Eventually, also the SFTP server started to work again


#1301

8392 is working good. Before the 5ghz would drop constantly, and the 2.4ghz wifi bars would be white with 0 noise, which clearly is a sign that it wasnt working properly.


#1302

@hnyman
Downloaded the latest buildscript and patches from you. Now I get

patching file tools/ccache/Makefile
Reversed (or previously applied) patch detected!  Assume -R? [n]
Apply anyway? [n] y
Hunk #1 FAILED at 8.
1 out of 1 hunk FAILED -- saving rejects to file tools/ccache/Makefile.rej
patching file tools/ccache/patches/100-honour-copts.patch
Reversed (or previously applied) patch detected!  Assume -R? [n]
Apply anyway? [n] y
Hunk #1 FAILED at 1.
1 out of 1 hunk FAILED -- saving rejects to file tools/ccache/patches/100-honour-copts.patch.rej

#1303

My own PR got accepted and merged in to Openwrt main sources, so the patch included in my yesterday's source is now unnecessary.
https://github.com/openwrt/openwrt/commit/b0a2e60793f194a7a33e93a12f9ca5f2ae410529

Just edit the main source patch file and remove the section regarding ccache.

(or wait for my next build source, where there will again be a clean patch)

EDIT:
you can take
master-r8407-dceee8cc09-20181101-ath10k