Build for Netgear R7800


#1143

Do you have a script to clean the build environment after the last image I created? Also, how long does it usually take to build a new image? The last build took 2 hours. Is that normal?


#1144

Normally the plain "make clean" is enough. That cleans the build itself.
The first time build takes long as also the tools and toolchain get compiled and that takes major part of the time. That full toolchain + firmware build takes maybe 70 minutes for me. The next build only does the actual firmware build and takes some 20 minutes.

You should read the wiki articles on build commands etc. E.g. various clean options are explained there.


#1145

I have read the wiki's, and can't find any information on how to add kmods to the build. (kmod-usb-net, kmod-usb-net-rndis, kmod-usb-net-cdc-ether, usbutils udev) other than running "make menuconfig". Is there a way to add them to your build environment? (insert into config file?) Sorry about all the questions.
Thank you.


#1146

For one time build and teasing, make menuconfig is naturally the easiest. If I select some package for permanent inclusion, I then add it manually to the small recipe .config.init, which I always copy as the new .config before as build.

./scripts/diffconfig shows you pretty easily the packages & config items included currently in the build. Note that you only need to add the "key" package to .config, not its dependencies that get pulled in automatically.


#1147

Hi, I just tried building this build (18.06) using the newBuildroot.sh script from Aug 12 and saw this error below. Is that ok to ignore? I do not think it was there before and it now happens at the end of the feeds update update -a.

Updating feed 'telephony' from 'https://git.openwrt.org/feed/telephony.git;openwrt-18.06' ...
Cloning into './feeds/telephony'...
remote: Counting objects: 259, done.
remote: Compressing objects: 100% (247/247), done.
remote: Total 259 (delta 21), reused 29 (delta 0)
Receiving objects: 100% (259/259), 169.51 KiB | 93.00 KiB/s, done.
Resolving deltas: 100% (21/21), done.
Checking connectivity... done.
Create index file './feeds/telephony.index' 
ERROR: please fix feeds/telephony/net/freeswitch/Makefile - see logs/feeds/telephony/net/freeswitch/dump.txt for details
Collecting package info: done
Collecting target info: done

#1148

Likely a bug in the telephony feed contents. Nothing to do with my build or scripts.

Possibly need to be fixed with something like https://git.openwrt.org/?p=feed/telephony.git;a=commitdiff;h=3466a118b5dbcda016453ab5b0f388345da7a76a

Inquire at the telephony feed.

(EDIT: or you can naturally just disable the telephony feed in feeds.conf.default )


#1149

i managed to get this working (build for D7800), and the leds do work (though maybe this is fixed on master too). you need to change the the profile (to D7800), and swap the packaged firmware from QCA9984 to QCA99x0 or the wireless won't work.


#1150

I have a weird issue, not sure if it's openwrt or build related but i'll ask here.
When i SSH remotely from work into one of my linux servers at home (ssh port is forwarded WAN-LAN) and run ps the output of the ps command is very slow and pauses.
Nevrer had this problem before I got the R7800, what could be causing this?


#1151

MAC collision and some packets getting lost?

Sounds strange that nay trouble should affect only "ps", but not the other commands.

In any case, there is nothing special about ps or network connectivity in my build.


#1152

If it hanging with things like "dmesg" or "logread" too? Basically hanging for every command producing large output in short time? If so then this is an indication of a PMTU discovery problem.


#1153

Yes, dmesg also.
Any idea how to fix or troubleshoot it?


#1154

Make sure that your wan zone has the mtu fix option set


#1155

I set it to 1500, no change in behaviour.
I also tried LAN.


#1156

I mean the firewall mss fix, not the interface mtu


#1157

Sorry for spamming the thread, same thing happens with mss clamping is enabled. Hmmm.
It's enabled for both wan and lan now.

EDIT:
Allowing ICMP fragmentation LAN > WAN fixed it, i setup a custom rule for it.


#1158

Yeah, was about to ask about that. Never block ICMP control traffic!


#1159

Can't say I have, it's the default rules that came with this build a few months ago. Maybe they're updated in newer releases tho'.


#1160

Hmmm. My builds have always had the default firewall ICMP rules. Nothing special.
Which rule you added?


#1161

temp

Adding this seems to have helped.


#1162

But the question is what prevented it for you originally? To my knowledge the default forwarding rules allow all forwarding from lan to wan. Do you have some firewall restrictions in place?