Build for Netgear R7800


#1123

Wiki explains how to format static DHCP entries
https://openwrt.org/docs/guide-user/base-system/dhcp_configuration#static_leases


#1124

More about how you count certain items in a text file.


#1125

This is going to be a bit OT, but i was looking for the info about external hosts --> ip bindings, without mac address. I think it is not described in the Wiki.
It was done via dnsmasq.conf before, but there are other options that might be better.
Thanks.


#1126

Hmm. external hosts?
So not about host-specific DHCP address allocation, but some DNS & hosts address database? More like /etc/hosts stuff?
If you have a /etc/dnsmasq.conf, it should still work like earlier.


#1127

I know I said earlier that I could live without USB tethering, but my cable service drops out on occasion , and I have to resort to tethering through my computer. I've been reading on how to build my own firmware, but haven't got to that point yet.
Would it be hard to included these kmod's in the next master build?

kmod-usb-net, kmod-usb-net-rndis, kmod-usb-net-cdc-ether, usbutils udev

Thanks hnyman.


#1128

Yah, I reported elsewhere that cake/piece_of_cake on 18.06/R7800 doesn't keep up with high speed service.


fq_codel/simple plus aggressive CPU scaling improved SQM a lot to the point that it kept up with my line speed


#1129

I am running the latest master with no modified settings. 5ghz running on channel 153/80mhz using wpa2 forcing aes. My family have the Samsung S7 edge phones and Galaxy tablets...when we use the 5ghz wireless I notice in Luci they have a connection of 433mbit all seems fine until you use youtube. It will work for around 1 min then just drops. I can reconnect with no issues and do it over again. I have tried lower and upper channels with the same result. If I use 40mhz then all is well but I want to use 80mhz. 2.4 wireless works with no issues. I also have a different tablet (no name brand) that connects at about 135mb to the 5ghz and never drops. Am I looking at a samsung side issue or is there something I can adjust/tweak on the router to be able to resolve this issue? Phones are stock and I really do not see how I can adjust anything on them. Other than that I am loving these builds, thanks so much!


#1130

Google has this gimmicky protocol called QUIC which forces Youtube traffic thru ports 443 UDP and 80 UDP. In my experience, WiFi is less stable with it.

In my routers I always go to firewall settings and create two rules - to disable UDP traffic on ports 80 and 443. It affects nothing except blocking QUIC, and forcing Google to use TCP on 80/443 like the rest of the web.

IMO it makes Youtube more stable on the phones.


#1131

Thanks. I will do that but since my post I determined that any high traffic to these S7Edge phones causes them to drop. I tried downloading test files and sure enough about 200mb into a 500mb file it bombs. so its not just YT... Almost time to upgrade phones anyway.


#1132

In fact I am mixing up "host-specific DHCP address" and "DNS hosts address database", there are docs out there which tell to use dnsmasq somehow. On linux / windows it is /etc/hosts but for openwrt the docs tell to add addn-hosts=/etc/dnsmasq.hosts to dnsmasq.conf and there the ip host is maintained.


#1133

with fq_codel piece_of_cake (I understood tha fq_codel is better on r7800) on 18.06/R7800, cable connection I get
Bufferbloat improvement from D -> A (250ms --> 12ms)
Speed decreases from 51/2 to 42/2 megabits/s

I am wondering if this improves my PS4 fortnite kill rate. :slight_smile:


#1134

Sorry to use your thread about this :slight_smile: I'll move into that other thread I just found. Thanks for the input.

FYI Absolutely love your build. Thanks for all the hard work of sharing your personal build.


#1135

bit of a silly question, will this build work on a D7800? obviously the modem etc won't work but i believe that doesn't work in eg the released 18.06 anyway.


#1136

No, while it's similar (just like the r7500v2 or the nbg6817 would be similar), it's still a different device and requires a dedicated image (built from the same source, as in multi profile/ per device rootfs, if you desire that).


#1137

so if i get the sources and change the target/profile and build it should work?


#1138

Following the general opensource mantra, "if you break it, you get to keep the pieces"...

There is one device specific change in the patch set which won't work/ behave on routers other than the r7800, the WPS setup - other than that, it should compile into something reasonable for all ipq806x devices (other targets could need additional changes), but so would plain OpenWrt master without any changes.


#1139

could you point me to that change? is it the hotplug bit? i don't use wps anyway.

i was hoping that the leds (amongst other things) would work better with this build.


#1140

Trying to build my own firmware, but getting this error when I run updateNmake.sh

n6oli147@n6oli147-VirtualBox:~/R7800/master/hnscripts$ ./updateNmake.sh
...update main source...
Already up to date.
...update feeds...
./updateNmake.sh: line 9: ./scripts/feeds: No such file or directory
Updating the feeds failed.

Why is that?


#1141

You don't run the build script from the buildscript directory, but from the build root with path.

hnscripts/updatenmake.sh

I just placed the command there instead of polluting the root dir. You still run all build commands from the root dir.


#1142

Thank you hnyman. That worked great. I'm really enjoying the learning process.