Build for Netgear R7800

No, piece/layer_cake always use cake qdisc. That is hardcoded.
see e.g. https://github.com/tohojo/sqm-scripts/blob/master/src/piece_of_cake.qos#L14

I don't think that cake would be more CPU intensive than fq_codel, But cake is still a bit experimental, while fq_codel is part of the official Linux kernel sources.

You can change the script and qdisc at the same time in LuCI and then just restart SQM.

Hi, my ISP using VLAN 500, I wonder if I have to set it up like VLAN 500 for WANt CPUt and VLAN 1 for the rest or just a VLAN 500 for all?

Okay. Got it. Thanks for the info, hnyman!

No idea.
And the question has no direct relation specifically to my build.

Question: do the latest stable builds contain dissent's PCIe fixes? I know master branch has them, but I'm not sure if stable does.

No, I have not backported the fixes to 17.01

1 Like

Thanks for the reply. Do you have any plans to backport them?

I've heard great things from DD-WRT users—dissent's patches have fixed numerous load and latency spike problems seen with ipq806x on certain kernels.

I have mainly kept the 17.01 build as a reference point close to the official source. So I have no immediate plans.

I usually run the master build, which is quite stable for my needs. And that has the fixes.

1 Like

@hnyman I can't find the latest master release in your Dropbox. Have you uploaded it?

Now I have done that. :wink:

1 Like

Just a heads up and a :+1: to @hnyman
I've used your WNDR3x00 builds for quite some time, gracefully used your build stuff to learn.

And another thank you for sharing your endeavors with the R7800 with us all again. I've ordered a R7800 myself. It seems like a great platform, receives good comments on reviews with stock firmware and seems quite a favorable platform on LEDE too :+1:

I've followed the exploration topic, good stuff is going on there. Awesome! If the postal services have their usual routine, my network should be running on the latest master build tomorrow evening with the new ath10k blob that was committed yesterday :innocent:

Hi. I'm new to the R7800, but not to OpenWRT/LEDE. I recently moved from the WRT1200AC and would like to compile my own build, using your environment. Basically, there are a few packages that I'd like to have built in (OpenVPN, etc.) I'm getting errors during compilation after running the script. What information would you need to see in order to tell me what I'm doing wrong? That is, of course, aside from the actual error message. Does your build script generate a log that I could post here? Thanks!

look into the logs directory in the build system. It contain the general log plus packet-specific logs.

I finally started using my laptop that wifi card only support 2.4ghz capable...I've tweaked the wifi 2.4ghz setting and channel sets at 6. I got 40/10 from 10/10 (it was on channel 11 by default)...it seemed not too bad, however, I ran dslreports. The bufferbloat was so bad. It looks like QoS isn't working with 2.4ghz at all. 5Ghz and wired both worked fine. In SQM setting, the interface is set at eth0.2. My ISP is 100/10. (tested on my PC- 113/12Mbps with bufferbloat A grade from dslreports.) I'm not sure if I missing anything....any suggestion?? Also, I'm getting a newest atheros wifi card for my laptop on this saturday. Thanks!

I'm running on the R7800-master-r6011-805f756d6e-20180206-2323-sqfs-factory.img build of @hnyman since a few days. It all seems to run fine except I can't get IPv6 working at all. A 6in4 tunnelbroker doesn't work, but even something as simple as ULA addresses don't work. I've compared the configs from my old WNDR3700v2 which is running the LEDE 17.01.4 release with hnyman's patches for this particular device. That worked out of the box with IPv6 ULA and a WAN6 tunnel broker set up. This new build from master doesn't seem to have a working odhcpd?

I've figured out that odhcpd is replaced with a smaller odhcpd-ipv6only since a few months but that the config in /etc/config/dhcp and /etc/config/network should work exactly the same between odhcpd and odhcpd-ipv6only.

When I run odhcpd-ipv6only in the foreground I see only this:

root@OpenWrt:/etc/config# /usr/sbin/odhcpd -l 7
Log level set to 7
odhcpd[4330]: Using a RA lifetime of 0 seconds on br-lan
odhcpd[4330]: Sent 64 bytes to ff02::1%br-lan

I believe the relevant config's are:

/etc/config/network:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdad:be5a:04f7::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth1.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option dns '9.9.9.9 149.112.112.112 2620:fe::fe'
	option ipaddr '192.168.1.254'
	option ip6assign '64'

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'dhcp'
	option peerdns '0'
	option dns '9.9.9.9 149.112.112.112 2620:fe::fe'
	option delegate '0'

/etc/config/dhcp:

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option expandhosts '1'
	option cachesize '1000'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	option localservice '1'
	option serversfile '/tmp/adb_list.overall'
	option local '/thuis/'
	option domain 'thuis'
	option nonwildcard '0'

config dhcp 'lan'
	option interface 'lan'
	option dhcpv6 'server'
	option ra 'server'
	option start '80'
	option limit '250'
	option leasetime '24h'
	option ra_default '1'
	option ra_maxinterval '480'
	list domain 'thuis'
	list domain 'local'
	list dns ' fdad:be5a:4f7::1'
	option force '1'
	option ndp 'relay'
	option ra_management '1'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '7'

The br-lan interface has a ULA IPv6 address:

br-lan    Link encap:Ethernet  HWaddr 8C:3B:AD:2D:25:24  
          inet addr:192.168.1.254  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fdad:be5a:4f7::1/64 Scope:Global
          inet6 addr: fe80::8e3b:adff:fe2d:2524/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:496663 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1714549 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:185157847 (176.5 MiB)  TX bytes:2426644778 (2.2 GiB)

Could it be that this particular build has an issue with odhcpd-ipv6only from a recent commit in master?

--EDIT--
When I use Wireshark to capture ICMPv6 packets on the old WNDR3700v2 I see Router Advertisement packets, but not on the R7800, I only see Neighbour Solication and - Advertisement.

I am running r6022-175538ffdb myself, and I have a quite normally working ipv6. And I did have ipv6 also with the previous build.

But you seem to have rather complex ipv6 DNS config, and at least one config error:

The leading space inside the ipv6 address parameter may possibly lead into faulty option parsing. And possibly odhcpd does not start.
Have you tested /etc/init.d/odhcpd restart ? (maybe some error message gets visible)

The default switch from odhcpd to odhcpd-ipv6only in master only removed the ipv4 capabilities from the odhcpd binary. As you are using the default dnsmasq to assign ipv4, there should have been no change for you.

@hnyman your eyes are better than mine!

The space in list dns ’ fdad:be5a:4f7::1’ was the problem!

:+1:

odhcpd ran "just fine", didn't complain about something not parsing. I guess this is good to know for future reference: double, triple check for typos and don't assume every daemon process will suggest something like a typo.

Getting this error, in your latest build 6022, causing disconnects and packet loss any ideas? in kernel log
pppoe-wan: renamed from ppp0
Regards

Alright, I loaded r6022, no glaring, critical issues thus far.

However, some interesting parts come from the kernel log.

First, is this bit of logged data normal?

[   19.759359] ath10k_pci 0000:01:00.0: Direct firmware load for ath10k/QCA9984/hw1.0/firmware-6.bin failed with error -2
[   19.759400] ath10k_pci 0000:01:00.0: Falling back to user helper
[   32.563214] firmware ath10k!QCA9984!hw1.0!firmware-6.bin: firmware_loading_store: map pages failed

Next, I've never seen this much entropy before. Not that I'm complaining though, since more entropy is better for performance.

There are some ath10k errors, as usual, but that's ath10k FOSS, not OpenWRT/LEDE:

[ 2174.406451] ath10k_pci 0001:01:00.0: Unknown eventid: 36925
[ 2320.759108] ath10k_pci 0001:01:00.0: Unknown eventid: 36925
[ 2320.810932] ath10k_pci 0001:01:00.0: Unknown eventid: 36925
[ 5501.148829] ath10k_pci 0001:01:00.0: Unknown eventid: 36925
[ 5511.791959] ath10k_pci 0001:01:00.0: Unknown eventid: 36925

The wifi driver loading items in log are normal.

But the unknown event thing is new. Might be related to the ath10k firmware update that is being tested.

1 Like