Build for Netgear R7800


As you have a few performance intensive applications using SSL you might want to enable the O3 option for OpenSSL.

Thanks for the info. Wen't back to 17.0.4 and Strongswan works there. Took me quite some time to get all the packages you installed in your build...

No one know why my 5ghz wifi dont start?
I added logs.
Noticed it happens on all DFS channels. LEDE 17.0.3 which is last one I had DFS worked fine.

For using DFS channels, the kernel needs to scan for DFS over at least one minute, before the interface can be enabled.

Could be a wonky option in /etc/config/wireless.

Just to make sure. do a backup, remove that file and do a fresh wireless configuration through luci.

Are you still using my build from LEDE 17.01.3 times? If so, please update.

sorry was typo it was your latest build with openwrt changes in.
wont have time to try again until after new year.

Hi Hnyman, Thank you for your wonderful build! However I met the same issue when installing shadowsocks. The developer said I should include kmod-ipt-tproxy when building kernel. So I'm hoping if there's anything I can do to rebuild this kernel or if you could include this package in future releases. Thanks a lot!

The issue I met is " iptables-mod-tproxy or ip is missing".


I've read your instruction, should I just add +CONFIG_PACKAGE_kmod-ipt-tproxy=y in main.patch and then follow your rebuild instructions? Should I build on the router or just on my Mac?

tumble really bad

Just build it on your Mac. (makes no sense to build onthe router, as there is not enough disk space for the build system.)

May be possible in the Mac itself (as MacOS is an Unix variant, but I am used to build in Ubuntu in a Virtualbox instance. If you build on MacOC, you may need to changes the pre-requisite packages a bit.

Thank you for answering my question. I appreciate it.

I will check those prerequisites. And as I've mentioned in my post, I hope to install iptables-mod-tproxy on my router, I guess the only thing I should do is to add +CONFIG_PACKAGE_kmod-ipt-tproxy=y to your main.patch before I build. Am I right?

Yes, (but note that you also need to adjust the number of lines to be added, in the patch after +++ )

Much easier is to just install the build environment as it is, and then use "make menuconfig" to select that kmod to be built into the firmware.

Or even better, as your goal is actually shadowsocks, use menuconfig to select shadowsocks to be included in the firmware image. That selection will also pull in the dependencies (like that kmod-ipt-tproxy)

Thanks a lot. I'll try make menuconfig first.

Hi Hnyman, finally I managed to build the image using your script and adding that kmod-ipt-tproxy to it. Now I'm "making the world" XD.

Thanks for your help and wish you all the best.

@nekromantik, same problem for me. I TFTP-flashed hnyman's master-r5530-build, and I could not get the 5GHz-wifi up, whatever WiFi-settings I tried.
Then I tried the 1701-r3784-build and wifi is working fine (as is stated in hnyman's thread).
If required, I can re-flash r5530 and capture and post the log, but only sometime after X-mas.

I used the latest version and 5ghz works on that one. @bouwew

So the lede-r5629-23bba9cb33-20171227-pcie-fix2-test is working right?. Should i upgrade from the stable branch?. I would like to test the k4.9 performance over 4.4 but i cannot be without wifi.

Still all the changes are in nbd's staging area ....;a=summary

Works for me.
It is easy to jump between master and 17.01 builds (as there are no material config differences), so you can test 4.9 and revert back to 17.01 if it does not work ok for you.

Confirmed. 5Ghz is now working for me as well.
And SQM can now be set-up normally :slight_smile:
Thanks for the updated build, hnyman!

1 Like

When using sysupgrade to do a update, is there any way to keep packages that you installed that was not built into the firmware? I find I have to re add everything I added after update and keeping settings.