Build for Netgear R7800

Now it has the correct files.
Thanks for pointing out the copy error.

There is no special thing to say about my build's 17.01 vs master, so the generic answer in wiki is quite valid. (My snapshot build from master do include LuCI, but other the following is valid):

I have not used samba, but I think that you should be able to install the package quite ok with opkg.

With the 2 latest master builds I'm getting a lot of those warnings: "kern.warn kernel: [66610.178657] ath10k_pci 0001:01:00.0: Invalid VHT mcs 15 peer stats"
Don't know what those are doing and I didn't find too much on it. (2 users mentioned it aswell in the exploration thread at some point)

Haven't tried factory reset and the router seems to be working fine. Just figured I'd mention it.

It is related to the ath10k wireless driver and the QCA9984 firmware. No known fix, yet. I see the same warnings myself.

1 Like

Hi, first of all I wanna say thank you for building us such a great firmware. I tried the latest master version from you, and found the wifi transfer speed is much slower than the latest 17.01 version, it’s about 18MB/s vs 37MB/s from my NAS to iPhone X, AC 5GHz channel 104, 80MHz, 27dbm(AU) for both. Signal is ok while both are about RSSI -53dBm, but when comes to real life transfer, it’s much much slower. Any idea? Thanks.

Not really. The build has standard wifi features. There have been some performance problems in the master lately (for some usres), but recent pcie patches have already helped things somewhat.

Much of the performance discussion is in R7800 exploration thread:
Netgear R7800 exploration (IPQ8065, QCA9984)

I've reverted the IPV6 settings in DHCP server settings and then restarted both router and cable modem. Now it's working. It's been up for 10 days right now. I have a question about SQM QoS. I have default setting is fq_codel and simple.qos. It worked great, bu what if I want to try to switch simple.qos to piece.of.cake.qos while fq_codel is enabled. Would it works? Or I have to change fq_codel to cake first before changing simple.qos to piece.of.cake.qos then apply? Cake is CPU intensive, does it? Thanks.

No, piece/layer_cake always use cake qdisc. That is hardcoded.
see e.g.

I don't think that cake would be more CPU intensive than fq_codel, But cake is still a bit experimental, while fq_codel is part of the official Linux kernel sources.

You can change the script and qdisc at the same time in LuCI and then just restart SQM.

Hi, my ISP using VLAN 500, I wonder if I have to set it up like VLAN 500 for WANt CPUt and VLAN 1 for the rest or just a VLAN 500 for all?

Okay. Got it. Thanks for the info, hnyman!

No idea.
And the question has no direct relation specifically to my build.

Question: do the latest stable builds contain dissent's PCIe fixes? I know master branch has them, but I'm not sure if stable does.

No, I have not backported the fixes to 17.01

1 Like

Thanks for the reply. Do you have any plans to backport them?

I've heard great things from DD-WRT users—dissent's patches have fixed numerous load and latency spike problems seen with ipq806x on certain kernels.

I have mainly kept the 17.01 build as a reference point close to the official source. So I have no immediate plans.

I usually run the master build, which is quite stable for my needs. And that has the fixes.

1 Like

@hnyman I can't find the latest master release in your Dropbox. Have you uploaded it?

Now I have done that. :wink:

1 Like

Just a heads up and a :+1: to @hnyman
I've used your WNDR3x00 builds for quite some time, gracefully used your build stuff to learn.

And another thank you for sharing your endeavors with the R7800 with us all again. I've ordered a R7800 myself. It seems like a great platform, receives good comments on reviews with stock firmware and seems quite a favorable platform on LEDE too :+1:

I've followed the exploration topic, good stuff is going on there. Awesome! If the postal services have their usual routine, my network should be running on the latest master build tomorrow evening with the new ath10k blob that was committed yesterday :innocent:

Hi. I'm new to the R7800, but not to OpenWRT/LEDE. I recently moved from the WRT1200AC and would like to compile my own build, using your environment. Basically, there are a few packages that I'd like to have built in (OpenVPN, etc.) I'm getting errors during compilation after running the script. What information would you need to see in order to tell me what I'm doing wrong? That is, of course, aside from the actual error message. Does your build script generate a log that I could post here? Thanks!

look into the logs directory in the build system. It contain the general log plus packet-specific logs.