Build for Netgear R7800

The whole flash is not available in R7800. You need a hack.
Netgear R7800 - only 19MB Flash available?

You can replicate my build and easily add new packages to the firmware compilation.

You could also read this for R7800 feature discussion:
Netgear R7800 exploration (IPQ8065, QCA9984)

Have you tried it? I have build a similar asus rt-ac58u firmware. sysupgrade -F gives (with set -x)

`ubus call system sysupgrade {
"prefix": "/tmp/root",
"path": "/tmp/lede-rt-ac58u-r1057-ed83357-ipq806x-RT-AC58U-squashfs-sysupgrade.tar",
"command": ". /lib/; include /lib/upgrade; do_upgrade_stage2"

Command failed: Unknown error
sysupgrade -F <any_junk> works. I need to resore the router after it. Sorry for offtopic with asus router.

Yes, I downgraded my R7800 to 17.01 using "sysupgrade -F"

Too long filename?

Super! Correct! Thank you! Thank you! Thank you!
Making firmware file name shorter solved the problem.

Says access denied when I clicked it

correct link: Netgear R7800 - only 19MB Flash available?

1 Like

Hi hnyman.

I got my new Netgear R7800 from old ASUS RT-AC66R with ASUS merlin and uploaded this R7800-lede-r5882-dd975d15a7-20180117-1758-sqfs-factory.img from your dropbox via tftp2.exe and no problem at all. My internet is at full speed, both 2.4ghz and 5ghz wifi are working fine. However, there is the only one problem I've been dealing with is trying to make ipv6 working permanently. I'm still very new to LEDE, still learning how to use it.

my ISP is Spectrum, 100/10Mbps. Btw, I used to had both ipv4 and ipv6 working permanently with ASUS merlin for long time.

Tried stateless. It worked for a few minutes then dropped. Also tried stateful+stateless. It's about the same thing. I still don't understand how ipv6 configuration works. I tried to read the LEDE ipv6 configuration documentation, but it's still confusion for me.

If your ISP supports prefix delegation, the default settings without any changes should be ok for you.

How do I reset the settings back to default? "Reset" would do it?" I'm not sure if I'm doing it right.

After you reset to defaults try running:
ifconfig eth0 promisc

I have a couple of questions:

  1. If I install the Hnyman R7800 firmware on my router which one should I use? I see "master" and "lede-17.01" but it really does not state the advantages/disadvantages of one over the other.

  2. I see that the Hnyman builds support NTFS partitions for external drives. Is Samba support (Version 1, 2, or 3) provided? If not is it hard to add? I have Windows 10 PC's and use the Netgear Readyshare a lot and do not want to loose the Network drive.

Thank you.

The upload to the master-r5952 Dropbox folder seems to be the wrong one. Only WNDR3700 and 3800 files are in there.

Now it has the correct files.
Thanks for pointing out the copy error.

There is no special thing to say about my build's 17.01 vs master, so the generic answer in wiki is quite valid. (My snapshot build from master do include LuCI, but other the following is valid):

I have not used samba, but I think that you should be able to install the package quite ok with opkg.

With the 2 latest master builds I'm getting a lot of those warnings: "kern.warn kernel: [66610.178657] ath10k_pci 0001:01:00.0: Invalid VHT mcs 15 peer stats"
Don't know what those are doing and I didn't find too much on it. (2 users mentioned it aswell in the exploration thread at some point)

Haven't tried factory reset and the router seems to be working fine. Just figured I'd mention it.

It is related to the ath10k wireless driver and the QCA9984 firmware. No known fix, yet. I see the same warnings myself.

1 Like

Hi, first of all I wanna say thank you for building us such a great firmware. I tried the latest master version from you, and found the wifi transfer speed is much slower than the latest 17.01 version, it’s about 18MB/s vs 37MB/s from my NAS to iPhone X, AC 5GHz channel 104, 80MHz, 27dbm(AU) for both. Signal is ok while both are about RSSI -53dBm, but when comes to real life transfer, it’s much much slower. Any idea? Thanks.

Not really. The build has standard wifi features. There have been some performance problems in the master lately (for some usres), but recent pcie patches have already helped things somewhat.

Much of the performance discussion is in R7800 exploration thread:
Netgear R7800 exploration (IPQ8065, QCA9984)

I've reverted the IPV6 settings in DHCP server settings and then restarted both router and cable modem. Now it's working. It's been up for 10 days right now. I have a question about SQM QoS. I have default setting is fq_codel and simple.qos. It worked great, bu what if I want to try to switch simple.qos to piece.of.cake.qos while fq_codel is enabled. Would it works? Or I have to change fq_codel to cake first before changing simple.qos to piece.of.cake.qos then apply? Cake is CPU intensive, does it? Thanks.

No, piece/layer_cake always use cake qdisc. That is hardcoded.
see e.g.

I don't think that cake would be more CPU intensive than fq_codel, But cake is still a bit experimental, while fq_codel is part of the official Linux kernel sources.

You can change the script and qdisc at the same time in LuCI and then just restart SQM.