Build for Netgear R7800

[quote="Tusc, post:26, topic:316"]
Has anyone tried any openssl benchmarks with this router?
[/quote]I ran the benchmark for you and the results are in Netgear R7800 exploration (IPQ8065, QCA9984)

Thanks hnyman, I've gone out and purchased the r7800. Any recommended wireless settings? I'm coming from a WRT1900AC which didn't offer MU-MIMO. I'm wondering if there are any additional wireless settings. Thanks.

No special recommendations reagrding wifi.

(and please ask the generic device questions in the generic R7800 thread that I linked, and leave this thread for discussion about my build itself.)

Just loaded LEDE master: lede-r3128-b94177e10f-20170126 and it is working great. Thanks for your efforts Hyman! Glad someone is giving this router some love in the LEDE space.

Hello hnyman,

I flashed your firmware today on my r7800 and it seems very well made and really stable. Thanks so much for supporting that great piece of hardware with LEDE.

I just found following problems with version lede-r3189-12db207e9b-20170128:

  1. Only 19MB flash storage are available. Seems to be a problem with an existing partition for the netgear stock firmware. Is it possible to get access to the full 128MB?

  2. 160MHz channel bonding doesn't seem to work, the radio doesn't go up with it. 80MHz is working totally fine and more than enough, though.

[quote="eggplanter, post:32, topic:316"]
I flashed your firmware today on my r7800 and it seems very well made and really stable. Thanks so much for supporting that great piece of hardware with LEDE.
[/quote]You are welcome :wink:

[quote="eggplanter, post:32, topic:316"]
Only 19MB flash storage are available.
[/quote]Yes, that is true. I have answered that in Netgear R7800 - only 19MB Flash available?

I haven't tried activating that 70 MB partition, but that should be possible in theory, if you build your own firmware.

After updating to your latest version (with keeping the settings), DNScrypt was uninstalled. A package, which I installed on my own over LUCI.

Is this the wanted behavior? I have to install and configure DNScrypt after every update then. :frowning:

Yes, that is normal. Only config files are preserved in a sysupgrade but not the packages installed separately. (Note that dnscrypt's config files should be preserved, so there should be no need to re-config)

If you upgrade regularly and have several installed packages, you could e.g. write a small shell script and store it in /etc/config so that it gets saved and you can easily run that after a sysupgrade.

opkg update
opkg install dns...

Can you tell me what's the difference between LEDE master and LEDE 17.01?
Is one of them stable? Thanks. :slight_smile:

[quote="eggplanter, post:36, topic:316"]
Can you tell me what's the difference between LEDE master and LEDE 17.01?Is one of them stable?
[/quote]Both are stable for the user.
But 17.01 branch is the "official stable branch" that is slightly behind the master in development, and from which the 17.01 stable release will be made in February.

Currently there is no practical difference with R7800. Slightly different wifi driver firmware, but otherwise pretty equal.

Some people like the "stable version", so that is one reason why I build also that. Additionally I like to help testing the forthcoming 17.01 release.

@hnyman are the led's for this unit still unable to operate due to limitation of driver? I am potentially in the market for a router, and have been eyeing this one.

Any other things to know coming in?

Other LEDs work as originally intended, but as the wifi status LEDs can't be controlled normally, the wifi status is still shown via wifi on/off and wps button LEDs in my build.

Otherwise everything works as expected.

(and like I have said several times, the TFTP recovery mode into u-boot by Netgear makes a possible unbricking really smooth.)

Ah, so the actual 2.4 and 5.0 led's on the unit DO actually light up. They just do not "blink" to simulate load/activity?

No. The original wifi status LEDs are dark.

Got it, thanks.

What is needed for us to be able to add this support. Is it a hard limitation? Or just needing to take the time to map the GPIO or triggers?

It has been discussed in the other R7800 threads here, Openwrt and ddwrt. Apparently the OEM software controls them separately, not via gpio. Likely the support will not be added in near future.

1 Like

Hello again :wink:

I use your great firmware with two R7800, one of them is a dumb AP and the other my router.

Sadly I have problems with roaming, my clients (Android devices, a macbook, windows notebooks) won't connect to the next AP. They get connected to one of them and stay with it.

Both R7800 have the same SSID and passwords configured. Following config is different on each:

Router: Connected to WAN (getting DHCP from ISP), channel 36 for 5GHz and 11 for 2,4GHz
AP: Disabled firewall, miniupnp and ddns (Should I disable dnsmasq, too?), channel 100 for 5GHz and 1 for 2,4GHz

Everything else is configured identical.

Can you give me some tips?

Google Wifi Roaming Aggressiveness Settings (ie, its your client devices configuration)

Assuming that the routers are connected via LAN ports, you should likely disable dnsmasq on the slave device "AP" and set it just to have DNS and gateway to the first main router. But I haven't tried multi-router roaming with R7800 as only have one. With my earlier ath9k WNDR3700s I also tried WDS configs, but I am not sure how that would work with ath10k drivers.

I think that it is rather typical that the wifi clients stay connected the device they first connect with.

You might ask this in a separate thread, as I don't think that this is device-specific.

That's normal. For roaming you should use 802.11r protocol.
Sample config
Wiki look for fast bss transition options

1 Like