Build for Netgear R7800

Possibly the recent wifi VHT160 fix that I included into my build a week ago, is probably the only real reason.

There has also been the bump to kernel 5.10, but that did not bring much new by itself. (The forthcoming DSA switch wil lthen change more things, but even that will not change anything for the basic router use (without VLANs)).

1 Like

Thank you hnyman,
your builds are running great for me for several months. i am looking forward to DSA. would it be possible to create a test build DSA + VHT160 fix.
I have already tried DSA. I see with it minimal improvement but it does bring advantages

Based on my tests VHT160 doesn't bring performance gain and is causing flaky connectivity to Apple stuff.

I am running very good version
Firmware Version OpenWrt SNAPSHOT r17520-5ef4608c02 / LuCI Master git-21.226.86205-376af36, Kernel Version 5.10.64
Meanwhile, I am going to install gpiofan control via USB port, that requires 5.10.75-1 - Kernel
(kmod-hwmon-gpiofan - 5.10.75-1 - Kernel module for GPIO controlled FANs)

Please show me your stable build with 5.10.75-1
Again, thank you.

If you want to add kernel modules not provided by this build, you'll have to build it from source together - with or without the modifications of this community build. How to do that has been described in detail, just follow it (you don't have to actually flash your first attempt, but get a feeling about it first). Fortunately this device is rather resilient to failures and has a mature push-button tftp recovery mechanism.


After upgrading to r17842-b428f187f0-20211024, my R7800 2.4Ghz and 5Ghz wifi stopped working and the Luci wireless page shows Generic 802.11bg for both radios. I am using the ath10k drivers and from a bit of research, I came across a patch which seems to address the recent issue

This is what I see in my logs:

[   14.166486] ath10k_pci 0000:01:00.0: assign IRQ: got 43
[   14.167052] ath10k_pci 0000:01:00.0: enabling device (0140 -> 0142)
[   14.167148] ath10k_pci 0000:01:00.0: enabling bus mastering
[   14.167732] ath10k_pci 0000:01:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
[   15.140001] ath10k_pci 0000:01:00.0: qca9984/qca9994 hw1.0 target 0x01000000 chip_id 0x00000000 sub 168c:cafe
[   15.140218] ath10k_pci 0000:01:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 1 testmode 0
[   15.155530] ath10k_pci 0000:01:00.0: firmware ver 10.4- api 5 features no-p2p,mfp,peer-flow-ctrl,btcoex-param,allows-mesh-bcast,no-ps,peer-fixed-rate,iram-recovery crc32 23bd9e43
[   17.426888] ath10k_pci 0000:01:00.0: board_file api 2 bmi_id 0:1 crc32 85498734
[   21.085387] ath10k_pci 0000:01:00.0: failed to copy target iram contents: -12
[   21.172940] ath10k_pci 0000:01:00.0: could not init core (-12)
[   21.173569] ath10k_pci 0000:01:00.0: could not probe fw (-12)
[   21.178236] ath10k_pci 0001:01:00.0: assign IRQ: got 45
[   21.179906] ath10k_pci 0001:01:00.0: enabling device (0140 -> 0142)
[   21.183740] ath10k_pci 0001:01:00.0: enabling bus mastering
[   21.184702] ath10k_pci 0001:01:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
[   21.396114] ath10k_pci 0001:01:00.0: qca9984/qca9994 hw1.0 target 0x01000000 chip_id 0x00000000 sub 168c:cafe
[   21.396149] ath10k_pci 0001:01:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 1 testmode 0
[   21.407102] ath10k_pci 0001:01:00.0: firmware ver 10.4- api 5 features no-p2p,mfp,peer-flow-ctrl,btcoex-param,allows-mesh-bcast,no-ps,peer-fixed-rate,iram-recovery crc32 23bd9e43
[   23.686963] ath10k_pci 0001:01:00.0: board_file api 2 bmi_id 0:2 crc32 85498734
[   27.354454] ath10k_pci 0001:01:00.0: failed to copy target iram contents: -12
[   27.443524] ath10k_pci 0001:01:00.0: could not init core (-12)
[   27.444154] ath10k_pci 0001:01:00.0: could not probe fw (-12)
1 Like

With r17842-b428f187f0-20211024 I have clients connected to both 2.4 and 5 GHz networks, with the default ath10k-ct wifi driver.

I haven't really looked into the mainline ath10k.

Ps. you might highlight that upstream patch to @hauke who just merged the newest batch of the upstream mac80211 wifi backports. As the fix was apparently accepted by upstream, the fix will trickle down to us at some point.

I made an updated DSA test build, as most of the qca8k switch config has now been merged, and the current PR is mostly about toggling the device DTSs.


(Based on PR 4036 from @Ansuel . Possible feedback to there...)


Equivalent to the soon-to-be-released 21.02.1

The relevant recent 21.02 change is the new ath10k-ct version with the VHT160 fix. It has been officially backported to 21.02 before the maintenance release 21.02.1 was tagged :wink: (My previous 21.02 build already contained it.)

(Not applicable to my build with openssl, but the 21.02.1 will also have the wolfssl fix for the Letsencrypt certs.)

1 Like

Thanks for awesome latest build

I'm getting following error, any help would be highly appreciated

Thu Oct 28 02:55:24 2021 daemon.err nlbwmon[2428]: Netlink receive failure: Out of memory
Thu Oct 28 02:55:24 2021 daemon.err nlbwmon[2428]: Unable to dump conntrack: No buffer space available

Having total 18 buffer size shortage in Logs in 11 hour active time

Heaviest service I've in my opinion is samba v4
As kernel doesn't support light ksmbd

Secondly, is there any chance i can get compatibility of following module in upcoming releases

The upstream patch for the mainline ath10k got merged a few minutes ago.



What is the difference between this build and the one in the wiki?:

I see you included some additional software to enable similar functionality as the stock firmware. Is there anything else non obvious you have done?

How about reading the very first post of this thread?

1 Like

BIG LOL ahahahhaha

Absolutely nothing....

Oh yes... That you cannot be able to install many software and any kernel module!

This version is not suitable for any type of advanced use tailored to your needs.

It's a very old story...
I'm here from 2017 and I see that this thing it's still the same.

The answer is that him have no plans to add kmod etc etc that this is him strictly personal build only etc etc because him have no need for it etc etc and for every questions or problems other than his build you are kindly invited to write in another thread etc etc as like if his build has ever had who knows what improvements and changes etc etc instead it is simply like the official build.

I am amazed how this strictly personal thread concerning only his strictly private build is still open.

Fortunately, since 2019 exists the Kong build.

You would be much better off using the Kong build which has a proper software repository support.

I smell random flame from new user.... BAD....

fwiw... I went down that route with the rpi4 ( fortunately does not really have space/ram constraints )...

i'm now at probably over 100 extra kmods... which chew up maybe;

  • 100M or extra ram...
  • 23M extra space

these things cost alot from the person providing these;

  • time (hour+ every build)
  • storage space (think TB over months)
  • hosting space (think many GBs)

putting a dollar factor on it... charging very low labor hours... you are looking at someone spending $700+(AUD) every year to provide such support

so if you want to do or suggest this go ahead... just know and be realistic about what it takes... choice is probably alot less than half of the equation...

and nobody has provided more builds for more time than hnyman... so $700 x 5 years would have cost him over $3500(AUD)~$2500(US) off his own back...

not a nice expectation at all for a 'volunteer' take on...


Well, you might be even more surprised, as this is the second-most read thread in the forum history...

Measured by the reply count this is "only" the 4th:

1 Like

here some of the pearls who do not question a single one of my statements:





Do yourself a favor, it would be much better for you to use Kong build which has an adequate repository and with which you can use all software and kernel modules for a full and complete openwrt experience.

if you didn't know it and you haven't done it've lost at least three years..don't waste any more time!

I am new to OpenWRT so I am still trying to learn, but after reading the first post I posted my question because I didn't have an answer.
Is what I linked to the "Official" or some other build a user made that got added to the wiki. I am trying to understand why I would use this build over the "Official" build, or some other build.