Build for Netgear R7800

Which file to use for flashing is identical to stock openwrt, this is described on https://openwrt.org/docs/guide-user/installation/generic.flashing. The sysupgrade file is very likely not what you want.

The R7800 can be put into tftp (unbrick mode) very easily see Netgear R7800 exploration (IPQ8065, QCA9984) - #5 by hnyman

How to flash openwrt with tfpt can be found at https://openwrt.org/docs/guide-user/installation/generic.flashing.tftp

1 Like

I have three different "latest", from different branches:

Branch Version
master master-r16178-1cd098784e-20210313
stable openwrt-21.02 owrt2102-r15874-ceb6869cd9-20210304
stable openwrt-19.07 owrt1907-r11318-c64742a96e-20210308

Try the 21.02 build...

2 Likes

Thank you again for all your builds and the fast response is much appreciated. Will try the R7800-owrt2102-r15874-ceb6869cd9-20210304-2223-factory.img and let you know how it goes.

It is a very nice build and a day/night difference between Voxel (OEM) and OpenWRT. Took a while to configure static leases as I have 25 and wish I saved a backup before retiring OpenWRT. I have nvram variables for static leases but OpenWRT uses /etc/config/dhcp and the format is completely different. So, finally fiddled with the dhcp file and got it to the way I want.

Btw, the bufferbloat is C (http://www.dslreports.com/speedtest/67679003). I tried cake/piece_of_cake, fq_codel/piece_of_cake, etc. but didn't see much difference. What SQM do you use?

Any other optimization do you suggest? I have a 500/500 Mbps connection.

Thank @hnyman for the newest 21.02 build, I had trying Voxel's, KONG's, then now HNYMAN.
Just flash and testing...
WG: tick!
SQM: seem no any improve to my case, even ping increase from 3ms to 4ms, so disable it.
Others reporting later...
Again, thank you @hnyman

  1. SQM doesn't work with software acceleration enabled in Firewall
  2. 500/500 is too much for SQM to handle on this hardware

This experimental firmware with NSS offload, has hardware-accelerated SQM via fqcodel: Ipq806x NSS build (Netgear R7800 / TP-Link C2600 / Linksys EA8500)

It may work for your 500/500 connection. You will have to disable software acceleration regardless (that build requires it to be OFF).

The SQM UI does not work for that build, so you'll have to figure out how to configure hardware-accel version of fqcodel via config files.

1 Like

It's already disabled in Firewall. Is this what you mean to disable it?

image

Yes. However, 500/500 is too fast for SQM on the R7800, at least the proper "cake/piece of cake" configuration, which is overall the best. By far.

I mean, you could try using a faster SQM, like "fqcodel/simplest" combination. This should be a decent HTB rate limiter without any sophisticated algorithms.

If that's not enough, you can try "fqcodel/simplest_tbf" combo, which is the fastest. However, you may experience issues with wifi calling.

Whichever max bandwidth you have (use a simpler speed test than DSL reports one to determine that), you should set the ingress/egress values in SQM to about 80% of its download/upload speeds.

1 Like

After testing various configurations and with @ninjanoir78 help, I figured that disabling SQM is the best one for my network as the bloat isn't that bad. Thanks for all your pointers and appreciate it.

Do you have the repos listed in /etc/opkg/customfeeds.conf? Can you please post your repos as I am not sure whether I have the right one?

I would like to configure DNSsec and not finding it in the default list.

No.
The normal repos are defined quite normally in /etc/opkg/distfeeds.conf
I do not offer any private package download repo. You can add the userspace packages from the normal buildbot download repos with opkg, but you can't add kernel-related packages.

1 Like

Hello, can anyone help me? I'm trying to upgrade my firmware with 21.02 DSA build from @hnyman, but I got into a boot loop, unable to boot my router.

I tried to use TFTP to reflash factory image, but I can't reach my router in TFTP mode, too.
Ping always result in request timed out, and TFTP also failed with connect request failed.
I've set static IP on my computer and tried factory reset 30/30/30 to no avail.

I also tried to connect the serial header to see if I can get U-Boot log, but somehow I only see gibberish in my serial console. I've tried swapping RX/TX cable, but there isn't any difference somehow.

If anyone can help please, I'm already at my wits end.

Regards.

There is no 21.02 DSA build. Only a test build for master, but DSA will not be in 21.02

TFTP mode should work for recovery, with a normal factory image. OpenWrt does not touch the bootloader's TFTP functionality at all.

Ah, I mean that one.

I think so too, but somehow it doesn't work for me. Is it possible that the bootloader is corrupted? I already tried to enter TFTP mode, but even though the router LED is blinking in white, I can't ping it at all. Is there any other settings that I need to set on my computer, other than setting manual IP?

No. It should be pretty straight-forward.
https://openwrt.org/toh/netgear/r7800#debricking

(But I am not sure if the router is actually pingable in the TFTP mode.)

I have used TFTP dozens of times, and the only difficulties I have had, have been with the TFTP client in PC. I use currently tftpd64 GUI tool from jounin. (TFTP2 tool (from dd-wrt) used to work earlier, but for some reason it does not work with the current master images since 1-2 years.)

Finally I can flash my router! Which image should I use to flash it first? (Assuming I want to use the test image with DSA support.)

There are also some patch files in the folder, so I'm quite confused as to which file should I use.

If you use the TFTP flashing method, you need only the "factory" image file.

Like wiki says:

A new firmware to flash in. Either an original Netgear firmware or an Openwrt “factory.img” firmware. “Sysupgrade” version will not work.

You do not need the other files like patches.

If you need to save your configuration make sure to make a backup before using tftp and the factory image.

When I tried to flash stock firmware, it was able to boot normally, but when I tried to flash it with master image (either normal one or test DSA one) I got stuck in boot loop. Is there anything that must be done before flashing master image? (21.02 image is working fine)

Anyway, thank you so much for the help. At the very least my router is functional once again. Thank you!

My experience is that you can ping it but if you have a non default ip/netmask/defaultgw setup you will have to configure a static IP, NM and GW.

If I'm not mistaken the default openwrt setup is 192.168.1.1/255.255.255.0.