Build for Netgear R7800

Hi hnyman,
does it mean you are going to use in your builds the code for NSS made by Ansuel (and others)?!? Uh hu!!! What a happy news!

nope... dsa is not nss :frowning:
it's just new kernel with new upstream driver

What has to be changed in config for using DSA? I'm only using VLAN on WAN for internet access.

all references to the hardware interfaces: eth0 eth1 eth.2 etc.

  • wan interface is not eth0.2, but just "wan".
  • lan is directly the 4 ports as 'lan1 lan2 lan3 lan4'

With default settings, only this change in the network config itself:

root@router1:~# diff -u /etc/config/network.normal /etc/config/network.hannu510
--- /etc/config/network.normal 
+++ /etc/config/network.hannu510
@@ -10,35 +10,20 @@

 config interface 'lan'
        option type 'bridge'
-       option ifname 'eth1.1'
+       option ifname 'lan1 lan2 lan3 lan4'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

 config interface 'wan'
-       option ifname 'eth0.2'
+       option ifname 'wan'
        option proto 'dhcp'

 config interface 'wan6'
-       option ifname 'eth0.2'
+       option ifname 'wan'
        option proto 'dhcpv6'

-config switch
-       option name 'switch0'
-       option reset '1'
-       option enable_vlan '1'
-
-config switch_vlan
-       option device 'switch0'
-       option vlan '1'
-       option ports '1 2 3 4 6t'
-
-config switch_vlan
-       option device 'switch0'
-       option vlan '2'
-       option ports '5 0t'
-
 config interface 'henet'
        option proto '6in4'
        option mtu '1424'

And the wan LED config:

root@router1:~# diff -u /etc/config/system.normal  /etc/config/system.hannu510
--- /etc/config/system.normal
+++ /etc/config/system.hannu510
@@ -33,8 +33,9 @@
 config led 'led_wan'
        option name 'WAN'
        option sysfs 'white:wan'
-       option trigger 'switch0'
-       option port_mask '0x20'
+       option trigger 'netdev'
+       option mode 'link tx rx'
+       option dev 'wan'

 config led 'led_esata'
        option name 'eSATA'

With those changes made before sysupgrade, I am able to sysupgrade with other settings intact. I do not use any VLANs.

But additionally, all stuff related to sqm, bcp38, whatever..., where references to the hardware interface names are used in config.

1 Like

Thanks a lot, I will give it a shot.
Just have to find out how to tag WAN to VLAN 3201.

You should probably ask help in the threads specific to ipq806x and kernel 5.10 with DSA:

(I do not want this R7800 build thread to get stuck into DSA debugging & advice, as those items are more wide and generic than my test build)

@hnyman Thank you for providing builds and much appreciate it. I have used OpenWRT couple of years ago until I retired R7800. Now, it's alive again. :slight_smile:

I see there are two builds: openwrt-21.02 and openwrt-19.07. Which one do you recommend?

I am planning to flash your firmware from Voxel (OEM). So, flashing via stock GUI should work, correct? If not, I will try tftp.

21.02 was branched off master just a month ago. It is two years newer than the old 19.07. There is not yet any 21.02 releases or even RCs, but soon there will be.

Personally I mainly use the actual master. (although I run these pretty much round-robin fashion, due to testing all builds I upload)

No idea about Voxel.

But it makes no sense to flash the OEM between Voxel and OpenWrt. Just skip the OEM firmware and use the TFTP flashing method.

1 Like

I am confused. If there are no builds for 21.02, what is this "R7800-owrt2102-r15874-ceb6869cd9-20210304-2223-factory.img"? Isn't this the latest?

So, you are using "R7800-master-r16178-1cd098784e-20210313-1827-sysupgrade.bin"?

I didn't mean to say that I am going to flash OEM to get to OpenWRT. Voxel is nothing but OEM with some performance optimizations.

I meant that there are not yet any official release builds.

Buildbot is crunching the packages etc., but so far there is no formal 21.02-rc release.

I build already from the 21.02 branch, so yes, for my community builds there already are 21.02 builds.

1 Like

So, you are using "R7800-master-r16178-1cd098784e-20210313-1827-sysupgrade.bin"? I just want to get your latest, similar to what you have to try it. Thanks again for your prompt response.

Which file to use for flashing is identical to stock openwrt, this is described on https://openwrt.org/docs/guide-user/installation/generic.flashing. The sysupgrade file is very likely not what you want.

The R7800 can be put into tftp (unbrick mode) very easily see Netgear R7800 exploration (IPQ8065, QCA9984) - #5 by hnyman

How to flash openwrt with tfpt can be found at https://openwrt.org/docs/guide-user/installation/generic.flashing.tftp

1 Like

I have three different "latest", from different branches:

Branch Version
master master-r16178-1cd098784e-20210313
stable openwrt-21.02 owrt2102-r15874-ceb6869cd9-20210304
stable openwrt-19.07 owrt1907-r11318-c64742a96e-20210308

Try the 21.02 build...

2 Likes

Thank you again for all your builds and the fast response is much appreciated. Will try the R7800-owrt2102-r15874-ceb6869cd9-20210304-2223-factory.img and let you know how it goes.

It is a very nice build and a day/night difference between Voxel (OEM) and OpenWRT. Took a while to configure static leases as I have 25 and wish I saved a backup before retiring OpenWRT. I have nvram variables for static leases but OpenWRT uses /etc/config/dhcp and the format is completely different. So, finally fiddled with the dhcp file and got it to the way I want.

Btw, the bufferbloat is C (http://www.dslreports.com/speedtest/67679003). I tried cake/piece_of_cake, fq_codel/piece_of_cake, etc. but didn't see much difference. What SQM do you use?

Any other optimization do you suggest? I have a 500/500 Mbps connection.

Thank @hnyman for the newest 21.02 build, I had trying Voxel's, KONG's, then now HNYMAN.
Just flash and testing...
WG: tick!
SQM: seem no any improve to my case, even ping increase from 3ms to 4ms, so disable it.
Others reporting later...
Again, thank you @hnyman

  1. SQM doesn't work with software acceleration enabled in Firewall
  2. 500/500 is too much for SQM to handle on this hardware

This experimental firmware with NSS offload, has hardware-accelerated SQM via fqcodel: Ipq806x NSS build (Netgear R7800 / TP-Link C2600 / Linksys EA8500)

It may work for your 500/500 connection. You will have to disable software acceleration regardless (that build requires it to be OFF).

The SQM UI does not work for that build, so you'll have to figure out how to configure hardware-accel version of fqcodel via config files.

1 Like

It's already disabled in Firewall. Is this what you mean to disable it?

image

Yes. However, 500/500 is too fast for SQM on the R7800, at least the proper "cake/piece of cake" configuration, which is overall the best. By far.

I mean, you could try using a faster SQM, like "fqcodel/simplest" combination. This should be a decent HTB rate limiter without any sophisticated algorithms.

If that's not enough, you can try "fqcodel/simplest_tbf" combo, which is the fastest. However, you may experience issues with wifi calling.

Whichever max bandwidth you have (use a simpler speed test than DSL reports one to determine that), you should set the ingress/egress values in SQM to about 80% of its download/upload speeds.

1 Like

After testing various configurations and with @ninjanoir78 help, I figured that disabling SQM is the best one for my network as the bloat isn't that bad. Thanks for all your pointers and appreciate it.