Build for Netgear R7800

You need to first opkg remove the -ct blob

(Opkg complains to you that you want to overwrite it with a file from another package)

OK. Did that, too.
I hope everything works now. :smiley:

Btw. you should see the full version number loaded into your WLAN cards in dmesg after rebooting, e.g.:

ath10k_pci 0000:01:00.0: qca9984/qca9994 hw1.0 target 0x01000000 chip_id 0x00000000 sub 168c:cafe
ath10k_pci 0000:01:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 1 testmode 0
ath10k_pci 0000:01:00.0: firmware ver 10.4-3.9.0.2-00139 api 5 features no-p2p,mfp,peer-flow-ctrl,btcoex-param,allows-mesh-bcast,no-ps,peer-fixed-rate crc32 84f36f58
ath10k_pci 0000:01:00.0: board_file api 2 bmi_id 0:1 crc32 85498734
ath10k_pci 0000:01:00.0: htt-ver 2.2 wmi-op 6 htt-op 4 cal pre-cal-file max-sta 512 raw 0 hwcrypto 1
1 Like

Been on master up until recently so i just sysupgraded every time i wanted to update the base,curious if now that i'm on the 21.02 branch its safe to just run a full update from opkg or if i should sysupgrade again to your build today.

edit: there is no build today, misread, but more of a general question i suppose

There is no safe "full update" with opkg.

Opkg is only suitable for upgrading selected individual packages. It can't upgrade kernel, and there are difficulties with low-level system packages.

Just use sysupgrade every now and then.

1 Like

Test-DSA-kernel510-master-r16135-7e7218d133-20210307

I have compiled a test version with kernel 5.10 and DSA switch config.
That is based on commits from @Ansuel in PR
https://github.com/openwrt/openwrt/pull/3954

Discussion and advice at
[WIP] [PR] ipq806x: kernel 5.10 bump code propose

I have been running 5.10 with DSA for a day, and so far no problems.

4 Likes

Hi hnyman,
does it mean you are going to use in your builds the code for NSS made by Ansuel (and others)?!? Uh hu!!! What a happy news!

nope... dsa is not nss :frowning:
it's just new kernel with new upstream driver

What has to be changed in config for using DSA? I'm only using VLAN on WAN for internet access.

all references to the hardware interfaces: eth0 eth1 eth.2 etc.

  • wan interface is not eth0.2, but just "wan".
  • lan is directly the 4 ports as 'lan1 lan2 lan3 lan4'

With default settings, only this change in the network config itself:

root@router1:~# diff -u /etc/config/network.normal /etc/config/network.hannu510
--- /etc/config/network.normal 
+++ /etc/config/network.hannu510
@@ -10,35 +10,20 @@

 config interface 'lan'
        option type 'bridge'
-       option ifname 'eth1.1'
+       option ifname 'lan1 lan2 lan3 lan4'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

 config interface 'wan'
-       option ifname 'eth0.2'
+       option ifname 'wan'
        option proto 'dhcp'

 config interface 'wan6'
-       option ifname 'eth0.2'
+       option ifname 'wan'
        option proto 'dhcpv6'

-config switch
-       option name 'switch0'
-       option reset '1'
-       option enable_vlan '1'
-
-config switch_vlan
-       option device 'switch0'
-       option vlan '1'
-       option ports '1 2 3 4 6t'
-
-config switch_vlan
-       option device 'switch0'
-       option vlan '2'
-       option ports '5 0t'
-
 config interface 'henet'
        option proto '6in4'
        option mtu '1424'

And the wan LED config:

root@router1:~# diff -u /etc/config/system.normal  /etc/config/system.hannu510
--- /etc/config/system.normal
+++ /etc/config/system.hannu510
@@ -33,8 +33,9 @@
 config led 'led_wan'
        option name 'WAN'
        option sysfs 'white:wan'
-       option trigger 'switch0'
-       option port_mask '0x20'
+       option trigger 'netdev'
+       option mode 'link tx rx'
+       option dev 'wan'

 config led 'led_esata'
        option name 'eSATA'

With those changes made before sysupgrade, I am able to sysupgrade with other settings intact. I do not use any VLANs.

But additionally, all stuff related to sqm, bcp38, whatever..., where references to the hardware interface names are used in config.

1 Like

Thanks a lot, I will give it a shot.
Just have to find out how to tag WAN to VLAN 3201.

You should probably ask help in the threads specific to ipq806x and kernel 5.10 with DSA:

(I do not want this R7800 build thread to get stuck into DSA debugging & advice, as those items are more wide and generic than my test build)

@hnyman Thank you for providing builds and much appreciate it. I have used OpenWRT couple of years ago until I retired R7800. Now, it's alive again. :slight_smile:

I see there are two builds: openwrt-21.02 and openwrt-19.07. Which one do you recommend?

I am planning to flash your firmware from Voxel (OEM). So, flashing via stock GUI should work, correct? If not, I will try tftp.

21.02 was branched off master just a month ago. It is two years newer than the old 19.07. There is not yet any 21.02 releases or even RCs, but soon there will be.

Personally I mainly use the actual master. (although I run these pretty much round-robin fashion, due to testing all builds I upload)

No idea about Voxel.

But it makes no sense to flash the OEM between Voxel and OpenWrt. Just skip the OEM firmware and use the TFTP flashing method.

1 Like

I am confused. If there are no builds for 21.02, what is this "R7800-owrt2102-r15874-ceb6869cd9-20210304-2223-factory.img"? Isn't this the latest?

So, you are using "R7800-master-r16178-1cd098784e-20210313-1827-sysupgrade.bin"?

I didn't mean to say that I am going to flash OEM to get to OpenWRT. Voxel is nothing but OEM with some performance optimizations.

I meant that there are not yet any official release builds.

Buildbot is crunching the packages etc., but so far there is no formal 21.02-rc release.

I build already from the 21.02 branch, so yes, for my community builds there already are 21.02 builds.

1 Like

So, you are using "R7800-master-r16178-1cd098784e-20210313-1827-sysupgrade.bin"? I just want to get your latest, similar to what you have to try it. Thanks again for your prompt response.

Which file to use for flashing is identical to stock openwrt, this is described on https://openwrt.org/docs/guide-user/installation/generic.flashing. The sysupgrade file is very likely not what you want.

The R7800 can be put into tftp (unbrick mode) very easily see Netgear R7800 exploration (IPQ8065, QCA9984) - #5 by hnyman

How to flash openwrt with tfpt can be found at https://openwrt.org/docs/guide-user/installation/generic.flashing.tftp

1 Like

I have three different "latest", from different branches:

Branch Version
master master-r16178-1cd098784e-20210313
stable openwrt-21.02 owrt2102-r15874-ceb6869cd9-20210304
stable openwrt-19.07 owrt1907-r11318-c64742a96e-20210308

Try the 21.02 build...

2 Likes

Thank you again for all your builds and the fast response is much appreciated. Will try the R7800-owrt2102-r15874-ceb6869cd9-20210304-2223-factory.img and let you know how it goes.