Build for Netgear R7800

Dear hnyman,
Thanks for your swift and helpful advice. I have a question for you. Is there a repository that you maintain anywhere for your prior builds? I ask this because I am brand new to your builds as I said previously. So - where can I get my hands on r15204 let's say ? Once again - thanks for all your work - and I will keep copies of your firmware which I am able to get up and working to my liking and skill level as you suggest.
Forgive me if I am off base as to your beliefs - but do have a Happy Holiday regardless. We are all one people and I celebrate everyone.
Peace and God Bless You and Yours - Always In Peace and Grace

I build every few days, and usually only the newest is available at the download site. There might be the previous one, but I am not keeping a public archive. It is up to you to keep an archive of the builds that you flash.

r15204 is the newest one, so it is naturally available from the Dropbox site linked in the first message of this thread.

Dear hnyman,
Thanks once again for taking the time and patience in order to get a newcomer up to speed when it comes to the manner in which you conduct your business so to speak. It is always good to know the rules - so that was the rationale for my questions. I will keep the copies of the builds as you suggest. And thanks for pointing out my oversight in missing r15204. Also - the information regarding the frequency with which you add new builds is very good to know. My gratitude can not be overstated for your overall attention and demeanor in running this thread - and making your builds for all of us here.

Well, according to my logs it has been 878 builds since 20 Nov 2016, when I stated this thread.
That means roughly a master or stable build every 1,7 days :wink:

(I have only edited this thread's first message 690 times, so not all builds have ended up advertised here)

Yeah, and so far my router's flash has survived the frequent flashing ok :wink:

1 Like

So it seems both master and 19.07 have ath10k ct variant, is that right?
Meaning master has just newer version of the same driver & firmware?
Assuming the ct variant is superior to the plain ath10k driver.
Is DTS implemented in both 19.07 and master, but only in master is hw based?
Where would you say DTS support is more complete/stable?
I guess DTS feature could be useful to potentionaly be able to use more 5GHz channels.
I tried to measure throughput of 19.07 and I am quite surprised to see it is on par with stock firmware - I assumed that NAT offloading is not implemented (yet) with openwrt or is it?
So I wonder if I did the measurement right.
Or is cpu that fast to do 1Gbit NAT?

Please take performance questions to the generic R7800 exporation thread, which is better suitable for those topics.

But shortly,

  • yes, both master and 19.07 use ath10k-ct by default. For master I also build the mainline ath10k for comparison.
  • Both 19.07 and master use DTS, which you can easily see from source code. Like I already said to you in my previous answer to you, there has recently (=this year) been some DTS work in master, so it is slightly different.
  • DTS (DeviceTree) has nothing to do with 5 GHz wifi.
  • There is not much real-life difference in performance between master and 19.07.
1 Like

Ah, sorry, my misunderstanding, I assumed DFS in place of DTS.
So if there is no r7800 specific significant difference between 19.07 and master - can you mention some general feature available in master only that might be worth to consider to choose master instead of stable branch?

Dear hnyman,
As you said and advised r15204 is working great on both bands wifi. Also - thanks for the heads up on the durability of the router when it comes to frequent flashing. Once again, thanks for your time efforts and geniality. Peace and stay Safe - I will see you here on the thread.
Oh yeah, I do remember you from Dave's thread - and no pressure - just asking - do you - or have you made any of your builds for WRT3200ACM public - or have you continued to not choose that option at this time. I only ask as I saw somewhere that you mentioned you had that hardware - wrt3200acm - and did at times do work with it. Anyway, I am more than pleased with my finding your output here - as " everything " works great.

Half-public something, but not a frequent community build...

(Mwlwifi is crappy abandonware, so I do not take my wrt3200acm that seriously.)

Dear hnyman,
Thanks for the information. I am being encouraged to let others get involved in the conversation - so I am going to go silent for a while. However, thanks for all you do in developing OpenWRT across many platforms.

now showing error
"Unable to fetch traffic statistic data: JSON.parse: unexpected end of data at line 1 column 16516 of the JSON data"`

I am not sure if this is the right place to ask. It could be a build issue (i.e. different packages used), or just plain understanding. very new to OpenWRT.
I just aquired a R7800 and now want to use this after my modem (AVM fritzbox brand modem-router configured to allow PPPoE from other devices for VDSL).

my ISP says that native ipv6 support is required, and has some information regarding openwrt specifically:

How can I enable IPv6 on a router with OpenWRT?
The following steps describe only the configuration of IPv6 access, but not the setup and configuration of a packet filter (iptables)!

To set up IPv6 on a router with OpenWRT operating system (version 'Attitude Adjustment'), some packages have to be (re)installed first as follows:

opkg update
opkg install kmod-ipv6
opkg install wide-dhcpv6-client
opkg install radvd  

The package 'kmod-ipv6' activates IPv6 support in general, 'wide-dhcpv6-client' is needed for DHCPv6 prefix delegation, 'radvd' is used to distribute the IPv6 prefix in the LAN.

Now you can enable IPv6 for the PPPoE connection. To do this, please add the following lines to the configuration of the interface used for PPPoE in '/etc/config/network'.

option ipv6 1
option accept_ra 1

The next PPPoE connection should now already have a /64 prefix, so the PPPoE interface should have a corresponding address. In the next step, please change the configuration in '/etc/config/dhcp6c' to get a /48 for the internal networks using prefix delegation.

To do this, please modify the following lines:

config 'dhcp6c' 'basic' option 'enabled' '1'
config 'interface' 'loopback' option 'enabled' '1' option 'sla_id' '0' option 'sla_len' '16 
config 'interface' 'lan' option 'enabled' '1' option 'sla_id' '1' option 'sla_len' '16' 

Important are the options for 'sla_len'. They determine which part of the /48 prefix should be used for an internal network. In the last step radvd is configured to distribute the appropriate prefix on the LAN interface via router advertisement.

config interface
 option interface 'lan
 option ignore 0 

config prefix 
 option interface 'lan
 option ignore 0 

now since these are different packages, but this build comes with ipv6 packages, I am not sure if all prerequisites are met so that I can use your build on my connection: No matter how I configure, it always comes down to the following error:

Timeout waiting for PADO packets
Unable to complete PPPoE Discovery

From what I understand this could be related to ipv6 configuration. But maybe I have an issue elsewhere?

No. Wrong place.
This thread is about my build for R7800.

Ps. The advice you quoted is hopelessly outdated, as it starts from the year 2012 perspective (Attitude Adjustment). radvd has been deprecated years ago.

All the prerequisites for ipv6 are met with hynman’s build. Feel free to load it and try it out.

I have installed this build on my r7800 and I am having wifi performance issues. Mostly, speeds are relatively slow (although I haven't done a proper test) and connections are unstable (dropping out entirely sometimes, but usually the device stays connected and simply can't communicate with any others on the network).
I have tried tweaking usual wireless options (band, transmit power) without much improvement. This seems to be more of a problem with the linux and android based devices on the network than with the windows ones, although I can't confirm that this is the case. The ISP-provided router did not have these issues so I am assuming interference etc are not the problem here.

I would appreciate any help!

I just build 19.07 branch patched with patches from r11250 release and booted the initramfs image, still having stock fw in the flash.
I see following errors on console:

root@OpenWrt:/# dmesg | grep -i 'mtd\|ubi'
[    1.265851] 8 fixed-partitions partitions found on MTD device qcom_nand.0
[    1.273229] Creating 8 MTD partitions on "qcom_nand.0":
[    1.344889] 0x000001880000-0x000007900000 : "ubi"
[    2.857613] UBI error: no valid UBI magic found inside mtd6
[   38.731797] print_req_error: I/O error, dev mtdblock0, sector 0
[   38.732246] print_req_error: I/O error, dev mtdblock0, sector 8
[   38.737011] print_req_error: I/O error, dev mtdblock0, sector 16
[   38.742832] print_req_error: I/O error, dev mtdblock0, sector 24
[   38.749983] print_req_error: I/O error, dev mtdblock0, sector 0
[   38.754666] Buffer I/O error on dev mtdblock0, logical block 0, async page read
[   38.765648] print_req_error: I/O error, dev mtdblock0, sector 0
[   38.767598] Buffer I/O error on dev mtdblock0, logical block 0, async page read
[   38.774507] print_req_error: I/O error, dev mtdblock1, sector 0
[   38.781201] print_req_error: I/O error, dev mtdblock1, sector 8
[   38.787160] print_req_error: I/O error, dev mtdblock1, sector 16
[   38.792991] print_req_error: I/O error, dev mtdblock1, sector 24
[   38.799385] Buffer I/O error on dev mtdblock1, logical block 0, async page read
[   38.807681] Buffer I/O error on dev mtdblock1, logical block 0, async page read

Is this normal/expected?
Or should I assume that the flash contains bad blocks?

The router is brand new, still having the original factory firmware, not flashed with anything yet.
I only disassembled it to attach a serial cable for console access (both covers removed, so I hope the cooler thermo stickers got attached back properly with re-assembly).

You’d do best with opening a thread in the “installing and using openwrt” forum to chase down configuration, router, and client issues.

i can't remember exactly (do a search) but some of these messages (or ones like them) are expected.

dd wrt for r7800 is very stable, any builld by BS since a year and more....

this is not linked with hnyman's build.
probably you are meeting CT drivers. i still can't use them proficiently, even if they are way faster than non-ct one. Try a non-ct build