Build for Netgear R7800

You do not need that, just make sure the irqbalance service is enabled on system/startup page in the web interface. But in the past I suspected irqbalance to cause issues, personally I keep it disabled and just manually move a couple of IRQs in /etc/rc.local

# Manual IRQ affinity (cat /proc/interrupts)
# IRQ31=eth0, IRQ32=eth1
# 1=CPU0, 2=CPU1
echo 2 > /proc/irq/31/smp_affinity
echo 2 > /proc/irq/32/smp_affinity
1 Like

hostpad/80211 seems to have issues with the inactivity timer. I see disconnects in the log from devices that are clearly active:

Sun Aug  2 08:49:39 2020 hostapd: wlan0: STA 10:xxx IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)
Sun Aug  2 10:15:09 2020 hostapd: wlan0-1: STA 38:xxx IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)

I know there's some option to disable it, just saying I didn't have to in the past.

The recent mac80211 and hostapd updates seem to be causing some wifi instability :frowning:

How is this load balancing if you are moving both to the same cpu? I only moved one and left the other as that not right?

**edit..oh wait, forgot about moving wan to cpu1 and that leaves wlan on eth0?

1 Like

You can cat /proc/interrupts and see how the IRQs are distributed. Unfortunately we can't move IRQs 45 and 46 ath10k_pci.

Yes I know that....but just trying to understand, should I move both eth over to same cpu or like I previously said, move just one eth over?

These might be better threads for these types of questions:

When upgrading to build 14023 the R7800 power LED started flashing orange and it didn't come back up after flashing like it normally does when upgrading to a new build. Powering off and back on manually got it going.

I've seen cases too when I reboot it from the command line it doesn't come back up, it restarts but can't connect to it. I have to pull the power.

1 Like

I want to use nfs, uas and f2fs but can't use the kmods from opkg because of different kernel versions. The version is actually the same but the checksum is different. Do I need to create my own build to make this work? I tried using --force-depends when installing the nfs kmod and it hard crashed the router. Had to use the reset button on the back.

Yes, you need your own build if you want to install kernel kmods. The checksum check is there for a reason, just like you noticed. Just build you own version with the needed kmods included.

(Or alternatively, you can use the official release 19.07.3 builds.)

1 Like

If transferring from official release builds to your builds (and vice versa), which one do we flash? The one from your builds labeled *factory.img or *sysupgrade.bin

Sysupgrade, naturally.

  • Sysupgrade image is used to upgrade from a running OpenWrt via sysupgrade
  • Factory image is used to upgrade from a running OEM firmware or using OEM bootloader's TFTP flash routine (or similar recovery tool). So the image needs to match OEM expectations...

That holds true to >95% of routers.


How can I open the UPNP in your newest vision?I tried,but it didn't work.

This fix looks promising

You need to set upnp "enabled" first. Use LuCI to toggle the config setting or manually edit /etc/config/upnpd first by toggling "enabled from 0 to 1 (and restart the service):

root@router1:~# cat /etc/config/upnpd
config upnpd config
        option enabled          0
        option enable_natpmp    1
        option enable_upnp      1
        option secure_mode      1
        option log_output       0

mac80211: fix spurious disconnect issues with disassoc_low_ack=1 (default)

I can confirm this fix works well, now I only see the deauth log lines when devices go out of range, not randomly as before while they were active.

Is that included in the latest master?

Since five days ago.

1 Like

I ready done it,But it doesn't work

Just how stable is "stable openwrt-19.07 owrt1907-r11182-5af8da3787-20200814 (ath10k-ct)"?

Has anyone ran it extensively non-stop for say, a month, with wireless active, no reboots? Does the performance still handle near-gigabit speeds?