Build for Netgear R7800

How often?

Hi, it occurs on WiFi 2.4 with the firmware owrt1806-r7902-05c858ff6a-20191109, for example yesterday happened about 6 times before I restarted the router, but today it has not happened yet, I can not figure out what triggers the error.

Just did a build with Wireguard enabled. Only took one hour total from start to finish with a wireguard connection -- Wireguard works amazingly well. Extremely simple to setup on Luci (as compared to openVPN at least).

Just wish the default builds had it built in. Either way, thanks a ton! The build scripts are very well done and worked fine on Ubuntu 19.10.

1 Like

Just trying this build - all flashed fine and working great so far :ok_hand:.

There very much appear to be two different hardware revisions...I have two R7800's that were Made in China that I have had running Kong's DD-WRT and just bought another R7800 recently that was Made in Thailand and was unable to install DD-WRT on it after trying all different methods (including many tries at tftp) . However, was eventually able to get stock OpenWRT installed on the newer Made in Thailand here I am! Maybe something about what DD-WRT needs in the RAM that OpenWRT doesn't?

This should really belong in a more appropriate thread, Netgear R7800 exploration (IPQ8065, QCA9984) - For Developers, for the reasons that it isn't specific to hnyman's OpenWRT build.


Just asking for recommendations on the procedure to swap from Kongs 12/12 build to the latest @hnyman version - is it Kong->stock->Hnyman or as simple as Kong->Hnyam with configuration resets in-between.

Kong to Hynman is fine and you don't have to reset settings. I keep going back and forth between the builds and never reset settings.

1 Like

If you don't mind, share your experiences with both Kong and Hnyman builds. I been thinking about trying Hnyman builds.

I like Hnyman's builds a bit more as it's light weight and you can install whatever you need. Also, with Hnyman's builds, total available memory is in the upper 350 MBs (for the most part) where as Kongs, always goes to 310 - 330 MBs. Not that it matters much as the free memory is more in R7800 on either builds, that's my observation and don't see any other significant benefit/difference in the two builds.

FWIW, I have been using Hnyman's for the most part, since I owned R7800, and like it a bit better.

And, last but not the least or the most important point is that Hnyman is readily available to answer any or all issues where as Kong is not to be seen and now, his thread is closed. :wink:


Thank You for that info!.. I will try Hnyman's builds!

Just switched my three r7800s from kong to the 12 December build today. Running one r7800 as the router, two as APs (thanks cyber monday sale!).

Only thing I changed from defaults -

  1. turned on both radios (wpa2)
  2. turned on 802.11r (just turned it on in gui, did nothing else...instructions said to do nothing with wpa2 devices)
  3. turned on firewall software offloading (router only)


  1. I’m getting about 650mbps download via a wired connection. There are tons of recommendations for CPU tweaks in the exploration thread. I’m interested in performance improvement but don’t want to sacrifice stability. Are most on here running some kind of performance CPU settings (if so what commands in a SSH session did you use to tweak your CPU for this build?) or just using the ondemand?
  2. anything else you would change to the above settings for max stability, fast hand offs, and performance?

This is very safe to do

Hi all,
Just switched to the owrt1907-r10784-e33a123140-20191212 build. All is working properly except dropbear. I cant get an ssh session. I always closes the connection.
In the logs it says that the Pulic key auth is successful but it receives a dissconect.
I tried going back to the older version I was running before but same problem there.
Here is the log:
Sun Dec 15 19:56:46 2019 dropbear[5611]: Child connection from
Sun Dec 15 19:56:46 2019 authpriv.notice dropbear[5611]: Pubkey auth succeeded for 'root' with key sha1!! edited from
Sun Dec 15 19:56:46 2019 dropbear[5611]: Exit (root): Disconnect received

Maybe I am not good at searching but I did not find much helpful info on StackOverflow.
Any ideas?

I've been using Kong's build for the r7800, and depending on the thread started by Jerrytouille. But the thread has been deleted and Kong is non-existant. I would like to install your build but don't understand your classification system. What are the master builds as opposed to the stable openwrt-19.07 build?
Thanks for any help.

I will try to step in here:

  • 4.19 image can be considered delta or work in progress
  • master - beta
  • stable - more or less production version
    Than there is a difference between network drivers: ct is newer and should be better maintained while "old" ath10k is more stable for some users.
1 Like

Went straight from Kong to the stable openwrt-19.7 - owrt1907-r10784-e33a123140-20191212 (ath10k-ct) sysupgrade. Works great. Very stable.

1 Like

Thanks for the explanation.

Thanks for the info. Thats the version I was going to start with. Glad it's going to work.

Anyone using kernel 4.19 builds? What do you think of them?
Mine (r11597-2fedf023e4) has been up for almost 18 days now, hard to tell if the crashes are fixed, I had uptime > 30 days on kernel 4.14 before it crashed.