Build for Netgear R7800


#148

Thank's for clarifying.

A last one before I switch to your blend...

Flash sqfs-factory.img or sysupgrade one?


#149

Factory is for switching from stock to LEDE. Upgrades after that require only the tar file.


#150

Thanks for the clarification. I flashed it via sysupgrade and it's a real breeze compared to the stock, especially with material GUI.

I chose the bleeding edge and I guess that's why I get:

Installing kmod-fs-udf (4.9.29-1) to root...
Downloading http://downloads.lede-project.org/snapshots/targets/ipq806x/generic/packages/kmod-fs-udf_4.9.29-1_arm_cortex-a15_neon-vfpv4.ipk
Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-fs-udf:
  • kernel (= 4.9.29-1-7a0b89d392d7fe43e86dd065c7becade) * kernel (= 4.9.29-1-7a0b89d392d7fe43e86dd065c7becade) *
  • opkg_install_cmd: Cannot install package kmod-fs-udf.

when trying to install udf filesystem support.

However I don't need to do that anymore. Something is odd with my USB stick. No matter what partition table or filesystem I feed it with, it only shows up on my Windows PC but not on the router. (64 GB SanDisk Ultra Fit)

Another really old fat32 formatted 2,1 GB Usb stick automounts just fine.

I'll check out the other one with a linux live image and gparted later on.

Does your build support mounting storage via esata port?

BR


#151

You can't install kmods from the release/snapshot download repo to private builds. That is due to ensuring full compatibility. The udf kmod would need to be compiled right into the firmware, or at least compiled in the same compilation run by me and then be downloaded and manually installed. If you really need udf support, I could build it into the next build, but I will not add that as a regular feature.

I had somewhat similar trouble with a large 32 GB USB stick. I doubt that it has FAT filesystem but more likely ExFAT that is a different beast. There is currently basic support for ExFAT in my build, but automount does not work and you need to mount it manually via mount /dev/sda1 /mnt

But you can install libblkid to add more type detection support, and the stick will automount after installnig that. (I should maybe add that module to the build, but I use my ExFAT stick so rarely that I have not bothered).

Try "opkg update" and "opkg install libblkid" and see if that helps mounting the stick.
You should also check the system log to see what entries get shown when you enter the stick.

I am not sure. I have not tried attaching anything to that.


#152

Thank you for clarifying.

I was looking to UDF, f2fs and exFAT as filesystems that support files larger than 4GB and are actually somewhat optimized for flash memory USB stick use AND work on mac, linux and windows. I preferred UDF because you can mount it on nearly any OS nowadays at least in read mode and on most as writable too. While f2fs would strand me in linux / android world, exfat does so for the newer windows versions.

I plan on having this 64GB usb stick as a storage extension permanently on my router and access it via openssh-sftpserver and maybe expose it via SMB locally on the network (and WebDAV externally). I wanted to have it read/write enabled on Windows too in case I want to copy over some large files quickly without relying on the network in between.

Right now I tried to reformat the stick with gparted with a gpd partition table and exfat as filesystem.

System Log:

Tue May 23 20:20:02 2017 kern.info kernel: [65430.851163] usb 4-1: new SuperSpeed USB device number 3 using xhci-hcd
Tue May 23 20:20:02 2017 kern.info kernel: [65430.883047] usb-storage 4-1:1.0: USB Mass Storage device detected
Tue May 23 20:20:02 2017 kern.info kernel: [65430.891887] scsi host1: usb-storage 4-1:1.0
Tue May 23 20:20:04 2017 kern.notice kernel: [65431.962857] scsi 1:0:0:0: Direct-Access     SanDisk  Ultra Fit        1.00 PQ: 0 ANSI: 6
Tue May 23 20:20:04 2017 kern.notice kernel: [65431.965641] sd 1:0:0:0: [sda] 125046464 512-byte logical blocks: (64.0 GB/59.6 GiB)
Tue May 23 20:20:04 2017 kern.notice kernel: [65431.971617] sd 1:0:0:0: [sda] Write Protect is off
Tue May 23 20:20:04 2017 kern.debug kernel: [65431.977418] sd 1:0:0:0: [sda] Mode Sense: 43 00 00 00
Tue May 23 20:20:04 2017 kern.notice kernel: [65431.983276] sd 1:0:0:0: [sda] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
Tue May 23 20:20:04 2017 kern.info kernel: [65432.022087]  sda: sda1
Tue May 23 20:20:04 2017 kern.notice kernel: [65432.025556] sd 1:0:0:0: [sda] Attached SCSI removable disk

root@LEDE:~# blkid
/dev/ubiblock0_0: TYPE="squashfs"
/dev/sda1: LABEL="UltraFit" UUID="F44C-4B81" TYPE="exfat" PTTYPE="dos" PARTUUID="e9d70fb7-01"
root@LEDE:~#

So it's working now!

Is it only problematic to install kernel modules or can I safely use other software such as openssh-sftp-server and luci-app-samba?

Nothing against Dropbear but I need sftp instead of scp to mount that usb stick on my Phone and PC :wink:

Is there a conclusive guide online on how to compile such a fw? What software and environment needs to be deployed? I might invest some time in a VM that does that occasionally for me based on your builds and just drag & drop in the needed extras. I know that sounds too easy and won't be but if there's a place to start looking, can you point me to it?

Another thing I recognised is that https://192.168.1.1/cgi-bin/luci/admin/status/realtime doesn't update anytime.

Regards


#153

Wiki is your friend. It contains several articles about the build system.
https://lede-project.org/docs/start
https://lede-project.org/docs/guide-developer/install-buildsystem
https://lede-project.org/docs/guide-developer/use-buildsystem

If you want an easy start for your own R7800 build, start with my build. Read the explanation from message #2 of this thread how you can install the build system with all my build modifications to a Ubuntu x64 VM in a few minutes.

The full explanation is in Build for WNDR3700v1/v2 / WNDR3800


#154

Only the kernel modules are problematic. There is a strict kernel options & modules checksum system to ensure that only fully compatible modules can be easily installed.

Normal user-space apps have no similar restrictions.


#155

Hello Hnyman,

Hats off for your build. i can see the image size is 9mb compared to lede stable version of 6 mb.

Is there any specific reason to lower the size. As the flash size is atleast 32MB or 25Mb usual stock rom .

Can there be a build to have all the needed package so that it can be configured in the setting page instead of copying manually to lib or a cron job .

It would be great if the build have all packages packaged but not activated unless needed. I believe the current one have all the necessary packages.

Is the size is so low because of less Images/icons than stock firmware.

Does your build support MU-MIMO, Beamforming. HT160 etc along with traffic analyzer module built in for device wise usage analytics.

Does the parenting control also available as addon module. VPN client, VPN server possible in future with optional own cerrtification

Can there be a Ftp client like pyload etc along with BT clients.


#156

I have created this firmware mostly for my own needs and I state already in the intro that "it offers the basic router functionality plus some useful add-ons, but does not contain too much additional fancy stuff like multimedia."

If you want "all features build", please compile it yourself.

I don't think that the open source wifi driver supports mu-mimo, yet.


#157

how about Beammforming, airtime fairness etc. i agree its your personal build with all the basic router functions.

i dont understand wifi driver is specific to chip manufacturers. Was it only possible by netgear to use the driver.


#158

Netgear has its own proprietary software driver that they are not sharing​. To my knowledge beamforming etc. are not yet in the ath10k opensource driver. Airtime fairness was developed for ath9k but not sure if that has been implemented in ath10k yet.


#159

Look at my post: why so little flash


#160

I have been trying to set up Homebridge to run through the router for the past few days and have had zero success. This is due to NPM being unusable if installed via opkg (or anything else for that matter). According to this post (https://community.onion.io/topic/1167/npm-coming-to-omega2/7) it could be that I need to install 'nodejs' instead of 'node' to get npm to work, but I was unable to find a .ipk file for this router's architecture.

Finally, I was unable to access the feed mentioned in (https://github.com/nxhack/openwrt-node-packages) which looks like it may be a nice jumping off point for. Basically, I'm stuck knowing where to go next and could use any advice you have. I am currently running LEDE Reboot SNAPSHOT r4049-9412fc2949 / LuCI Master (git-17.117.26217-26fb47b). Here is the pickle I'm seeing:

root@TheJudiciousRouter:~# opkg update
Downloading http://downloads.lede-project.org/snapshots/targets/ipq806x/generic/packages/Packages.gz
Updated list of available packages in /var/opkg-lists/reboot_core
Downloading http://downloads.lede-project.org/snapshots/targets/ipq806x/generic/packages/Packages.sig
Signature check passed.
Downloading http://downloads.lede-project.org/snapshots/packages/arm_cortex-a15_neon-vfpv4/base/Packages.gz
Updated list of available packages in /var/opkg-lists/reboot_base
Downloading http://downloads.lede-project.org/snapshots/packages/arm_cortex-a15_neon-vfpv4/base/Packages.sig
Signature check passed.
Downloading http://downloads.lede-project.org/snapshots/packages/arm_cortex-a15_neon-vfpv4/luci/Packages.gz
Updated list of available packages in /var/opkg-lists/reboot_luci
Downloading http://downloads.lede-project.org/snapshots/packages/arm_cortex-a15_neon-vfpv4/luci/Packages.sig
Signature check passed.
Downloading http://downloads.lede-project.org/snapshots/packages/arm_cortex-a15_neon-vfpv4/packages/Packages.gz
Updated list of available packages in /var/opkg-lists/reboot_packages
Downloading http://downloads.lede-project.org/snapshots/packages/arm_cortex-a15_neon-vfpv4/packages/Packages.sig
Signature check passed.
Downloading http://downloads.lede-project.org/snapshots/packages/arm_cortex-a15_neon-vfpv4/routing/Packages.gz
Updated list of available packages in /var/opkg-lists/reboot_routing
Downloading http://downloads.lede-project.org/snapshots/packages/arm_cortex-a15_neon-vfpv4/routing/Packages.sig
Signature check passed.
Downloading http://downloads.lede-project.org/snapshots/packages/arm_cortex-a15_neon-vfpv4/telephony/Packages.gz
Updated list of available packages in /var/opkg-lists/reboot_telephony
Downloading http://downloads.lede-project.org/snapshots/packages/arm_cortex-a15_neon-vfpv4/telephony/Packages.sig
Signature check passed.
root@TheJudiciousRouter:~# opkg install node
Installing node (v4.4.5-2) to root...
Downloading http://downloads.lede-project.org/snapshots/packages/arm_cortex-a15_neon-vfpv4/packages/node_v4.4.5-2_arm_cortex-a15_neon-    vfpv4.ipk
Configuring node.
root@TheJudiciousRouter:~# node -v
v4.4.5
root@TheJudiciousRouter:~# opkg install node-npm
Installing node-npm (v4.4.5-2) to root...
Downloading http://downloads.lede-project.org/snapshots/packages/arm_cortex-a15_neon-vfpv4/packages/node-npm_v4.4.5-2_arm_cortex-a15_neon    -vfpv4.ipk
Configuring node-npm.
root@TheJudiciousRouter:~# npm -v
Assertion failed: (sk_num(((_STACK*) (1 ? (comp_methods) : (struct stack_st_SSL_COMP*)0)))) == (0) (../src/node_crypto.cc:     InitCryptoOnce: 5482)
Aborted
root@TheJudiciousRouter:~#

#161

Please ask that in a separate thread. It goes outside the scope of my build.
Node , homebridge etc. add-on packages are not in my build.

This is not a generic help thread.

And you will find more expertise on those packages if you have a new thread with a specific title about homebridge etc.


#162

How to revert to orginal firmware once we are in lEDE if things dont go well.


#163

Using the OEM TFTP recovery mode is the easy way to revert to Netgear firmware.


#164

Hnyman,

Thanks. Just wanted few more before i flash. the stock works fine but when i upgrade to V4 database of qos it get crashed. Voxel believes it could be V4 database problem or Hardware problem.

I dont know which is causing the crash. But the router works perfectly fine when it is in V2.0 database.

I dont know if the LEDE support such QOS.

I am having 100/5 Mbps connection download and upload.

I do wanted to know if there is similar qos . Is there any traffic analayzer package available which keep additional traffic data like individual devices data consumption.

Does LEDE also support secure Remote web management and VPN as a client or server for home access.

It would be great in near future the LEDE have a mobile app to access and control both locally and remotely.


#165

Was this normal default stock r7800 partition of flash layout.


#166

You are again hijacking this build-specific thread for generic questions.
Never heard about QoS v4 database...
Your questions are related to general LEDE features. Just browse the forum and wiki and you will find suitable packages.
SQM, openvpn, vnstat, luci-statistics ...


#167

I have been losing wifi access lately.
I am not sure when it started but since the last builds it happens within 24 hours.

The only thing in my kernel log is this:
[46645.621937] nf_conntrack: default automatic helper assignment has been turned off for security reasons and CT-based firewall rule not found. Use the iptables CT target to attach helpers instead.
[101198.237888] ath10k_pci 0001:01:00.0: rx ring became corrupted: -5

the ap isnt visible to any device.
I am on LEDE Reboot SNAPSHOT r4173-5d48dc1146
i reset the settings to default to rule out any old settings causing it.