Build for Netgear R7800

IMHO much too much ... but I am not aware of such limit in adblock/dnsmasq.

Then you are using tmpfs for backups? Makes no sense - please prefer an usb stick or hard disk for that.

As @hnyman already mentioned probably unrelated to this build and the wrong thread for this.

1 Like

I don't remember what it said but I don't think it only was backups that caused the increased memory usage, I found something else that makes more sense.
I just swiched to @hnyman's own build now he doesn't suppy tcpdump-mini so no domain statistics are generated. maybe these grew bigger and linux decided to kill the process that used most memory, which is dnsmasq.

Just for the sake of it I'm going back to a build that I know worked fine and try.

EDIT: Noticed the older build uses Adblock 3.6.4, the newer snapshots are 3.6.5.
@didot did you change something between the versions that could cause dns reporting to use more memory?

I find that hard to believe. DD-WRT is still worse than OpenWRT in its current state. It hasn't been truly stable for a very long time. I've gone thru multiple so-called "stable builds" over the years, and yet the old decrepit 14929 is still the most stable of them all.

When I got this router, I tried to install a recent "stable" KONG build on it, only to have my ISP turn off my Internet immediately! Somehow DD-WRT managed to overflow their NAT tables and they had to reset them manually!

Meanwhile, OpenWRT, for the most part, just works. The 17.01 build is always there in case things go really bad, but despite its speed and stability, it had major bugs. In DSLReports speed test, I got scores like C and B for bufferbloat and quality. With 18.06 I get all A's.

Of course I stick with the "stable" R7800-owrt1806-r7144 build, which was shortly after they fixed a slowdown, so it performs decently with "software acceleration" turned off... because that option is buggy.

I have very simple needs. I don’t really need to use a custom firmware (just like 99% of the users here) I just like to use CFW because I’m a nerd. (Also just like about 100% of the users here). Basically I just need some sort of QOS and maybe an adblocker.

Latest Kong for R7800 (as of now october 28, 2018, build 37495M) has been absolutely stable on my R7800. It's QOS may not be as up-to-date as Openwrt, and the configuration of Privoxy is not as point n click as Adblock in Openwrt, and I cant build my own custom build as easily, but it doesn't crash several times each day anymore and that's f****** beautiful. Has been rock solid for 4 days since I got fed up by OpenWrt. Will for sure go back OpenWrt if new builds become stable.

1 Like

No, for reference see here:

Yes, I've also seen this on one of my 64MB/32MB routers with ~40K domains. The problem I found is not with average memory usage, but transient usage. Using many adblock domains bloats dnsmasq and, since dnsmasq forks to handle each TCP request, this seems to consume more than usual memory (even with sharing) sometimes. If already low on memory, it's then easy to trigger the OOM reaper e.g. try opkg update. One option is to switch to ipset based blocking e.g. banIP.

Would you say the problem is new? For me it seems like it is but maybe I was just on the limit of what it could handle.

@hnyman Sorry for offtopic. :frowning:

Just trying to bring some closure to the tangent... And no, none of the OOM / dnsmasq / opkg / etc behaviour is new, just that it's a question of a safe and reliable operating point. But compared to my borderline 40K domains, your 800K seems far beyond :space_invader: .

Thank you. The conclusion I make is that something in OpenWRT might use a little bit more memory now so I hit the limit. I do have about 220mb mem free, I thought that was enough...
I only have one dnsmasq instance up tho', I see no forks, unless they close after a while.

I realize this is the OpenWrt forum but still:

Firmware:[ DD-WRT v3.0-r37495M kongat (10/28/18)]
Time: 02:02:05 up 13 days, 18:24, load average: 0.84, 0.64, 0.37
Wireless Packet Info
Received (RX) 136342904 OK, no error
Transmitted (TX) 192206497 OK, no error
(I do realize a small amount of TX/RX errors is normal, but I was kinda surprised there were none at all).

For reference I use a R7000 and EA6300v2 as wireless media bridges (with Advanced Tomato and DD-WRT), plus various iphones, ipads, androids, usb wireless clients, laptops and desktop machines with internal WLAN cards and friends over as well with their mobile phones.
I'll stfu now :slight_smile:


That's pretty cool. I am keeping that Kong build just in case I start using this router for WiFi. Wonder if DD-WRT is stabler than OWRT when you enable their version of NAT acceleration (SFE?). My OWRT build can hang after 6 days of that enabled. Sometimes.

What ath10k driver does DDWRT use that is stable compared to the one in OpenWRT?

Idk about DDWRT but afaik there are no other drivers than the ones that exists in linux by default, you can toy with the official firmwares in openwrt and see if you find one that's works for you.

The non-CT driver/fw should be quite stable in openwrt now tho'. I'm currently not experiencing issues with CT.

Even with the non-ct driver I still see crashes in dmesg :frowning:

r9627: dnsmasq keeps starting even though I have the service disabled. Any ideas what could be causing it? What is strange is that I'm stopping it and disabling in rc.local but the process is still there after a reboot. There is no dnsmasq in /etc/rc.d, so something else must be causing it to start.

Luci is also very slow, it just sits there spinning. If I restart uhttpd it's fine for a while but then back to being painfully slow.

Anyone else seeing this problem? Seems to happen in Chrome, Firefox looks OK. I tried a clean Chrome profile and same problem. Not sure if it's related to this change:

Another problem:
I installed bind-dig opkg, but can't run dig, any ideas?

# dig
Error relocating /usr/lib/ ENGINE_get_id: symbol not found
Error relocating /usr/lib/ ENGINE_load_private_key: symbol not found
Error relocating /usr/lib/ ENGINE_load_builtin_engines: symbol not found
Error relocating /usr/lib/ ENGINE_set_default: symbol not found
Error relocating /usr/lib/ ENGINE_free: symbol not found
Error relocating /usr/lib/ ENGINE_load_public_key: symbol not found
Error relocating /usr/lib/ ENGINE_by_id: symbol not found

Could be openssl 1.1.1 misbehaving with the engine config option. Apparently some packages have been compiled with engine support dependency while openssl itself is not.

Thank you. Hopefully it gets fixed in future pkg builds.
Any ideas for the slow Luci UI in Chrome? Not only slow, many times request never finish, they just time out, rendering the UI unusable in Chrome.

Time for a solution update on the issues I've been facing:

  • Trying to disbable dnsmasq service but it was still running: turns out that calling /etc/init.d/dnsmasq stop and disable from /etc/rc.local at every boot causes this, dnsmasq starts running even though it was previously disabled and stopped. Not sure whether it's a bug in the init scripts. I just have to remember to do it once after a firmware upgrade as I don't know how else I can automate it short of building my own firmware.
  • Slow https UI/requests time out in Chrome only, but OK in Firefox, or plain http OK too: I was tired of accepting the self-signed TLS cert every time and didn't want to add it as an exception, so I decided to have my local CA and generate my own cert signed by it. I used this useful tool:
    Now no more warnings from browsers and to my surprise it also fixed the Chrome issues, though I didn't think it would. There must have been something about that self-signed cert generated by OpenWRT that Chrome didn't like.

i can't get nginx to start with this build.
did i miss something?
the service is not starting but not giving any error, so i tried manually and i got this:

root@RUTTO:/etc/nginx# /usr/sbin/nginx -c /etc/nginx/nginx.conf
Error relocating /usr/sbin/nginx: ENGINE_load_private_key: symbol not found
Error relocating /usr/sbin/nginx: ENGINE_set_default: symbol not found
Error relocating /usr/sbin/nginx: ENGINE_free: symbol not found
Error relocating /usr/sbin/nginx: ENGINE_by_id: symbol not found


edit to add: well, nginx with ssl, is it the problem?