Build for Netgear R7800

Like slh said, by using the online imagebuilder server, you can install the same packages, but some tweaks will be missing and some buttons will not work, or will work differently. (E.g. my build has 5 second time window to enter failsafe mode at boot, while the official sources set only rather short 2 second time window.)

Currently there are not that many actual source changes from me in the build, as most of my changes have been accepted into the main sources...

Same experience here. Using SQM cuts my 400 Mbps downlink in half with just one device on the network. I read somewhere that Netgear doesn't recommend QoS for anything over 100 Mbps.

1 Like

@cynics @cascadingstyletrees

You should open a separate thread about the possible SQM problem with R7800, so that it would get proper attention from those get are affected.

(There is nothing special regarding SQM related things in my build.)

[131240.732544] ath10k_pci 0000:01:00.0: Invalid peer id 3 peer stats buffer


Just got this error.

That is 'normal', it happens very rarely, but will happen from time to time (courtesy of the binary firmware).

Thank you slh.

I believe hnyman has addressed these errors earlier, but wondering if your getting these errors too.

[10386.583652] print_req_error: 2 callbacks suppressed
[10386.583658] print_req_error: I/O error, dev mtdblock0, sector 0
[10386.587825] print_req_error: I/O error, dev mtdblock0, sector 8
[10386.593807] print_req_error: I/O error, dev mtdblock0, sector 16
[10386.599746] print_req_error: I/O error, dev mtdblock0, sector 24
[10386.606316] print_req_error: I/O error, dev mtdblock0, sector 0
[10386.611384] Buffer I/O error on dev mtdblock0, logical block 0, async page read
[10386.620145] print_req_error: I/O error, dev mtdblock0, sector 0
[10386.624318] Buffer I/O error on dev mtdblock0, logical block 0, async page read
[10386.630809] print_req_error: I/O error, dev mtdblock1, sector 0
[10386.637996] print_req_error: I/O error, dev mtdblock1, sector 8
[10386.643894] print_req_error: I/O error, dev mtdblock1, sector 16
[10386.649715] print_req_error: I/O error, dev mtdblock1, sector 24
[10386.656107] Buffer I/O error on dev mtdblock1, logical block 0, async page read
[10386.663965] Buffer I/O error on dev mtdblock1, logical block 0, async page read

Sorry, I can't help you with that - but individual sectors going bad on NAND, as used on the r7800, is normal behaviour, ubi should catch that. I personally don't own a r7800 myself (but I do have a very similar ZyXEL nbg6817, which however isn't using NAND (so this particular error can't happen there), but spi-nor (only bootloader and firmware blobs/ ART) and eMMC (kernel+rootfs)).

Similar error messages are there usually at boot, so i think those are rather notrmal.
No idea about the actual reason.

Is the grep info an example of how you grep information of a config file?
A real sample of rather personal requirements or preferences --> how to maintain the dhcp file for static host bindings would be good.

Wiki explains how to format static DHCP entries

More about how you count certain items in a text file.

This is going to be a bit OT, but i was looking for the info about external hosts --> ip bindings, without mac address. I think it is not described in the Wiki.
It was done via dnsmasq.conf before, but there are other options that might be better.

Hmm. external hosts?
So not about host-specific DHCP address allocation, but some DNS & hosts address database? More like /etc/hosts stuff?
If you have a /etc/dnsmasq.conf, it should still work like earlier.

I know I said earlier that I could live without USB tethering, but my cable service drops out on occasion , and I have to resort to tethering through my computer. I've been reading on how to build my own firmware, but haven't got to that point yet.
Would it be hard to included these kmod's in the next master build?

kmod-usb-net, kmod-usb-net-rndis, kmod-usb-net-cdc-ether, usbutils udev

Thanks hnyman.

Yah, I reported elsewhere that cake/piece_of_cake on 18.06/R7800 doesn't keep up with high speed service.

fq_codel/simple plus aggressive CPU scaling improved SQM a lot to the point that it kept up with my line speed

1 Like

I am running the latest master with no modified settings. 5ghz running on channel 153/80mhz using wpa2 forcing aes. My family have the Samsung S7 edge phones and Galaxy tablets...when we use the 5ghz wireless I notice in Luci they have a connection of 433mbit all seems fine until you use youtube. It will work for around 1 min then just drops. I can reconnect with no issues and do it over again. I have tried lower and upper channels with the same result. If I use 40mhz then all is well but I want to use 80mhz. 2.4 wireless works with no issues. I also have a different tablet (no name brand) that connects at about 135mb to the 5ghz and never drops. Am I looking at a samsung side issue or is there something I can adjust/tweak on the router to be able to resolve this issue? Phones are stock and I really do not see how I can adjust anything on them. Other than that I am loving these builds, thanks so much!

Google has this gimmicky protocol called QUIC which forces Youtube traffic thru ports 443 UDP and 80 UDP. In my experience, WiFi is less stable with it.

In my routers I always go to firewall settings and create two rules - to disable UDP traffic on ports 80 and 443. It affects nothing except blocking QUIC, and forcing Google to use TCP on 80/443 like the rest of the web.

IMO it makes Youtube more stable on the phones.

Thanks. I will do that but since my post I determined that any high traffic to these S7Edge phones causes them to drop. I tried downloading test files and sure enough about 200mb into a 500mb file it bombs. so its not just YT... Almost time to upgrade phones anyway.

In fact I am mixing up "host-specific DHCP address" and "DNS hosts address database", there are docs out there which tell to use dnsmasq somehow. On linux / windows it is /etc/hosts but for openwrt the docs tell to add addn-hosts=/etc/dnsmasq.hosts to dnsmasq.conf and there the ip host is maintained.

with fq_codel piece_of_cake (I understood tha fq_codel is better on r7800) on 18.06/R7800, cable connection I get
Bufferbloat improvement from D -> A (250ms --> 12ms)
Speed decreases from 51/2 to 42/2 megabits/s

I am wondering if this improves my PS4 fortnite kill rate. :slight_smile: