Build for Linksys EA9500

Phone ads cannot be blocked completely because apps and browsers use private internal dns to route their traffic.

@Aragorn64 Make sure you save your changes and ensure that those are saved in the /etc/config/wireless file. You may have to reboot the router.

I see. I used adaway in the past with RR, and it worked great blocking 99.99% of ads, but you had to make sure your blocklist is current which meant basically daily updates, now i'm on stock unrooted rom so i can't test it.

Regarding the blocklists update, does it occur automatically on router reboot or does it need a cron job?

have a read thru this:

1 Like

Thanks for taking time from your busy schedule to reply npcomplete.

1 Like

You can block port 53 TCP/UDP for anything other than LAN to help prevent devices from sourcing DNS externally. (Granted you are an IPV4 only network, assuming you are)

Thank you for your reply :slight_smile: , but I don't know how I resolved the problem haha. The router started working properly after I performed the following steps:

Firstly, I checked that the changes were saved correctly on the wireless file and rebooted the router, but it did not solve the problem.

Secondly, I performed a factory reset, but after that, the router became so laggy that the OpenWrt interface took forever to load.

Finally, I performed another factory reset and after that, everything works well. The 5.0Ghz Wi-Fi is working so well.

Thanks for taking the time to answer our questions. I´ll try to help others who might have the same problem :).

Note: I installed the latest version firmware.

1 Like

I've been struggling with this weird behaviour happening in my router, and pinpointing what's causing it. I have tried multiple different "factory resets"; via the button, keeping it pushed && via the GUI (reset changes) && using the firststart command && flashing (retaining changes) && flashing other versions, not retaining changes. I feel like somewhere, somehow there might be a persistent part that's not being reset, as I keep having the same issue, some devices on WiFi cannot communicate with some devices that are connected through a wire.
I'm currently running the 03-29 bleeding edge build again, but am toying with the idea of flashing back stock Linksys firmware, and then boot to see if the issue persists. If that solves it, reflash OpenWRT again and see if it's still fixed...
However, before doing so (and obviously, before making my fiancee want to murder me because she cannot watch Netflix on the weekend :wink: ) I would like to get some feedback. Are there other ways that I can approach this that might be quicker?
I find it weird that this issue started popping up with the bleeding edge build and then persisted.
I also find it weird that some of the options in the bleeding edge build flat out give me error messages.
ie. The SIIT 4over6 assistant gives me the following:

/usr/lib/lua/luci/cbi.lua:53: Model 'clamav' not found!
stack traceback:
	[C]: in function 'assert'
	/usr/lib/lua/luci/cbi.lua:53: in function 'load'
	/usr/lib/lua/luci/dispatcher.lua:1370: in function '_form'
	/usr/lib/lua/luci/dispatcher.lua:930: in function 'dispatch'
	/usr/lib/lua/luci/dispatcher.lua:441: in function </usr/lib/lua/luci/dispatcher.lua:440>

And when I tried to install the (not-simple) luci-app-adblock, it also bonked out on me... I'm not sure if my router might be fubar, the memory or storage has somehow deteriorated too much, or if it's just some kind of setting somewhere, somehow.

*Edit: I fully disabled ipv6 based on the gut feel that SIIT 4over6 giving errors indicated there might be ipv6 issues internally, unfortunately no success.

Update: Looks like nvram settings are "sticky"? It seems to have stored my wifi password and SSID in nvram, even after flashing new firmware and rebooting.
Haven't reflashed it with stock yet, but that's mainly due to having misplaced my usb cable in my last move....

More updates: Bleeding edge build seems to be the cause of my issues. It shows the LAN devices as individual ones (and keeps them that way unless I "mtd erase nvram" before rebooting into a different build).
After flashing the January build and erasing my nvram, my devices can talk to each other again :slight_smile:

Alpha/bleeding edge build:

January 2020 build:

Hi. Thanks for all the info and support to install openwrt for this device.
I successfully installed bleeding edge build. What I'm trying now is to mount an USB HDD and share it through ftp but haven't find a way to do it. Is it possible to do it?

Hi Lexandorf,

I am not sure about sharing through "standard" FTP, however if you have SFTP (FTP over SSH) it should work by default without any changes required.
Check your Mount Points under OpenWRT > System > Mount Points and see if your USB drive is connected (and what the path is).
Then give it a try with an SFTP client on port 22 (yes, that is the SSH port), using "root" as user, and whatever your password is. If that works to your satisfaction, make sure you create a new user that is "chrooted" to the USB drive to use for FTP transfers. Also, probably not a great idea to expose port 22 to "the internet" if that's what you were looking to do.
There are definitely ftp servers available too, but I have no experience with them, nor do I fully understand your purpose. There might be other (better?) alternatives available. I am sharing my USB drive over SMB for example.



Non-US V1.0 owner frustrated with stock firmeware. Downloaded Jan 2 version from link in OP and flashed from GUI. Procedure reboots router, but to stock firmware. Tried 3x10s interrupt of boot to activate boot from secondary partition, but to no avail.

Please advice.


Should be what you're looking for

How do I do that? Sorry, I am new to OpenWrt.



From CFE prompt execute following.

Where is where your tftp server is running.

flash -noheader nflash0.trx
flash -noheader nflash0.trx2
1 Like

@taarhaug Unfortunately you will need to open up the device and have a special cable to flash it, as it doesn't allow software flashing by default... So just "flashing from the GUI" will not work.
The "Detailed instructions" from the top post is potentially what you've missed:


I managed to flash by downgrading stock rom first. Well, first flash was not successful as I could not connect to the internet, but a reflash did the trick.

I did however observe abysmal WIFI speeds for 5GHz bands, so I reverted to stock.

I never liked the EA9500, and will probably replace it soon.

Thanks for the help.


thank you very much. work for me :slight_smile:
the router made boot loop at the beginning I just need to wait maybe 30 minutes and the router is set to factory setting

Just a small update, I'm still working on the next alpha build. I've run into issues with wifi backports crashing the wifi firmware load. Will keep you updated.


Appreciate the update. From my perspective: Take your time, I'd rather have a good alpha2 version that works, than a half-arsed alpha2 version that causes more issues and frustrations with the "rest of us". I think mostly because the general public doesn't quite understand what alpha means, and just installs the latest version, and will then flood this forum (and yourself by proxy)... So yeah, save yourself some headaches, take some extra time :wink: However, if you need an alpha tester (or want to run ideas by someone), feel free to reach out. Although my linux (and openwrt) knowledge is a bit stale, I'm always happy to brush up on skills by talking about things :wink: