Build for Linksys EA9500

Don't worry, npcomplete's builds are totally fine - it's just that UCI configuration for DSA bridging isn't there yet (for bcm53xx at least).

You can configure bridges manually with "ip bridge" and it'll work fine on npcomplete's builds :slight_smile:

1 Like

I've run a bunch of his builds and have loved them over stock firmware. I'm totally aware of the CLI bridging utility also, but it's extra work and I like Luci. I'm also cisco certified and still like their gui when i can use it. I also utilize more than 5 ports on mine. That said I am always trying out the new builds. I am curious as to the changes in the new kernel. Haven't looked at the change logs yet.

Try this from Serial cable:

flash -noheader nflash0.trx
flash -noheader nflash0.trx2


flash -noheader nflash1.trx
flash -noheader nflash1.trx2


nvram set bootpartition=0 && nvram set partialboots=0 && nvram commit

It has to boot into Factory

Hi thank you for the quick reply but I tried the instructions and nothing all i get is the reloop boot and nothing else.
I can revert to openwrt but no to factory firmware .
:thinking: :thinking: :thinking:

Are you downloading factory firmware from this page or somewhere else?

Hi I am downloading from this website. its the same as the one u posted at first post.
the router works fine with openwrt but I cannot revert it to factory.


I have a Linksys EA9500 V 1.1 US Version. I have read the thread and I think that I want to install the OpenWRT software on my router.

Before to doing that, I want to ask if there is any drawback of installing OpenDWR software on my router instead using the Linksys stock firmware.

Thank you all :slight_smile:


Hello again :).

I followed the steps of the "Detailed tutorial". I have connected the 3 wires correctly, set my IP to (Gateway, set the Putty settings as in the guide but when I open the Putty session and power on the router, nothing happens. I only see a black screen on the Putty console.

Should I open the Putty session prior to power up the router, right?
Should I wait some time until I see something on Putty console?

Here some screenshots about what I did:

Thank you.

Thanks for the pictures. Everything looks good.
Yes, make sure to open putty console before starting the router.

Hope you are connecting wires properly. Don't assume colors of the wires. Sometimes they get swapped. Make sure you check the manufacturer documentation. Have you used the wire anywhere else?

I have successfully flashed the openwrt-20200102.trx :slight_smile: . But when I reboot the router, it boot with the Linksys firmware. I´m doing something wrong?

Thank you for your fast replies :smiley:

Flash it to both the partitions:

nflash0.trx and then to nflash0.trx2

Hey all,

Firstly @npcomplete: THANK YOU. Honestly, I was so frustrated when I first got my ea9500 that I put it back in the box and left it there for a year or so, and just went back to the provider's wireless router as I bought the thing to do smart stuff for me, but it only came with crappy Linksys software.
I started following your thread on the LEDE forums, and the second I was able to get my hands on a serial cable, I started flashing :slight_smile:

I'm a software engineer (with affiliation to hardware) myself, and have managed to install and flash multiple flavours of your (and hurrian's) builds without too many difficulties, bar the bootloader locking when the ground cable of the serial is connected... Easy fix though.

We have just moved into a new place, and the internet is quite unstable here, and it doesn't seem to support IPV6, which I initially blamed on the firmware (which actually had been rocksolid for the past 3 months before moving), hence I started experimenting with different builds, including hurrian's.

Last Friday I flashed your alpha/bleeding edge build. It all went well, except I was seeing some weird issues with LAN connectivity. (Sometimes?) my PC, which has a wired connection, cannot access my NAS which also has a wired connection. And, through WiFi, half my devices can and half my devices cannot reach my NAS (which is a bit of an issue when you have WiFi smartbulbs and Home Assistant running on the NAS :slight_smile: ).
Before rebooting today, I quite often got the message that a packet was received with its own destination address (which happened to be the MAC of the 2.4Ghz channel).
Now after my reboot, I'm getting the following oin repeat every 6 seconds: ieee80211 phy0: brcmf_cfg80211_start_ap: Set Channel failed: chspec=53290, -52
I'm going to flash back to the January version of your build, to see if that stabilises, as I need a stable connection to be able to work from home.
Having said that, I am more than happy to experiment over the weekend with some bleeding edge builds.
Located in Brisbane, Australia, so GMT+10 if that's of any import.



Thanks for the feedback, I'm going to upload a new bleeding edge build later this week.

But even with the current bleeding edge build, make sure to factory reset. There has been some issue with ports 4,7,8 not being able to communicate with ports 1,2,3,5,6. The problem is that I just have one router atm.

Given, the current situation, I can't put entire family in darkness :sob: while I'm trying to fix this issue once and for all.

It's good to see fellow software developer test the builds. My entire goal of this project is to avoid electronics from going to landfill. Feedback from likes of you certainly helps making future builds better.


Haha, I know the issue. My fiance was very annoyed yesterday when she couldn't Netflix....

Anyway, just flashed the 2020-01-02 non-US version back on my ea9500, configured my WiFi and well... The issue returned.
I then did a factory reset (no improvement), did a umount /overlay && firststart -y (no improvement).

This version was working fine before. I'll move around the cables, see if that helps. I just think it's weird that some wifi devices (like the laptop I am currently on) can see the NAS, while others (ie. Smartplug listed in the screenshot) cannot. Can it have something to do with my laptop being on radio2 (40Mhz, 5Ghz, channel 157) whereas the Smartplug is only 2.4Ghz (and thus on radio1)?

Anyway, attached a screenshot just for some more info:

I'll swap around the plugs in a sec, see if that helps, making sure everything's plugged into either 1,2,3,5,6. Will report back after :wink:

So... That was weird.
Cables were plugged into 1,2,3.
Thought I'd give it a try moving them to 4, 5, 6 instead.
4 seems to be working, no problem. 5, 6 blink for about half a second to a second and then go dead. On my NAS, my Windows PC as well as my 1Gb switch.

Having said that, with the NAS in port 4, I still have exactly the same issue; Laptop can see both devices, NAS cannot see the Smartplug

  • Edit: PS. This was the build I was running before the weekend, when I had no issues with internal connectivity.
1 Like

Finally I managed to get the OpenWrt firmware working on my router :slight_smile: It's a worth upgrade from Linksys stock firmware.

Thank you very much for your awesome work :smiley: :smiley: :smiley:


Since I have reached the 3 replies here I needed to use the Github account.... Anyway a big fan of your work and I have also posted here under SoniC. Now back to the topic about the latest alpha from end of march :

With the latest alpha I have had some really weird instabilities....
First problems with WiFi....
I have a Danfoss Link CC connecting to the bgn network since it cannot work with 5G, however with the latest build (and 802.11r) it seems it connects but indicates lack of network. Reverting to January build and no problems.... Workaround is to only enable 802.11r on 5G and leave 2.4 as is, but then I have two networks....

Second is more serious I think.... I don't know what causes it but sometimes changing the settings in the alpha (for me they are random and not connected to any interfaces etc. like changing something on the dhcp side --- e.g. adding two new dns servers)
and a ping -t running in the background on the pc results --- after a reboot --- a weird response from (router) that the port cannot be reached or something like that.... And virtually making the config unusable.... No internet etc. however I can access the router gui @ just normally.
Rebooting or reverting to backup settings doesn't help. Sometimes even a factory reset doesn't help and I need to reflash the firmware (or - revert to january build)....

It could provide some more information but I am.... limited with my knowledge on what to provide (and on occasion also --- how to access the information e.g. like commands in putty). I would gladly help if someone would guide me a little bit /// I know the basics of putty or sftp but not all the needed commands to access the logs, except the stuff in the gui.

I have been testing all the OpenWrt features, but I noticed that the 5.0ghz Wi-Fi signal strength (radio0) is so weakened, and the radio 2 does not work.

I followed the Wifi Instructions: Set country code to US, Radio0 and Radio2 stick to 40Mhz, Radio0 at band 36 and Radio2 at band 161.

After I made the changes to the Radios, I rebooted the router but as you can see in the images, the Radio2 seems to remain at band 36, but inside the configuration menu its at band 161.

Should I name both radios with the same SSID?
Should I need to make other configuration in order to get the 5.0Ghz band works?
Anyone know how can I fix this issue?

The following screenshots show how my router´s Wi-Fi configuration looks like:

Thanks in advance :slight_smile:

Hi npcomplete,

I've been testing the 'bleeding edge' for the last couple of days, so far it works great (some minor annoyances with 5GHz but since 2.4ghz works fine, and most of my devices are wired anyways - I've got no complains.).

One question though regarding simple-adblock: I've noticed some mobile ads are not blocked. Do i need to add a crone job for adaway (and other) list(s) update interval or is there another way to auto-update lists?

If crone job is a way to go, what would be a proper command? I assume something along these lines: '/etc/init.d/simple-adblock timer dl 72h' ?

PS. Great news about the new build coming out - Thanks! :+1: :+1: