Build for Linksys EA9500

I would recommend doing a factory reset while switching from npcomplete's builds.

Sorry for my late reply. I am still trying to understand the difference between the release you can download from "THIS" page ( and "YOUR" It is a newer version of OpenWrt 19.07.1 and your swconfig. Why is your release a fraction of size compared to "THIS" download? I assume it just comes with less pre-installed packets?

If I have "THIS" installed, may I overwrite it with "YOUR" release?

I hope "THIS" and "YOUR" makes sense.

"THIS" = npcomplete's DSA-based builds, they're built from OpenWrt newer head sources.
"YOUR" = my swconfig-based builds, it's built to match OpenWrt's stable releases.

I provide my swconfig-based builds for those that prefer that type of switch configuration over DSA, and because it's slightly easier to chase down packages.

You must do a reset when switching between the two types of builds.

This works great! Regardless if the port is up or down, I get solid 22MB/s.

What the .... ? I rebooted and I am greeted by the old linksys OS.

sent the image via tftpd and things looked normal again. I started to change some settings and rebooted. On reboot it went back to the linksys OS

Scanning device for bad blocks
Bad eraseblock 768 at 0x000006000000
Creating 1 MTD partitions on "brcmnand":
0x000005200000-0x000008000000 : "brcmnand"
VFS: Mounted root (squashfs filesystem) readonly on device 31:5.
devtmpfs: mounted
Freeing init memory: 248K
Failed to execute /sbin/preinit. Attempting defaults...

          _        _  __    _    __ _____ __   __ _____
         | |      | ||  \  | |  / // ____]\ \ / // ____]TM
         | |      | ||   \ | | / /| (___   \ V /| (____
         | |      | || |\ \| |\ \  \____ \  \ /  \____ \
         | |_____ | || | \   | \ \  ____) | | |   ____) |
         |_______||_||_|  \__|  \_\[____ /  |_|  [_____/

(c) 2013 Belkin International, Inc. and/or its affiliates. All rights reserved.
Booting panamera (firmware version

The system is unable to boot as soon as I install "kmod-tcp-bbr"

Hi guys

I have flash openwrt luci us version on my bricked ea9500 router and after the flash it work perfectly :slight_smile:

Now I Want to flash the factory firmware for the us model v1.1

where I can find the correct firmware or its possible to use .img firmware on linksys website and recompile for .trx

I have try to flash the ea9500_Factory.trx firmware below

flash -noheader nflash0.trx
flash -noheader nflash0.trx2

but impossible to boot on the linksys original firmware begin to boot and after a few minute made a boot loop :frowning:

Hello Everyone!

After long days of testing the assembly from Hurrian, I found that the brcmfmac driver for all Linux distributions is limited, and many things that work in the original firmware cannot be run in open source projects.

Now to the point!

I managed to create a Three-Band Wifi network! YES!

Spending my hours looking for a solution to the problem of how to create one SSID for all three (radio0,1,2) channels, I came across a forum here on Raspberry 3 B+, where I also found a problem when I turned on 802.11r

It turned out that the brcmfmac driver is not able (yet) to work with the WPA2 PSK ONLY + 802.1r, it wants mixed mode!

For 802.1r to work, you need to change Encryption to mixed WPA / WPA2 PSK, then everything starts working! You can also enable 802.1w.

After that, I created 3 AP with the same SSID + the same Encryption + the same password + and two ticks 802.1r and 802.1w.

And it works!

I hope this will help everyone!

1 Like

In addition to this:

/etc/init.d/clear_partialboot in hurrian built (for those who use it)

case $(board_name) in
		# clear partialboots and always set to boot first partition
		nvram set bootpartition=0 && nvram set partialboots=0 && nvram commit

where $(board_name) actually returns "linksys,panamera"

So, it better to change to

case "$(board_name)" in
		# clear partialboots and always set to boot first partition
		nvram set bootpartition=0 && nvram set partialboots=0 && nvram commit

Hi, i can install openwrt on this router with serial cable, but i can’t revert back to factory, i have tried and tried. its driving me crazy. if anybody out there can help with information how to do this for dummies pls help help.
will be highly appreciated. thank u

Thanks man! this helps! But anyway I would feel better if 802.11r and tri-band would work with the "strong" encryption mode too. anyway confirming working also on the npcomplete build!

I'm also seeing these errors but only in the latest build with the .91 kernel. Ended up rolling back to the 20190618 build and it's pretty solid.

Hi guys, I'm on firmware and on the back of it, it only says EA9500, so i assume my unit is 1.0. How can you tell if it's US or Non-US version?

Where did you purchase it? I would just try the non-US factory firmware v1.1.6 linked in the first post. If it succeeds, update it to Openwrt using the non-US Openwrt image.

Hi npcomplete, Thanks for the quick response, much appreciated! I've got mine from a seller in Switzerland through eBay. I've sent him a message asking about it yesterday, but he has yet to respond.

So let's see if i understand it correctly:

  1. I should revert to FW_EA9500_1.1.6.173418_prod.img

  2. If the router is Non-US version, no serial cable needed, it can be flashed straight from the stock UI, with this image

  3. If i attempt to flash it with 1.1.6 stock firmware and it turns out it's US version, nothing will happen and the router will simply revert to 1.1.7 stock firmware on reboot? (I don't have a Serial cable on me, and wouldn't wanna brick it as I'm using it currently :slight_smile: )

You are correct, no harm will be done to the router with above steps

1 Like

Thank you! off to testing the build, will post the results.

1 Like

Sadly It got stuck in the reboot loop after i tried flashing the openwrt image, i was able to interrupt it by holding the reset button for 10 seconds so I'm back on stock. Thank god for the second partition :slight_smile:

So it's safe to assume this is an US version and I'll need a serial cable? Will this one work? It's color coded exactly like the one you linked, but I'm not sure if it's the same brand (It only says: IoT USB to RS232 TT Serial.)

I think it should work as long as you have correct driver for it.

I'm curious about - why it didn't take the openwrt. Let me know if you find out once you connect the serial cable.