Build for Linksys EA9500


#247

@yefx1
You will need cfe, nvram1 and nvram2 which corresponds to mtd0, mtd1 and mtd2.

I think your nvram is corrupt or the firmware flash damaged. First try flashing nvram and your cfe has no issues. If that doesn't work, I'm pretty sure that your flash chip is toast.

I've uploaded mtd0,mtd1 and mtd2 here: https://www.dropbox.com/sh/agmhwz107bnu5u6/AAB-78KkBVfMbk7q7nXnSrQHa?dl=0

mtd3 has firmware copy 1
mtd6 has firmware copy 2

You can flash both copies using:

mtd3:

flash -noheader 192.168.1.10:/openwrt.trx nflash0.trx

mtd6:

flash -noheader 192.168.1.10:/openwrt.trx nflash0.trx2

Good luck!


#248

NP- I did. Well in that I hadn't when I initially flashed, but realized that might be an issue so reset it via the website and the manual reset 30/30/30 bit. No difference.


#249

I have the same issue as oXYnary.
I dont get a dhcp address from my cable router (running in bridge mode).
I did a reflash from serial (&TFTP) and configured from scratch
I had the same problem with v4.14.82.
However v4.14.61 works fine for me.


#250

We should pull the [2018-12-26] release. When I do a configuration reset, my router gets an IP from my FIOS MOCA. However, after several changes in OpenWRT it just stops working. I rolled back the firmware and everything is working as expected again.


#251

Thanks for all the feedback, I've pulled down the Dec 26th build


#252

Thank you very much, your support,because the flash openwrt WIFI signal is weakened,
I hope the flash factory has improved.


#253

Can this method be done with firmware 1.1.7.180968?


#254

It can't be turned on now, it looks like there is a problem with CFE. unable to start openwrt with original factory。

CFE started successfully without ipaddr
Input ifconfig eth0 -addr=192.168.1.1 -mask=255.255.255.0
Error message "Could not activate network interface 'eth0':Error"
CFE> show deviices
there is no eth0 in the list
It should be a problem with cfe.
I don't know how to solve it. help me

Thank you!!
the problem has been solved.
CFE input

CFE> nvram erase

CFE> devinfo commit

CFE> reboot

Successfully started eth0 is also loaded

If there is no IP address, please try the above steps


#255

Clearly indicats that flash chip is corrupt. If you can still boot to cfe prompt, I would try another go at flashing the cfe.

What happens if you just type 'go' at the cfe prompt and hit enter?

Frankly, I think your router is bricked now.


#257

CFE> mfg nand

NAND Device Information Dump:
Vendor Name : Toshiba
Total size : 128MB
Block size : 128KB
Page Size : 2048B
OOB Size : 64B
Sector size : 512B
Spare size : 16B
ECC level : 8-bit
Device ID : 0x98 0xf1 0x80 0x15 0xf2
BAD Block No: 1
*** command status = 0

A bad block appeared


#258

1 Bad block shouldn't affect anything. Flash memory is prone to bad blocks and have a map/table of these bad blocks so that it can skip when reading writing them.


#259
CFE> mfg nand bbckl                                                                                        
Bad Block Offset: 06000000                                                                                 
BAD Block No:  1                                                                                           
*** command status = 0                                                                                     

Will it be the cause of bad blocks, can't flash back to the original factory?


#260

I tried a lot of methods, replaced a lot of firmware, still can't flash the original firmware.
The following is the restart ttl output log of the original firmware.
ttl.log


#261

Can you post log when you flash OpenWrt?


#262

flash factory firmware.


#263

flash openwrt 2.4G wifi does not work,fhe original firmware 2.4G wifi is working.
So I want to brush back the original firmware.


#264

Hi is there a way to debrick this router i think i just bick it trying to install OpenWRT now it wont start at all not even CFE.

Thank you.


#265

Without the ability of getting to the CFE prompt, the router is pretty much dead.

[EDIT]
Unless you find a way to JTAG it.


#266

Hi npcomplete

I noticed that on the LUCI network tab there is no option for "switch" . Is this something that needs to be compiled? I see the same on some of the screen shots in earlier posts. I do see it on other routers I have.

PS Your latest firmware from Nov is pretty stable for me.


#267

@npcomplete thanks for this build. I hope to soon clone your repo and build from source.