Build for Linksys EA9500


#186

john,

Please run this from CFE -

nvram set bootpartition=0 && nvram set partialboots=0 && nvram commit

Then flash the openwrt -

flash -noheader 192.168.1.10:/openwrt.trx nflash0.trx

Once the flashing is complete. Power off the router and power back again. Wait for CRC errors you see and all the scrolling text. Then reboot one last time.

You don't want to boot into Linksys firmware.


#187

npcomplete, thank you for the response, when you say "CFE" do you mean in Putty after I boot up and press CTRL-C?

When you say "Wait for CRC errors you see and all the scrolling text" do I wait until there is no more text or only after the CRC errors? Am I waiting the entire boot sequence to finish before I reboot?

I believe I have tried and accomplished this, but I will give it a go again. I can get into WRT firmware, it's when I make any changes and select "Apply and Save" it locks up and I can never boot into WRT unless I flash it again.


#188

Yes CFE is what you get after ctrl-C. You may or may not see CRC errors which happens during boot sequence.

On reboot, force the boot to OpenWRT by this.

nvram set bootpartition=0 && nvram set partialboots=0 && nvram commit


#189

Yes, I understand how to force to boot it into OpenWRT. My problem is once I am in OpenWRT and make any changes and select "Save and Apply" it stays on "Applying changes" like the picture above and I have to restart, then it will not boot into OpenWRT even if I try to force it. It's seems when I select "Save and Apply" the router locks up and is unable to boot.


#190

It's very hard to guess why your router does that. Several people have used this firmware without issues you mention.


#191

Is there way to upload a log file of some sort?


#192

When you try to save and apply, do you notice anything on the putty console? Any errors?


#193

I never had Putty open when I boot into WRT. I will give it a try in about 8 hours


#194

I have a log file, is there anything I need to hide before posting it? Let me know and I will upload the entire log file. Here is a pic of the log file once I click Save&Apply. By the way, it only locks up when I select Save in Apply on the PPPoE screen.
After%20Save%20and%20Apply%20Log%20pic


#195

Copy the whole log and pm me. But I can see that your IPV6 isn't working, that is not a huge problem.
I'd suggest, perform a firmware install once more, but not to change anything on the UI.

Change the wan section in /etc/config/network file to:

 config interface 'wan'
         option type 'bridge'
         option ifname 'wan eth2.102'
         option proto 'pppoe'
         option username 'xxxxxxxx'
         option password 'yyyyyyyy'

Save and restart your server. Do not make any changes to the UI.

Btw, does your ISP require PPPoE connection to be tagged?


#196

Ok, don't laugh, but how to I PM on this site? I don't see an option. And I am not sure what " PPPoE connection to be tagged" means, but I need to insert an email and password into PPoE setting for my internet to work.


#197

Ok, then just change the network config to above and restart the router.
You can PM me by going to my profile (click on my avatar)


#198

I must be on crazy pills, I don't see anything about PM or messaging, just Summary, Activity, Badges, etc..I wonder if I don't have rights to see or use PM feature.. I'll mess with the network config..

How do I get into "/etc/config/network" through CFE or through the OpenWRT router interface?


#199

After the boot sequence finishes and you still have your serial cable hooked up. Hit enter.

Then, open the config in vi editor

vi /etc/config/network

Then scroll down to wan section. If you haven't used vi editor. You'll find a quick "How to" online.


#200

I tried to look for a VI how to, but I think I gaffed it anyway. To make matters worst, I think my serial cable is shot (I see gibberish in putty and no longer see words, but the router still boots into both WRT/Linksys). I have messed with this stupid thing for over 8 hrs now and still no progress. I will wait until my cable gets here before I mess with it again. I am sure it's something I am doing worng...stupid PPPoE requirement is messing everything up.


#201

Enter an arbitrary topic of your choice (not just this one and not one you have already visited) and you should advance to "Basic Member" and be allowed to send PM.


#202

Thank you very much npcomplete. Your patience and effort you provided was amazing. I was actually able to use VI Editor and make those changes... Your suggestions worked. I was able to successfully use PPPOE and have my wifis working. If you can accommodate a few setting questions, it would be great. I am in Japan and saw a country setting World wide. Do I need to change anything on this setting? I don't want to mess up others wifi with band issues. I think I set up my DNS correctly (unlocator). Are there any other settings I need to fine tune?


#203

An update. Apparently I do not have DNS set up correctly, I am using DNS from "Unlocator" I placed it in the Interface- LAN - EDIT- USE CUSTOM DNS SERVERS, but that didn't work. After reading I tried to do the following

Blockquote 1. Log in to your OpenWRT interface LuCI via 192.168.1.1

  1. Network -> Interfaces
  2. Edit WAN
  3. Advanced settings
  4. Uncheck "Use DNS servers advertised by peer"
  5. Add IP addresses of the DNS you want to use to "Use custom DNS servers"

Like before, when I clicked Save and Apply, it lfroze up and I had to re-flash, then go into VI and make those changes. What is the correct way to get my two DNS numbers added correctly?

One other question, how can I make a firmware image of the way it is now so I don't have to go through that rediculous process each time it crashes. I have internet and wifi working so I would like ot have a good OpenWRT image of the way it is now. I saw the back up, but that just gave me a "backup-OpenWrt-2018-08-14.tar.gz"


#204

Send me the output of this -

nvram show | grep ccode

and

nvram show | grep regrev

To fix the DNS servers:

rm /etc/resolv.conf
echo "nameserver 8.8.8.8" >> /etc/resolv.conf
echo "nameserver 8.8.8.4" >> /etc/resolv.conf

reboot

#205

Do I do the rm /etc/resolv.comf in VI Editor? I let it boot, and typed "rm /etc/resolv.conf" but it says no such file or directory. I will post the "ccode and regrev" These dumps are after I reflashed the firmware and have my internet and wifi working.