Build for Linksys EA9500

Thank you!

Can someone test the latest snapshot? Please note I can't guarantee it's going to work, thus testing request.

It works when you are connected to 4,7,8 ports. When connected to 1,2,3,5,6 - I receive no ip address.

When I change the config and add 1,2,3,5,6 - all ports work.

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan4'
        list ports 'lan7'
        list ports 'lan8'
        list ports 'extsw'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan5'
        list ports 'lan6'

I'll give it a try this weekend.

Thank you both for still supporting the hardware

Thanks @npcomplete! One more test request: do you need extsw in your config? Can you try dropping it and checking if ports still work?

`extsw' is needed in the config. Without it the ports hanging off it don't work.

Thanks, fixed bcm53xx: bridge all LAN ports on Linksys EA9500


Thanks for update, now the 8 ports are online.

note: the led on ports 3,4 aren't on, others (1,2,5,6,7,8) are when connected.


Can you try this:
While there's no extsw on the 02_network file.

ip link set up extsw
service network restart

See if the external switchports start working?

Hi there, Can someone please test the following scenario? Best to start by disconnecting the devices and rebooting the ea9500:

  1. Turn off the DHCP server on the ea9500 or set up a new vlan and add two ports from any of lan1,2,3,5,6, pvid untagged. Basically set it up as though the two ports are a dumb switch.

  2. Connect one of those two ports to another device running a DHCP server and connect the other to a client making DHCP requests.

  3. Observe. Does the client get an IP from that DHCP server? If any issues, run tcpdump on extsw.

This test is to see if unknown packets can be successfully resent back through the interface they came from (ext_sw in this case) to go to the DHCP server.


1 Like

Only DSA-tagged frames will appear on the extsw interface. You should run tcpdump on the bridge interface instead.

1 Like

Better yet, you can see if the issue's still there on 5.15 by compiling this branch.

Enable using test kernel option on the menuconfig.

The prebuilt image is here, for everyone to try it.

@npcomplete @rmilecki

1 Like

I tried the latest snapshot.

It seemed to work with all ports initially but after a reboot, it crapped itself and port connectivity was inconsistent and I couldnt get my WAN IP back at all.

Took me 2 hours to revert back to the August release which works.

I will have another crack at it when I have a few hours to play with.

I tried this and it doesn't work. Client connected on LAN1 doesn't get IP when extsw is not part of the bridge. I'll try your pre-built image

The pre-built image doesn't detect 1,2,3,5,6 ports. I think it is missing the mdio driver. Will build it and try again.

Oh, my bad. Compile with V=s, it’s going to ask about a kernel option while compiling.

Update: I've updated the prebuilt image on the GitHub release to address this issue.

no go :frowning: this one doesn't detect any of the ports

What does the bootlog say?

I made a mistake on the kernel config and DSA wasn't enabled properly. Now, that I don't see anything DSA related on the bootlog, could you try the updated prebuilt image on the same Github release?