Build for Belkin RT3200 (Linksys E8450) [UBI] and Redmi AX6S (Xiaomi AX3200)

I mean that's not really a good comparison. You're comparing a WRT32X which has a 1866 MHz processor, with a 1350 MHz processor. It's expected that you'd be able to hit higher bandwidth rates with cake with a faster processor.

I think it's pretty well understood that cake consumes more CPU than fq_codel does, so you can achieve higher rates with fq_codel if the CPU is your limiting factor. That appears to be the case with the RT3200.

It also depends to some extent what you're optimizing for - like if it's average latency and bufferbloat-related metrics, then I'd assume cake is better. If you're looking for more efficient CPU utilization, then fq_codel would be better. The bufferbloat website even states:

At line (native) rate cake uses more cpu than what fq_codel does.


Good reply. Although then it says:
"At a shaped rate, it [cake] does much better than htb + fq_codel does."
So not sure which, I suppose there are pros/cons to both algorithms but good to know. I'll stick with cake on my main router.


Just as another data point, I just upgraded my internet speed for kicks so the provisioned speeds now are like 968 Mbps download / 18.15 Mbps upload. I just ran the DSLreports tests on a direct wired connection and the results are as follows:

fq_codel + simple.qos: Speed result of 950/16.42 Mbps | DSLReports, ISP Information
cake + piece_of_cake.qos: Speed result of 421.6/18.08 Mbps | DSLReports, ISP Information

So it seems like with fq_codel + simple.qos you could definitely fully utilize a Gigabit line with this router. With cake it seems to max out at 420 - 480 Mbps from what I'm seeing, and it's definitely due to it maxing out the CPU core based on the output of top / htop.


@segal_72 fq codel + simpleqos for fiber :slight_smile:

This build doesnt like mesh at all.

What's the issue exactly? Is it just missing some crucial packages for mesh networking or something?

So far i remember, all packages needed were there. The router just refused to start up the mesh.

What causes the GUI to become somewhat non-responsive when the router is in use running traffic.

Not sure, I get that behavior sometimes just with any wireless router running OpenWRT. I'd assume just that some other process is running that has a higher priority / "niceness" that is de-prioritizing the uhttpd process.

I also have a Netgear WAX204 which runs I believe a Netgear variant of OpenWRT. This router also will sometimes have a slow GUI response. So seems to make sense that this is an OpenWRT characteristic so to say. Routers I have running Tomato, for example, never seem to have any delay in the GUI. Out of curiosity, what have been the main changes in your recent builds for the Linksys E8450?

I've just been adding various tweaks - I try to keep the original post updated with the latest info, so you can just view like the edit history on that to see what has changed recently.

The most recent additions were:

Those are mostly just additional compiler / build optimizations with the hopes of squeaking out a little more speed from the router.


After using this build for about a week I completely lost my 5.0 radio. Couldn't re-enable it through any means. Tried updating packages and ended up bricking the router...

If the RT3200 gets an official release with 802.11ax support then I will consider trying it again.

I think this is a no no. Typically you don't want to issue updates through software manager for precompiled images unless you are choosing one offs for specific packages. Just running a full update in software manager will likely leave you with a nonworking router.

1 Like

Sorry I should have gone into more detail. Tried downloading and installing packages as per the instructions in SSH but the packages were in read only for some reason. The bricking was definitely my fault and I take full responsibility for my lack of knowledge lol. You live and you learn.

While I haven't personally tried this, I do note that the guy (daniel) who made the UBI conversion stuff for the RT3200 included a TFTP recover mechanism in the u-boot bootloader he built. You might consider checking that out as a way to try and unbrick your unit:

I will definitely consider this for the future. Walmart's return policy took care of my defective unit :slight_smile:

@Shrekfes I guess it would have been good to also mention:


Well shit, I still have the old one in my car. I will message him lol

Upnp is broken on the latest version, Collected errors:

 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-nf-conntrack-netlink found, but incompatible with the architectures configured
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for luci-app-upnp:
 * 	kernel (= 5.10.42-1-64d9152f61b0ba993c1f961328c9f31b)
 * opkg_install_cmd: Cannot install package luci-app-upnp.

Also I have been getting this message everytime I've updated the opkg lists. Collected errors:
* opkg_download: Failed to download, wget returned 8.

wait many hours the all packages arrived please :slight_smile: