Build for Belkin RT3200 (Linksys E8450) [UBI] and Redmi AX6S (Xiaomi AX3200)

Not really familiar with auc, but reading on it I doubt that it would work with this build. This is basically a monolithic build with the packages pre-bundled with the firmware. I don't build the full set of openwrt packages and make them available anywhere, and I imagine installing packages in general from like could cause issues.

@diogenes Flashed your latest build and everything looks good. I am now trying to configure VLAN, but it doesn't seem to work.
The following is what I tried via Luci: enable vlan filtering in br-lan, tag a VLAN ID to one of the LAN ports and then apply the settings. However, the settings never get applied!
Am I missing something? Or is VLAN not supported at this moment for this device?

Also noticed that the bridge utility is not available in your build. Could that be the reason for issues with VLAN configuration? If so, can you please add that to your next release?

1 Like

I'm also looking at creating VLANs but it does not seem to be working.

Ok, try the latest build up there. I added two packages 'ip-full' and 'ip-bridge' based on what I read on some other areas of the forum; but I don't personally use VLANs on my router so I didn't verify that this allows them to work now.

Thanks a lot for the quick build. I tried via Luci but it still doesn't apply the configuration.
As the "bridge" command is now available in your build, I will try to set up the VLANs via CLI and post here if I have some success. Thanks again!

a quick update: I managed to use the latest build from 29-06-2021 and setup VLANs. A detailed description is available here.
Thanks @diogenes for your support!

1 Like

Any chance we can get usb flash drive support ? (block-mount e2fsprogs kmod-fs-ext4 kmod-usb-storage kmod-usb2 kmod-usb3) would be awesome to load NFS for my docker swarm. Thanks for your work.

Sure yeah, go ahead and try the latest build up there and tell me if it works for you:

1 Like

wow that was super quick thanks! Usb is detected and succesfully formatted but I somehow missed the nfs-kernel-server in the list of dependencies. Once that is added to the firmware I should be able to share my pendrive. Thanks again!

Yup, I just put a new build up with nfs-kernel-driver

1 Like

Excellent :cowboy_hat_face: she is up and running.

are you sure than upnp work ? i didin't have wok at my home thanks

i has try but witouth success

my stepto your step 2 don't work

then i has remove the two packages and install just luci-app-upnp ...

upnp is a software feature, it shouldn't be specific to the rt3200 at all.

1 Like

thank you for the answer @slh but I have an xbox, a ps5 and a pc I have no other way to use upnp, by disabling upnp and reinstalling it tells me confiles has been placed in etc / config / upnpd different , now upnpdopkg,

I tried on another router version openwrt (not rt3200 belkin) and upnp works immediately

The new default config files have been placed as upnpd-opkg for reference, so that your old settings have not been overwritten, and that you can compare your old config file to the current defaults, and possibly make the necessary changes. Quite normal.

Sure. There were no existing installation and no existing config files, so you get the current defaults and they apparently work.


ok thank you, yes the router is a mikrotik rb750gr3, so there is so far no solution to set up upnp on belkin rt3200? or have I done something wrong?


config upnpd 'config'
option download '1024'
option upload '512'
option internal_iface 'lan'
option port '5000'
option upnp_lease_file '/var/run/miniupnpd.leases'
option igdv1 '1'
option enabled '1'
option uuid '...............................'
option ext_ip_reserved_ignore '1'
option external_iface 'wan'
option log_output '1'
config perm_rule
option action 'allow'
option ext_ports '1024-65535'
option int_addr ''
option int_ports '1024-65535'
option comment 'Allow high ports'

config perm_rule
option action 'deny'
option ext_ports '0-65535'
option int_addr ''
option int_ports '0-65535'
option comment 'Default deny'`

and upnpdopkg

config upnpd config
	option enabled		0
	option enable_natpmp	1
	option enable_upnp	1
	option secure_mode	1
	option log_output	0
	option download		1024
	option upload		512
#by default, looked up dynamically from ubus
#	option external_iface	wan
	option internal_iface	lan
	option port		5000
	option upnp_lease_file	/var/run/miniupnpd.leases
	option igdv1		1

config perm_rule
	option action		allow
	option ext_ports	1024-65535
	option int_addr	# Does not override secure_mode
	option int_ports	1024-65535
	option comment		"Allow high ports"

config perm_rule
	option action		deny
	option ext_ports	0-65535
	option int_addr
	option int_ports	0-65535
	option comment		"Default deny"

maybe a solution here

Maybe a bit off topic...
But I leave this here for people that have to use a double NAT setup.
For example if you have to use your ISP router and your OpenWRT box behind it.

UPNP also passes the public IP as info to the clients.
(I'm sure PS4 uses this info)
In a double NAT setup this will not work. (Because a private IP is passed over to the clients)
To fix this, change/add
option external_ip 'your public ip address'
to your miniupnpd conf.
It also possible to modify the miniupnpd init script to automatically get the public IP address.
And enable DMZ mode on your ISP router. (to the IP address of your OpenWRT box)
Or forward all high ports (1024-65535) to your OpenWRT box.
But for cgNAT, your ISP has to open/forward the ports or to give a public IP.

by shm0

thanks to @shm0 resolve with external ip

Capture d’écran 2021-08-03 à 09.40.59

Sorry for a totally off-topic question, any idea (timeframe) when E8450 will be officially supported in OpenWrt?


It is already. (in the master, not yet in the releases based on older source code).

1 Like

Master is also UBI based?