Build for Belkin RT3200 (Linksys E8450) [UBI] and Redmi AX6S (Xiaomi AX3200)

I also have a Netgear WAX204 which runs I believe a Netgear variant of OpenWRT. This router also will sometimes have a slow GUI response. So seems to make sense that this is an OpenWRT characteristic so to say. Routers I have running Tomato, for example, never seem to have any delay in the GUI. Out of curiosity, what have been the main changes in your recent builds for the Linksys E8450?

I've just been adding various tweaks - I try to keep the original post updated with the latest info, so you can just view like the edit history on that to see what has changed recently.

The most recent additions were:

Those are mostly just additional compiler / build optimizations with the hopes of squeaking out a little more speed from the router.

2 Likes

After using this build for about a week I completely lost my 5.0 radio. Couldn't re-enable it through any means. Tried updating packages and ended up bricking the router...

If the RT3200 gets an official release with 802.11ax support then I will consider trying it again.

I think this is a no no. Typically you don't want to issue updates through software manager for precompiled images unless you are choosing one offs for specific packages. Just running a full update in software manager will likely leave you with a nonworking router.

1 Like

Sorry I should have gone into more detail. Tried downloading and installing packages as per the instructions in SSH but the packages were in read only for some reason. The bricking was definitely my fault and I take full responsibility for my lack of knowledge lol. You live and you learn.

While I haven't personally tried this, I do note that the guy (daniel) who made the UBI conversion stuff for the RT3200 included a TFTP recover mechanism in the u-boot bootloader he built. You might consider checking that out as a way to try and unbrick your unit:

I will definitely consider this for the future. Walmart's return policy took care of my defective unit :slight_smile:

@Shrekfes I guess it would have been good to also mention:

3 Likes

Well shit, I still have the old one in my car. I will message him lol

Upnp is broken on the latest version, Collected errors:

 * pkg_hash_fetch_best_installation_candidate: Packages for kmod-nf-conntrack-netlink found, but incompatible with the architectures configured
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for luci-app-upnp:
 * 	kernel (= 5.10.42-1-64d9152f61b0ba993c1f961328c9f31b)
 * opkg_install_cmd: Cannot install package luci-app-upnp.

Also I have been getting this message everytime I've updated the opkg lists. Collected errors:
* opkg_download: Failed to download https://downloads.openwrt.org/snapshots/packages/aarch64_cortex-a53/stoickish/Packages.gz, wget returned 8.

wait many hours the all packages arrived please :slight_smile:

I was wrong by the way. It is possible to get wpad-openssl on the next release? Thank you in advance.

Sure yeah - the latest build up (https://owrt.plzh4x.me/mediatek-mt7622-linksys_e8450-ubi/2021-06-10_1623371914/) now uses wpad-wolfssl instead of wpad-basic-wolfssl

1 Like

auc dont work?

Not really familiar with auc, but reading on it I doubt that it would work with this build. This is basically a monolithic build with the packages pre-bundled with the firmware. I don't build the full set of openwrt packages and make them available anywhere, and I imagine installing packages in general from like downloads.openwrt.org could cause issues.

@diogenes Flashed your latest build and everything looks good. I am now trying to configure VLAN, but it doesn't seem to work.
The following is what I tried via Luci: enable vlan filtering in br-lan, tag a VLAN ID to one of the LAN ports and then apply the settings. However, the settings never get applied!
Am I missing something? Or is VLAN not supported at this moment for this device?

Also noticed that the bridge utility is not available in your build. Could that be the reason for issues with VLAN configuration? If so, can you please add that to your next release?

1 Like

I'm also looking at creating VLANs but it does not seem to be working.

Ok, try the latest build up there. I added two packages 'ip-full' and 'ip-bridge' based on what I read on some other areas of the forum; but I don't personally use VLANs on my router so I didn't verify that this allows them to work now.

Thanks a lot for the quick build. I tried via Luci but it still doesn't apply the configuration.
As the "bridge" command is now available in your build, I will try to set up the VLANs via CLI and post here if I have some success. Thanks again!

a quick update: I managed to use the latest build from 29-06-2021 and setup VLANs. A detailed description is available here.
Thanks @diogenes for your support!

1 Like