Build errors for WRT1900acV1(Mamba) with kernel 4.4

Not sure if this is the proper place but here goes.

Using the same process I have for years to build custom LEDE for my wrt1900acv1 on kernel 4.4 . This started happening recently.

arm-openwrt-linux-muslgnueabi-cpp: error: /home/kirkb/lede-mamba-120317/build_dir/target-arm_cortex-a9+vfpv3_musl_eabi/linux-mvebu/linux-4.4.100/arch/arm/boot/dts/armada-388-clearfog-pro.dts: No such file or directory
arm-openwrt-linux-muslgnueabi-cpp: warning: '-x assembler-with-cpp' after last input file has no effect
arm-openwrt-linux-muslgnueabi-cpp: fatal error: no input files
compilation terminated.
make[5]: *** [/home/kirkb/lede-mamba-120317/build_dir/target-arm_cortex-a9+vfpv3_musl_eabi/linux-mvebu/image-armada-388-clearfog-pro.dtb] Error 1
make[5]: Leaving directory `/home/kirkb/lede-mamba-120317/target/linux/mvebu/image'
make[4]: *** [install] Error 2
make[4]: Leaving directory `/home/kirkb/lede-mamba-120317/target/linux/mvebu'
make[3]: *** [install] Error 2
make[3]: Leaving directory `/home/kirkb/lede-mamba-120317/target/linux'
make[2]: *** [target/linux/install] Error 2
make[2]: Leaving directory `/home/kirkb/lede-mamba-120317'
make[1]: *** [/home/kirkb/lede-mamba-120317/staging_dir/target-arm_cortex-a9+vfpv3_musl_eabi/stamp/.target_install] Error 2
make[1]: Leaving directory `/home/kirkb/lede-mamba-120317'
make: *** [world] Error 2

Note, I purposefully tried 4.4 kernel because of the ongoing reboot problems with 4.9.

This post in context with the calendar, but I don't build 4.4 so have not tried myself.

Prior to building, did you issue:

  1. git pull && ./scripts/feeds update -a && ./scripts/feeds install -a ; then once done:
  2. make MENUCONFIG_COLOR=blackbg menuconfig, Save, then Exit
  • I always recommend adding the following to your ~/.*rc file of choice:
    • alias wrta='git pull && ./scripts/feeds update -a && ./scripts/feeds install -a'
    • alias wrt='make MENUCONFIG_COLOR=blackbg menuconfig'

If you did 1 & 2, issue the following:

  1. mv build_dir/target-arm_cortex-a9+vfpv3_musl_eabi/linux-mvebu/linux-4.4.100/arch/arm/boot/dts build_dir/target-arm_cortex-a9+vfpv3_musl_eabi/linux-mvebu/linux-4.4.100/arch/arm/boot/dts.old
    • Or (depending upon distro): cp -R build_dir/target-arm_cortex-a9+vfpv3_musl_eabi/linux-mvebu/linux-4.4.100/arch/arm/boot/dts . && rm -Rf build_dir/target-arm_cortex-a9+vfpv3_musl_eabi/linux-mvebu/linux-4.4.100/arch/arm/boot/dts
  2. make V=s

If @anomeome's reference or the above don't work, you'll need to utilize 4.9 (possibly 4.1, but I'm not sure if that's still supported for the V1s).

Every build I make/made, I start from scratch with the same recipe. Essentially this:

/usr/bin/git clone
cd lede
./scripts/feeds update -a 
./scripts/feeds install -a
vi target/linux/mvebu/Makefile ### change to 4.4 kernel
make menuconfig
make -j4 V=s  ### if this fails try -j1

The stuff provided in the link anomeome provided does work. But having to do that for every build is a pain. And, I'm reporting this here to let folks know that 4.4 build is broken and we can't use 4.9 because there are random reboots(long thread with many experiencing this) >> [Solved] WRT1900ACV1 reboots: kernel 4.9

@stmtpr The reboots on 4.9 are environment specific and are not experienced by everyone. I'd recommend trying 4.9 to determine if your environment is one that causes reboots (the issues with 4.4 for the 1900ac V1 have been around for months IIRC).

Thanks for the input JW. I've tried 4.9 many times over the last few months and all of them cause my Mamba to reboot when I'm doing very large downloads via wired ethernet.

I guess the point I'm trying to make by bringing this up is if I cannot use 4.9 then I must have an easy way to build 4.4 without jumping thru hoops.

@stmtpr Unfortunately, it looks like your stuck with the inconvenience of 4.4 then, at least until the issue has a hard coded fix/patch in the repo.

On a side note, when building, you don't have to limit the jobs via -j4 unless you're compiling on a system with mediocre performance.

  • Any 4C/8T or 8C processor and 8GB RAM shouldn't require specifying a jobs number if the compile is the only intensive process being ran.