Build Error on mainline missing dependency

ERROR: package/utils/jsonfilter failed to build

I have succesfully built images from MASTER over the last week or so - but today after getting latest

git pull
./scripts/feeds update -a
./scripts/feeds install -a
make menuconfig
make V=s

I get a build error and w new missing dependency - but I can't see why? - can anyone help (nothing changed menuconfig (but I did try adding librt as that looked like a dependency - but same result...)

\find /home/jon/openwrt/build_dir/target-mips_24kc_musl/jsonfilter-2018-02-04-c7e938d6/ipkg-mips_24kc/jsonfilter -name 'CVS' -o -name '.svn' -o -name '.#*' -o -name '*~'| xargs -r rm -rf
**Package jsonfilter is missing dependencies for the following libraries:**
make[3]: *** [Makefile:41: /home/jon/openwrt/bin/packages/mips_24kc/base/jsonfilter_2018-02-04-c7e938d6-1_mips_24kc.ipk] Error 1
make[3]: Leaving directory '/home/jon/openwrt/package/utils/jsonfilter'
time: package/utils/jsonfilter/compile#1.41#0.57#2.08
    ERROR: package/utils/jsonfilter failed to build.
make[2]: *** [package/Makefile:114: package/utils/jsonfilter/compile] Error 1
make[2]: Leaving directory '/home/jon/openwrt'
make[1]: *** [package/Makefile:108: /home/jon/openwrt/staging_dir/target-mips_24kc_musl/stamp/.package_compile] Error 2
make[1]: Leaving directory '/home/jon/openwrt'
make: *** [/home/jon/openwrt/include/ world] Error 2

I believe it's an current issue with current mainline/snapshots, started with yesterday (20210215) snapshot
There are quite a few recent changes regarding ubox and ABI version, probably broke this

Another related thread:
Imagebuilder (snapshot 2021-02-15) failed with Unknown package ‘block-mount’


Try cleaning up maybe.


thanks @anomeome sorry for noob clarification - you mean run 'make clean'?

I would start with

rm -rf bin tmp build_dir
make defconfig

if that don't get the job done make dirclean perhaps.

1 Like

thanks @dominick-han and @anomeome - all fine indeed it looks like it was recent changes now fixed with another git pull, cleaned build environment anyway but now building fine again

Try with make package/utils/jsonfilter/clean and make package/utils/jsonfilter/compile,I met the same problem,after exec these,everything is ok.

1 Like

I'm suffering the same error with a RPi4 build, I've tried the above steps but get the same error, I guess it's best to leave it a day or two and try again and see if the problem is fixed.

Things are building fine here, and if it is just one package as above example

make package/utils/jsonfilter/{clean,compile} V=sc

to force cleanup and build with some extra output.


Thank you, I'll try that now...

In general, always do "make clean" before a build, especially if you have already got failures.

Additionally, when the package metadata and its handling rules have changed (like now), it may also help do delete the contents of tmp/ and let the build system to re-create the package data. Directory tmp/ in buildroot contains several semi-hidden .package* database files, that may have now somehow sneakily invalid. (similar may happen e.g. when a package is moved from OpenWrt main repo to the Github feeds, or something similar)


That fixed it, many thanks!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.