Build 18.06.2, error make kmod-jool


#1
make[3]: Entering directory '/home/vech/openwrt/feeds/packages/net/jool'
rm -f /home/vech/openwrt/build_dir/target-mipsel_24kc_musl/linux-ramips_mt7620/jool-9dfaf22e49f7905d94af9b73f9bee22c26d7dd4a/.built
touch /home/vech/openwrt/build_dir/target-mipsel_24kc_musl/linux-ramips_mt7620/jool-9dfaf22e49f7905d94af9b73f9bee22c26d7dd4a/.built_check
make -C "/home/vech/openwrt/build_dir/target-mipsel_24kc_musl/linux-ramips_mt7620/linux-4.14.95" KERNEL_DIR="/home/vech/openwrt/build_dir/target-                                                                                            mipsel_24kc_musl/linux-ramips_mt7620/linux-4.14.95" ARCH="mips" CROSS_COMPILE="mipsel-openwrt-linux-musl-" SUBDIRS="/home/vech/openwrt/build_dir/                                                                                            target-mipsel_24kc_musl/linux-ramips_mt7620/jool-9dfaf22e49f7905d94af9b73f9bee22c26d7dd4a/mod/stateful" V="s" modules
make[4]: Entering directory '/home/vech/openwrt/build_dir/target-mipsel_24kc_musl/linux-ramips_mt7620/linux-4.14.95'
  CC [M]  /home/vech/openwrt/build_dir/target-mipsel_24kc_musl/linux-ramips_mt7620/jool-9dfaf22e49f7905d94af9b73f9bee22c26d7dd4a/mod/stateful/fra                                                                                            gment_db.o
/home/vech/openwrt/build_dir/target-mipsel_24kc_musl/linux-ramips_mt7620/jool-9dfaf22e49f7905d94af9b73f9bee22c26d7dd4a/mod/stateful/fragment_db.c                                                                                            : In function 'inet6_hash_frag':
/home/vech/openwrt/build_dir/target-mipsel_24kc_musl/linux-ramips_mt7620/jool-9dfaf22e49f7905d94af9b73f9bee22c26d7dd4a/mod/stateful/fragment_db.c                                                                                            :96:14: error: 'INETFRAGS_HASHSZ' undeclared (first use in this function); did you mean 'INET_FRAG_LAST_IN'?
  return c & (INETFRAGS_HASHSZ - 1);
              ^~~~~~~~~~~~~~~~
              INET_FRAG_LAST_IN
/home/vech/openwrt/build_dir/target-mipsel_24kc_musl/linux-ramips_mt7620/jool-9dfaf22e49f7905d94af9b73f9bee22c26d7dd4a/mod/stateful/fragment_db.c                                                                                            :96:14: note: each undeclared identifier is reported only once for each function it appears in
/home/vech/openwrt/build_dir/target-mipsel_24kc_musl/linux-ramips_mt7620/jool-9dfaf22e49f7905d94af9b73f9bee22c26d7dd4a/mod/stateful/fragment_db.c                                                                                            :97:1: warning: control reaches end of non-void function [-Wreturn-type]
 }
 ^
scripts/Makefile.build:326: recipe for target '/home/vech/openwrt/build_dir/target-mipsel_24kc_musl/linux-ramips_mt7620/jool-9dfaf22e49f7905d94af                                                                                            9b73f9bee22c26d7dd4a/mod/stateful/fragment_db.o' failed
make[5]: *** [/home/vech/openwrt/build_dir/target-mipsel_24kc_musl/linux-ramips_mt7620/jool-9dfaf22e49f7905d94af9b73f9bee22c26d7dd4a/mod/stateful                                                                                            /fragment_db.o] Error 1
Makefile:1533: recipe for target '_module_/home/vech/openwrt/build_dir/target-mipsel_24kc_musl/linux-ramips_mt7620/jool-9dfaf22e49f7905d94af9b73f                                                                                            9bee22c26d7dd4a/mod/stateful' failed
make[4]: *** [_module_/home/vech/openwrt/build_dir/target-mipsel_24kc_musl/linux-ramips_mt7620/jool-9dfaf22e49f7905d94af9b73f9bee22c26d7dd4a/mod/                                                                                            stateful] Error 2
make[4]: Leaving directory '/home/vech/openwrt/build_dir/target-mipsel_24kc_musl/linux-ramips_mt7620/linux-4.14.95'
Makefile:113: recipe for target '/home/vech/openwrt/build_dir/target-mipsel_24kc_musl/linux-ramips_mt7620/jool-9dfaf22e49f7905d94af9b73f9bee22c26                                                                                            d7dd4a/.built' failed
make[3]: *** [/home/vech/openwrt/build_dir/target-mipsel_24kc_musl/linux-ramips_mt7620/jool-9dfaf22e49f7905d94af9b73f9bee22c26d7dd4a/.built] Erro                                                                                            r 2
make[3]: Leaving directory '/home/vech/openwrt/feeds/packages/net/jool'
time: package/feeds/packages/jool/compile#2.53#0.61#2.90
package/Makefile:107: recipe for target 'package/feeds/packages/jool/compile' failed
make[2]: *** [package/feeds/packages/jool/compile] Error 2
make[2]: Leaving directory '/home/vech/openwrt'
package/Makefile:103: recipe for target '/home/vech/openwrt/staging_dir/target-mipsel_24kc_musl/stamp/.package_compile' failed
make[1]: *** [/home/vech/openwrt/staging_dir/target-mipsel_24kc_musl/stamp/.package_compile] Error 2
make[1]: Leaving directory '/home/vech/openwrt'
/home/vech/openwrt/include/toplevel.mk:216: recipe for target 'world' failed
make: *** [world] Error 2

The kmod-jool module is enabled for compilation by default as "= m"


#2

Intentionally, or as “build all modules”? Recently a post here reported that module in the error messages from someone trying to build everything.


#3

No, compiled with default configuration

git clone https://git.openwrt.org/openwrt/openwrt.git/
cd openwrt
git checkout v18.06.2

./scripts/feeds update -a
./scripts/feeds install -a

wget https://downloads.openwrt.org/releases/18.06.2/targets/ramips/mt7620/config.seed -O ../config.seed

cp ../config.seed .config

make defconfig
make menuconfig
select Target profile = Nexx WT3020 (8MB)
uncheck Build the OpenWrt Image Builder
uncheck Build the OpenWrt SDK

make download
time ionice -c 3 nice -n19 make -j4

#4

You're trying to replicate a full-repo build for the buildbot on a local machine.

To get a "standard" build for your device, remove ./.config (or, if you're using ./env or the like to manage your local config cat /dev/null > .config to keep from removing the symlink), then run make menuconfig and select your target and device. Save your config, and that's the default package selection for your device.

See further


#5

deleted .config
run make menuconfig
chose architecture and router

~/openwrt$ ./scripts/diffconfig.sh |grep -v "^#\|^$"
CONFIG_TARGET_ramips=y
CONFIG_TARGET_ramips_mt7620=y
CONFIG_TARGET_ramips_mt7620_DEVICE_wt3020-8M=y

Run build make -j 4

Why is toolchain compiled again?


#6

Have you solve this compiling error? I met the same problem. How to solve it?
Thank you.


#7

seems fix needed