Bug which is solved by a reboot


I've been using open wrt on an AX6S since May 20, 2023.
Everything works well except that, for the second time, I have an Rsync service that leaves my network to connect to a remote server that fails to authenticate.
Both times the problem was solved by a simple reboot of the router.

I just tried to update the router but I see that there is no new version : OpenWrt 22.03.5 r20134-5f15225c1e

Question 1 : If it happens again, how can I try to diagnose? I haven't noticed anything else that doesn't work ?
Question 2 : I see that it is possible to launch CRON tasks. Is it relevant to set up a periodic reboot of the router?

Thanks in advance.

you can redirect the output of the rsync command to a file to test what actually does or fails

also check the $PATH $HOME variable

the possible options may be different

It's not fully clear to me whether rsync is running on OpenWrt or on another machine within your network.

If on OpenWrt, what I assume, how is it started? Manually? Periodically?

1 Like

Important detail indeed.

Rsync is executed by a NAS server on the network to contact another remote NAS. It is a periodic task (every day at 2 am, at a time when the router has not much else to do.

then how exactly is this related to openwrt ?

1 Like

The router is the source of the problem.
When there is a problem (2d times yesterday) just restart the router solve the connection problem.

then you need to provide more info than "it doesn't work ..."

1 Like

It is precisely the question of knowing how to diagnose the problem of the router when this connection becomes impossible and while all the other uses of the network seem to work well.

I do more or less the same: In my case, rsync is either tunelled through SSH or tunnelled through SSH and Wireguard. For my configuration, OpenWrt would be involved in the Wireguard tunnel and the DDNS setup, so these would be two potential sources of problems I would investigate in in case rsync wouldn't work. My rsync backup scripts provide very detailed logging to diagnose such problems.

Please provide some more details on how exactly your rsync setup works.

Did you try any other things - e.g. disconnect/reconnect of the NAS's network cable?

Argh, hard question.
I don't know what Rsync does. I go through the synology shared folder synchronization service.

On the Rsync server side, I only have the standard configuration of the nas synology Rsync file service. The only thing that is configurable is the SSH port, which I have set to non-standard

Hours and hours.
I looked through the synology logs and found nothing except connection error.
I then

rebooted the 2 nas,
updated the 2 nas
set up backups of the 2 nas
and many more
Then the simplest thing in the world I rebooted the router and hop it worked again.

Yesterday, the second time, I just rebooted the router and it worked again directly.

This sounds somewhat strange. I suppose you checked whether your internet connection was still working and the other system reachable before rebooting?

... or are those boxes local ?

yes, the remote server like all other uses of the network worked perfectly.
The first time Rsync was down for several days while I tried things and the remote server was perfectly accessible (excluding SSH) since I played with hours trying to solve the problem.

I didn't understand.

The first nas is on one local network of the openwrt router, the second is 400km from here on another network.

that would be a no then :wink:

1 Like

I no longer have any problems since I added this cron

50 1 * * * sleep 70 && touch /etc/banner && reboot