Bug in Dropbear [LuCI]

I just stumbled upon something buggy in Dropbear instance. I was not able to SSH into the router when I changed the interface from lan to unspecified. I thought I messed up some network configuration but after going through the configuration over and over again, couldn't find anything. So I reset my router and then when I changed the Dropbear config first from unspecified to lan (it worked) then lan to unspecified (and it stopped working again).

After that I decided to reflash my router and same thing is happening now. If I dont change the config for Dropbear, it's working okay, but I am not sure on which interface it actually is listening. But if you change the config to lan and then back to unspecified it does not let you SSH into the router anymore. You can only SSH from lan if you choose lan.

I have Tp-Link TD-W8980 V1 with v18.06.1 and latest packages, since I just flashed my router. Hopefully someone can shed some light on this behavior. Thanks

I can't recreate this in trunk. (well, it's unspecified by default and it doesn't include luci, so this bug would make access router impossible short of some serial port thing.

uci del dropbear.cfg014dd4.Interface

As you mentioned that I figured something else could cause the problem and here I figured it out. LuCI somehow doesn't delete the configuration line at all, it just adds 1 instead of deleting the Interface option.

Now that I saw this I suddenly remember that it's not just dropbear, it's everywhere, even in firewall config. For instance, if you create an input rule in firewall through LuCI, upon saving, you'll see that it will be listed as a Forward rule and the zone/interface will be listed as 1 instead of being empty or no option at all. This can cause problems in future if not fixed now.


Also for the firewall:

Working in 18.06.1:


root@OpenWrt:/etc/config# netstat -t -l -n | grep :22
tcp        0      0*               LISTEN
tcp        0      0 xxxx:xxxx:xxxx::1:22    :::*                    LISTEN 


root@OpenWrt:/etc/config# netstat -t -l -n | grep :22
tcp        0      0    *               LISTEN      
tcp        0      0 :::22                   :::*                    LISTEN

Are you sure that you're clicking "Save & Apply"?

@lleachii If you look at the pictures above you can see that when I save it from LuCI it puts 1 in place of Interface option, when it should just delete the line altogether. And it is not just Dropbear, same thing happens in firewall config if I add an input rule, it also puts 1 in interface option. I am not sure if this only happens to my router because I have no other device running on v18.06.1 so I cant test on other devices. But I can confirm that it doesnt happen on 17.01.X. Although if I use command line/ssh everything works normally and there is no problem.